samba public write access

I have the following for my smb.conf file.  And here is the ls -al for the /home/dgbc/share folder


dgbc@fileserver:~$ sudo ls -al share/
total 0
drwxr-xr-x 2  777 dgbc   6 2008-02-12 19:17 .
drwxr-xr-x 4 dgbc dgbc 173 2008-02-12 19:17 ..


[global]
; Uncomment this if you want a guest account
workgroup = DGB
guest account = nobody
log file = /var/log/samba-log.%m
lock directory = /var/lock/samba
share modes = yes
security = share
restrict anonymous = no
[public]
comment = Public Stuff
path = /home/dgbc/share
public = yes
writable = yes
printable = no
guest ok = yes
read only = no

Open in new window

casitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mjutrasCommented:
so whats the problem? There is no question...

Well right now I can see that everyone as not the write access on the folder in your ls -al command.

If you wanna have everyone the write, read and execute access on the folder run: sudo chmod -R 777 {folder} on the shared folder
0
mjutrasCommented:
remember that you need to set the permission in samba AND on the specific folder in your system, it's like the windows file sharing when you have to set the "security" options and the "sharing permissions"
0
casitAuthor Commented:
Ok here is my new ls -al after I deleted the folder and then recreated it.  What I want it public read access to this folder and also public write access.

dgbc@fileserver:~$ ls -al share/
total 0
drwxr-xr-x 2  777 dgbc   6 2008-02-12 21:36 .
drwxr-xr-x 4 dgbc dgbc 173 2008-02-12 21:36 ..

0
mjutrasCommented:
well you used the command chown instead of chmod as i can see because now the owner of the file/folder is 777
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
casitAuthor Commented:
Thanks.   I need to go to bed.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.