How do I resolve the procedure entry point SHRegGetValueW...SHLWAPI.dll error?

How do I get around this procedure entry point problem without the original Win 2K CD?

Beginning Wednesday the 13th after my PC automatically restarted after a Windows update I've been getting the error "The procedure entry point SHRegGetValueW could not be located in the dynamic link library SHLWAPI.dll". IE is one of the only programs that seems to be unaffected.

I first tried replacing SHLWAPI.dll with an older version but that resulted in no change. I then uninstalled the most recent update but that didn't change anything either. Then I tried Microsoft update and part of the update failed: KB110806 .NET Fremework 2.0 Service Pack 1 "A problem has been encountered while loading the setup components. Canceling setup."

I tried running sfc /scannow but I cannot find the Win 2000 CD that came with the PC so it would not continue. I've googled and found reference to Win XP with issues related to the error I'm getting, but not Win 2000 so far.

I tried restoring the registry with a good backup but could not due to the same procedure entry point error.

I'm running Windows 2000 Pro 5.00.2195 Service Pack 4 on a Dell Dimension 8200, Pentium 4 1.9 GHz.

Thank you.
jbodineAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nirmal SharmaSolution ArchitectCommented:
The entry point is missing - that means the current DLL which is being loaded by the application doesn't the proper function defined in it. You need to obtain the copy of DLL which has this function in it.

Use DLL parser to explore the DLL functions.
jbodineAuthor Commented:
Thanks for the suggestion. I've not used DLL parser before. Is it a downloadable utility?
Nirmal SharmaSolution ArchitectCommented:
Sorry, its DLL explorer:

http://www.tucows.com/preview/224165
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

jbodineAuthor Commented:
Thanks. I installed it and unfortunately when I try to run it I get the same procedure entry point message.
Nirmal SharmaSolution ArchitectCommented:
Does installing this resolve the issue? You need to explore the DLL function and check if it is conflicting wiht another one.
jbodineAuthor Commented:
Sorry, I wasn't clear in my last comment. I installed DLL explorer but can't use it due to the same procedure entry point error I receive when trying to run other programs. DLL explorer won't run on my machine in its current state. Any tricks to get around that?
Nirmal SharmaSolution ArchitectCommented:
try running SFC /scannow from safe mode. This should resolve this issue.
jbodineAuthor Commented:
Thanks, but that didn't work either. I ran sfc /scannow while in safe mode and received the message "Windows File Protection could not initiate a scan of protected system files. The specific error code is 0x00006ba [The RPC server is unavailable.]"
Nirmal SharmaSolution ArchitectCommented:
jbodineAuthor Commented:
Thanks again, but unfortunately it didn't work for me. I saw that article after I got the error on sfc in safe made. It requires that I run MMC but running MMC gives me "MMC cannot create a node manager. Make sure the file Mmcndmgr.dll is registered."

Then I tried registering mmcndmgr.dll with regsvr32 c:\winnt\system32\mmcndmgr.dll but that failed with "LoadLibrary("c:\winnt\system32\mmcndmgr.dll") failed - The specified procedure could not be found.".
jbodineAuthor Commented:
Problem solved. A friend loaned me a Win2K CD which allowed me to run sfc /scannow. One restart later and now I'm back in business and happy.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nirmal SharmaSolution ArchitectCommented:
ok.
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.