Link to home
Start Free TrialLog in
Avatar of NJT9
NJT9

asked on

XP automatic restart on access NAS share

Using QNAP TS209 NAS, just viewing  workgroup computers or clicking on share, XP pro reboots without BSOD,  despite autorestart being unchecked. No problem connecting to NAS with other XP pro or WIN2K machines on network. For first few times, event log showed Error ID 1003 code 1000007f but lately, no warnings at all in event log. Full Dell hardware diagnostic scan shows all ok and replacing memory, changing page file has no effect. Browser service appears to work fine and can find all machines with net view. However, if try to access share using UNC, same thing happens. Problem machine very similar to another on network, which works fine. Problem machine has some additional software such as Nero 8, I tunes, Citrix client. Help!
Avatar of kadadi_v
kadadi_v
Flag of India image

Check the Hard Disk Bad Sectors.........and upgrade your antivirus and scan the pc throughly and also  scan with spybot search & Destroy in advanced mode.

If not install the another PCI Network card and configure on the network and check...



Reards,

V.K.
Is there a dump file in c:\windows\minidump?

If so, post it here (rename to .txt).....
Avatar of NJT9
NJT9

ASKER

Thanks for your comments.

I have checked the partition with chkdsk /r and also rescanned the machine with Zone Alarm Security Suite 7, which has been installed since day1 - nothing found and no improvement.
Minidump file from a few days ago attached -although, as I mentioned, the restart is no longer (last 10 or so times) accompanied by a system error in the event log - and therefore no dump file.
One of Microsoft's 'related topics' for Error ID 1003 is a TCP/IP header corruption for which there is a suggested hotfix. However, this seems to relate to a diffferent error code.
Mini022708-02.txt
I agree with kadadi_v, try to change your NIC (the better if the NIC vendor would be different).

Avatar of NJT9

ASKER

The NIC is exactly the same one as in the other machines which work fine - a Broadcom integrated into the MB, so not sure if any mileage in plugging in another PCI NIC. However, the NIC and the BIOS in the problem machine are set for wake on LAN - do you think this could be causing it?
> do you think this could be causing it?

try to turn off and see what happens

> The NIC is exactly the same one as in the other machines which work fine - a Broadcom integrated into the MB

That's good, but in your case that maybe some problem in that special machine.
Can you install external PCI NIC and test NAS access again?
> XP pro reboots without BSOD

this points to the BIOS or hardware problem, so first try to turn off wakeup on lan,
that try to use another NIC (that's cheaper than to change motherboard).
Dump shows vsdatant.sys....

vsdatant.sys file information
http://www.file.net/process/vsdatant.sys.html

Uninstall Zonealarm..... And retry....
Make sure that driver is gone though, after the uninstall....
Avatar of NJT9

ASKER

Thanks all for your suggestions.

I first disabled wake on LAN in the BIOS and on the NIC - no change.
I disabled the NIC in setup and replaced it with a Netgear PCI NIC from another machine which does not show this problem, checked the config, etc.  - same result.
I did a clean uninstall of Zone Alarm ( I was going to do this anyway!) and checked vsdatant.sys absent -  ditto!

I think it must be significant that there is no error message and no BSOD despite autorestart disabled.
Also I wonder what the process is when you try to browse the share - there must be something about this that is causing the reboot. Could it be a  TCP/IP header / stack problem as previous post?
Avatar of NJT9

ASKER

Further to previous, I should mention that I checked for this fault again once Zone Alarm had been completely removed with the same result. I then installed Kaspersky firewall & av and ran a full scan on the machine. Nothing detected.
ASKER CERTIFIED SOLUTION
Avatar of NJT9
NJT9

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial