Link to home
Create AccountLog in
Avatar of jackjohnson44
jackjohnson44

asked on

.net deploy webservice

I created a webservice and am trying to deploy it to a local webserver.  I am publishing the files to a local directory and then copying them to my web directory.

here are some settings:
Scripts source access
read
write
directory browsing
scripts and executables
anonymous access
asp.net 2.0

Here is the error I am getting when I browse to my Service.asmx file.
-------------------------------------
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.
Parser Error Message: An error occurred loading a configuration file: Access to the path 'C:\Inetpub\wwwroot\OM\web.config' is denied.
Source Error:
[No relevant source lines]
Avatar of ZachSmith
ZachSmith
Flag of United States of America image

Make sure the users ASPNET and IIS_WPG have access to the directory where you're deploying the web service.
And when I say "access" I mean Windows file system access, not IIS access
Avatar of jackjohnson44
jackjohnson44

ASKER

Thanks, how do you do that?
Go to C:\Inetpub\wwwroot\ in Windows Explorer, right click the "OM" folder and go to "Properties". Click the "Security" tab, and add the users to the list.
Thanks, can you be a little more specific?
I go there, press ADD, tye in ASPNET, click OK
A new box pops up with a box that says "Correct this object information and search again"
I click OK, and it stays there.
Under "Select this object type" It says "Users, Groups, or Built-in security principals:
Under "From this location" it says my domain name.

What am I missing?
ASKER CERTIFIED SOLUTION
Avatar of ZachSmith
ZachSmith
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I did that, but still no luck, any other suggestions?  I also stopped and started the website incase that mattered.
You're not trying to write to the web.config are you?
no, I am not even using it, I am just trying to view my service.asmx file.  It is my webservice file, that should show all available functions.
Hey ZachSmith, thanks for your help.  I finally got it.  Apparently my computer is uses encryption based on the user, so I can open files, but the iis user can't since it is another user.  I had to manually unencrypt them to work.

thanks for your help
Wow - thanks for the update! That's an interesting problem you had!