Link to home
Start Free TrialLog in
Avatar of jcroy727
jcroy727Flag for United States of America

asked on

Office users lose keyboard functionality.

Users accessing Office 2003 through a Citrix session (PS 4) lose the ability to type in Word, Excel and Outlook. They have to close the program and go back in order for it to return. Has anyine else experienced this or similar problems? Thanks in advance for your help.
Avatar of Craig Roberds
Craig Roberds
Flag of United States of America image

Does it not work at all, or does it work for awhile and then quit?  Is this all users or just some?  And is this a published app or do you have a published desktop and then they click the app?  If it is published rather than a desktop is their a difference if you go to a desktop?  How about RDP?

I haven't seen this but I am trying to isolate when/how it could be happening.  If it's only on Office apps and it's all users maybe do a reinstall.
Avatar of jcroy727

ASKER

It works for a while and then quits. In excel specifically, if you minimize the window and re-ioen it, it works again for a while. It is some users, but the numbers are growing. It is a published application. I have not tested a published desktop or RDP yet.
Do you know if there are any timers set for inactivity or anything like that (usually in a GPO)?

Also I did find a rollup for Windows Server 2000 and Citrix PS 4.0 that had a number of Excel and Office issues.  Is your citrix server 2000 or 2003?  

If 2000 then you may want to look at rollup 3: http://support.citrix.com/article/CTX111414
and rollup 4:  http://support.citrix.com/article/CTX113483
No timers set in GP. Also, I should have mentioned this in the original post, but mouse functionality is never lost. It is only the keyboard.

My servers are all 2003, SP2.
You have just one citrix server?
3 Citrix servers on Presentation Server 4.
Assuming Office is published on all and you are load balanced is this happening on all 3 servers or can it be isolated to one?  I am assuming you have TS roaming profiles stored on a share?
You are correct. It occurs on at least 2 of the servers from my experience so far. It is also happening to users who use strictly the ICA Web client and users accessing the farm via the Program Neighborhood. So that doesn't appear to be the cause either. I am running the latest Citrix client as well. And just to add some additional confusion to the issue, 1 user mentioned to me today that this is happening to him in applications other than office as well.
SOLUTION
Avatar of Craig Roberds
Craig Roberds
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I will definitely try your recommendations. I am seeing a lot of paging file alarms in resource manager. For all 3 servers. It seems that this number increases throughout the day. I am starting to think that the farm may just be overloaded and the servers resources degrade throughout the day. In your experience, could this be a possibility?
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
THank you for all of your suggestions. It turned out that this was a rather simple issue. Too many users on too few servers. The servers were overloaded. Once I added 1 more server to the mix and the number of users connected to each decreased, these issues went away. Thank you again for your help.