Link to home
Start Free TrialLog in
Avatar of Dwight Baer
Dwight BaerFlag for Canada

asked on

How to start the Print Spooler Service in Vista Premium

I'm trying to add a network printer to a brand-new Dell workstation.  The error message comes up, "Cannnot add the printer because the Print Spooler Service isn't started".
Sure enough, in Services, the Print Spooler service is stopped.  But it doesn't allow me to start it - right-click doesn't work.
ASKER CERTIFIED SOLUTION
Avatar of tboy6423
tboy6423
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Dwight Baer

ASKER

First of all, when I came to the machine the print spooler service was running.
Then I tried to add a network printer.  (The printer is shared, on a machine in the same workgroup.)  I got the following message:
"Windows cannot connect to the printer.  The local print spooler service is not running.  Please restart the spooler or restart the machine."
Then I see a window with the following error message:
`Spooler Subsystem App stopped working and was closed.  A problem caused the application to stop working correctly. Windows will notify you if a solution is available.``

What I mean, `Right Click doesn`t work is:  I`m looking at the Services from within the MSConfig window.  Right-click doesn`t work here.  What is the proper way to configure Services in Vista.
OK ... I tried to add this printer from a different Vista machine.  Same error.  Let`s call the machine VistaPrintServer1 where I have the printer shared.  Let`s say I`ve tried to access that printer from VistaPrintClient1 and VistaPrintClient2.

Then I shared a printer on a different machine, let`s call it VistaPrintServer2.  I tried to add it on VistaPrintClient1.  Same error.  Yikes!  What am I missing.
(I hate Vista!)
Just for grins, I shared a folder on VistaPrintServer1.  And I was able to successfully map a drive to that folder on VistaPrintClient1.

Just for more grins, I turned on the Guest account on VistaPrintServer1.

I checked in the Network Sharing Center.  The following are all turned on:  Network Discovery (On);  File Sharing (On);  Public Folder Sharing (On, Read Only, Password Required);  Printer Sharing (On;  password required);  Password Protected Sharing (On);    Media Sharing is Off.

I double-checked:  All machines are in the Workgroup workgroup.  
For clarification:  The settings listed above for the Network Sharing Center are the same for both VistaPrintServer1 and VistaPrintClient1.
Starting to get desperate now.  I physically moved the printer to VistaPrintClient1`s desk.  I used the AutoRun on the printer CD (it`s an HP LaserJet 1022) to install the drivers.  Everything seemed to be fine until the very end of the process, when it said:   Operation could not be completed (error 0x00000015).  The device is not ready.
Now I`m downloading the latest Windows Vista drivers for the LaserJet 1022 from the HP site.
OK, I figured it out.
After I installed the printer using the latest Windows Vista driver from HP, I can now share it out.
Funny how with the older drivers the printer worked fine when accessed locally, but produced all kinds of weird errors when accessed across the network.
Thanks for your help, tboy6423!  I`ll give you all the points even though I solved this myself.  Who knows when you`ll see my name come up again!
I am glad you figured it out! Have a great week!
Avatar of jonflux
jonflux

There is another cause for this error. If you have ever had a lexmark printer driver (which may also have been installed with a non-Lexmark printer, like a Dell) then you will find a small program called LexBce. This is usually a service and can be found under Control Panel->Services. LexBce needs to also be running before Print Spooler will run. I hope this helps someone else. It took me hours to resolve this problem :-)

Thank you guy from another page.