Link to home
Start Free TrialLog in
Avatar of mihaisz
mihaiszFlag for Afghanistan

asked on

Exchange 2007 Autodiscover Service problems

I followed the steps from http://technet.microsoft.com/en-us/library/bb332063.aspx to configure the Autodiscover Service.
I installed Windows Certificate Services and created my own SSL certificate that includes multiple DNS names.

At the end, when I test the result with:

Test-OutlookWebServices -identity test1 | Format-List

I am getting the following response:

Id      : 1016 Type    : Success
Message : [EXCH]-Successfully contacted the AS service at https://exch-mbs.mbs.local/EWS/Exchange.asmx. The elapsed time was 62 milliseconds.

Id      : 1015 Type    : Information
Message : [EXCH]-The OAB is not configured for this user.

Id      : 1014 Type    : Success
Message : [EXCH]-Successfully contacted the UM service at https://exch-mbs.mbs.local/UnifiedMessaging/Service.asmx. The elapsed time was 15 milliseconds.

Id      : 1013 Type    : Error
Message : When contacting https://mail.mydomain.com/EWS/Exchange.asmx received the error Unable to connect to the remote server

Id      : 1013 Type    : Error
Message : When contacting https://mail.mydomain.com/EWS/Exchange.asmx received the error No connection could be made because the target machine actively refused it 207.......4:443

Id      : 1016  Type    : Error
Message : [EXPR]-Error when contacting the AS service at https://mail.mydomain.com/EWS/Exchange.asmx. The elapsed time was 890 milliseconds.

Id      : 1015 Type    : Information
Message : [EXPR]-The OAB is not configured for this user.

Id      : 1013 Type    : Error
Message : When contacting https://mail.mydomain.com/UnifiedMessaging/Service.asmx received the error Unable to connect to the remote server

Id      : 1013 Type    : Error
Message : When contacting https://mail.mydomain.com/UnifiedMessaging/Service.asmx received the error No connection could be made because the target machine actively refused it 207.......4:443

Id      : 1014 Type    : Error
Message : [EXPR]-Error when contacting the UM service at https://mail.mydomain.com/UnifiedMessaging/Service.asmx. The elapsed time was 968 milliseconds.

Id      : 1013 Type    : Error
Message : When contacting https://mail.mydomain.com/Rpc received the error  Unable to connect to the remote server

Id      : 1013 Type    : Error
Message : When contacting https://mail.mydomain.com/Rpc received the error  No connection could be made because the target machine actively refused it 207.......4:443

Id      : 1017 Type    : Error
Message : [EXPR]-Error when contacting the RPC/HTTP service at https://mail.mydomain.com/Rpc. The elapsed time was 78 milliseconds.


How can I fix all these?

Avatar of Matthew Millers
Matthew Millers
Flag of Australia image

Is mail.mydomain.com resolving properly (to an internal address)?
Are you running any firewall on the exchange server, transit networks etc etc
Avatar of mihaisz

ASKER

mail.mydomain.com resolves to an external IP (207.....4) that has the ports forwarded by the firewall to 192.168.x.95. The firewall is between the Exchange server and the Internet, so it's not on the Exchange box.

The other Exchange features work well on that box (POP3 / SMTP, OWA). It's the Outlook Anywhere I'm having difficulties with.
My Outlook from home is connected to the server via POP3/SMTP. I just wanted to use the Outlook Anywhere connection instead.
ASKER CERTIFIED SOLUTION
Avatar of mihaisz
mihaisz
Flag of Afghanistan image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of RajarshiVaibhav Pandey
Did you check whether the connections are being dropped on firewall or not?
Avatar of mihaisz

ASKER

I don't really know how to do that since it's an OpenBSD firewall.
Exchange seems to be working now so I just assume the test above is irrelevant.