Link to home
Start Free TrialLog in
Avatar of matthewhamer
matthewhamerFlag for United Kingdom of Great Britain and Northern Ireland

asked on

NO OS appears on Xenix machine

Hi

Sadly I'm more of a Windows man and have a slight issue.

A tiny 234MB hard disk on an old machine believed to be running Xenix suffered a mechanical fault. I had the disk repaired by a lab and copied it onto a new disk. I have no reinstall or boot disks anywhere to be seen.

Now I have the new disk back with old data on, I've replaced it back in the machine and have a "NO OS" error. The new disk is an 80Gig disk with just the original 234MB partition on (oh what a waste..!)

I found this link http://docsrv.sco.com:507/en/HANDBOOK/sstT.no_os.html which looks like the solution.

Boot disk wise, I downloaded RIP, as well as this image
http://aplawrence.com/SCOFAQ/FAQ_scotec1downloadboot.html
ftp://ftp.caldera.com/pub/EFS/efs132.n1.Z Xenix 2.3.4 386 ISA 3.5"

Am I on the right track here?

I've cloned the hard disk before I began but is this the correct way forward?

Thanks!
Avatar of yuzh
yuzh

You can try to fix the boot blocks  for your new HD to make it boot, to see if it work.

Do you know how they copy the data across?  It is important to know
how they copy the data to the new HD, in case you have problem and need help. because the filesystem much be the same type of the original  Xenix  kernel can support, not something like NTFS (windows
XP filesystem)!
a) How did you clone the hard disk?
b) The boot blocks are either missing or corrupt. This happens nearly 100%
    when the physical structure of your (target) disk is not identical to your
    original (source) disk.
    The web page http://docsrv.sco.com:507/en/HANDBOOK/sstT.no_os.html
    describes how to fix this
Avatar of matthewhamer

ASKER

hi yuzh and justUNIX

The data recovery was done by a 3rd party company who said they had to open the disk. They also reported that the last 2MB on the disk was unrecoverable but everything else was intact.

Although I am not 100%, I would hope they did a byte for byte copy. I have viewed the partition structure of the disk and there is just one 234MB partition with 70+GB unallocated.

I tried the RIP linux boot disk but when I entered the hd(40)unix command, it said image not found. I appreciate though that that was a linux rescue disk, not unix.

I have this image:

ftp://ftp.caldera.com/pub/EFS/efs132.n1.Z 
Xenix 2.3.4 386 ISA 3.5"

But how can I write that out to a floppy?

Thank you!!!
additional - the FS shows as Xenix Root
a) FS type look good !
b) The boot disk image for floppy is ftp://ftp.caldera.com/pub/SLS/xnx264.n1.Z
    What disk adapter do you have?
c) To copy the file onto floppy:
    a) put it into some temporary directory
    b) Uncompress it with "uncompress xnx264.n1.Z"
    c) Copy the image onto floppy with "cp xnx264.n1.Z /dev/floppy"
        Substitute /dev/floppy with your floppy drive's real device name (some
        Unix/Linux variants use something like /dev/fd0 of /dev/fd0c
correction: copy with "cp xnx264.n1 /dev/floppy"
If you don't have Unix (or Solaris) on any PC available, use this on Windows:
a) Open the *.Z file with some packer (winzip, winrar or the like) and extract xnx264.n1
b) Use the program "rawrite2.exe" on Windows (in a DOS box) to copy that file onto floppy disk
    You can download from many locations, inlcuding http://www.tux.org/pub/dos/rawrite/
Thank you!! I will need to prepare the floppy on a Windows machine....is the xnx264.n1 some sort of raw image file that I can write with something like WinImage?

Or will I need to get the floppycp.exe a quick googling has brought up??

Thanks again!!!!!
Thanks again!

Here's hoping the floppy drive still works! ha!!

Thanks, I'm not onsite with this customer today but I will report back soon and dish out the points

:D
WinImage should do as well ;-)
I'm just trying this boot disk now after ra-writing it.

After about 30 mins or so I just had a screen full of Es!! Now I know floppy drives are slow, but....!! Have rebooted it and tried a different disk with the same image on it.

Is this possibly the wrong boot disk, or do you just think the floppy disk drive is goosed???

Thanks!
Additional:

Have burned the image onto a CD! Just to make sure the FDD wasn't goosed.

The same thing is happeninng, but the Es are appearing faster....(!) It seems to go through about 8 e's at a time, then 8 more appear.... eeeeeee !!

Is a different image advisable? And if so, which one? The machine in question is a bog standard Dell business machine from about 10 years ago, presumably it previously had Windows on and then had the system reinstalled.
Maybe this is NOT (?) the correct image for you hardware.
Unfortunately, by that time (long ago) only very (!) limited hardware support
was available and due to the very small size of a floppy disk, only very few
driver did fit on the floppy. Therefore, many different floppies did exist for
different PC hardware (especially disk drivers).
I see!!

I didn't realise how old we were talking. That would explain why this 10 year old PC that it's currently running on, the CPU is set to run in "compatible" mode?? And why it has only a 234MB hard disk...

Are there any further images you suggest I could try to boot this machine?
The only suggestion I can leave you with is to search (Yahoo, Google, ...) for boot disk images
Unfortunately, I don't have any of the old stuff left -- only some 5 1/4" floppies for Xenix in my
garage (buried under some piles of old computer stuff).
I have been googling it for quite a while today now but am not having much luck...

I did find this thread which is a remarkably similar situation

http://ubuntuforums.org/showthread.php?t=593180

Also this link appears to be along the lines of what I'm trying to do

http://virtuallyfun.blogspot.com/2007/05/running-xenix-on-qemu.html

Perhaps these chaps may know...unless you fancy a raid through your garage! And if there's a working 5.25" drive anywhere in the world....

How viable is mounting the drive under linux and trying to run the database program? ...not very, I'd guess?
Your comment reminid me that Xenix is too old and hard to find a PC can run it these days.  The last time I seen an Xenix box is running on a 386 (or a 486).  I remember SCO 3.2 was having trouble to run on a P2 with 2.1GB IDE hard drive, it cause "double kernel panic, and SCO 3.2 is newer than Xenix.

I suggest you to use a SCO box or a Linux box to mount the hard drive and transfer the data accross.

SCO is getting out of the martket, consider migrate your OS to Solaris 10 x 86 (Free and and lot better than Linux).

All the best and good luck!
I doubt Linux will be able to read the file system (plain old Unix System III) on your disk.

You may be able to mount it from SCO Unix (old version -- NOT "Open Server")  or from
Interactive Unix (http://en.wikipedia.org/wiki/INTERACTIVE_UNIX).
The problem is that it's likely hard to find supported hardware for it.
I've just recently (about a year ago) tried to install Interactive Unix in VMware -- but
failed as the hard disk controller does not match. Even Old VMwar 4.x did not work :-(
What a can of worms I've opened!

I tried imaging the hard disk and loading it as a virtual disk in M$ virtual PC. although this sort of worked, the boot disk i was using from ultimate boot cd had 3 linux boot options. I tried all 3 to mount the device. 2 reported xenix FS not supported and one insisted the partition wasn't there at all.

The physical machine is a Celeron 350 stepped down into "compatible mode", along with 128MB RAM and using onboard IDE.

So, now I'm thinking, download Solaris, run on virtual PC and try to mount it ? Then if everything looks good, file structure in tact etc, try to run the db program?? will it run???

then if that doesn't work, try and somehow track down an old SCO Unix/Interactive UNIX and rebuild the old box as a last resort?

thank you all again!
ASKER CERTIFIED SOLUTION
Avatar of Hanno P.S.
Hanno P.S.
Flag of Germany image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thanks! Will report back soon...!