Link to home
Create AccountLog in
Avatar of shekharbasnet
shekharbasnet

asked on

cisco cmts pppoe client not reacble from outside

hi all experts

i have a very wierd problem. i have a cisco router ubr 7246 with cable modems connected. the cable modems are also from cisco ubr920. customer connect their PCs to the cable modems. i have pppoe over cable configured on router ubr7246. pppoe is successful and the customers are assigned public IPs from the radius server. customer can ping to the router and the router is able to ping to the customer ip. but customer cannot ping to any other ip beyond the router.

when i trace to the customer ip , the trace reaches to the router ubr7246 and times out after that. when i do a "show ip route customer_ip" from the neighbor routers of the ubr7246, the route is seen to be coming from the ubr7246. but still i cannot ping to the customer ip.

when i clear route in ubr7246 then one single ping takes place and times out after that. when i clear ospf in ubr7246 same thing happens. just one ping. when i do a continuous ping to that ip and then only establish the pppoe session, the same thing happens. one single instance of ping happens when the pppoe is established and then nothing after that.

so while troubleshooting i moved pppoe from cable to ethernet interface. the customer ip could be pinged when the pppoe is done on the ethernet interface.

its very baffling. is there some special command to be added when pppoe is done over cable interface? is it a pppoe problem or a routing problem i am not able to understand...

tia
shekhar basnet
Avatar of shekharbasnet
shekharbasnet

ASKER

some relevant config



ip dhcp smart-relay
ip dhcp relay information option
!
ip dhcp pool cm-platinum
   network 172.16.0.0 255.255.0.0
   bootfile platinum.cm
   next-server 172.16.0.1
   default-router 172.16.0.1
   option 7 ip 172.16.0.1
   option 4 ip 172.16.0.1
   option 2 hex ffff.8f80
   lease 7 0 10
!
vpdn enable
no vpdn logging
!
vpdn-group gyanu
 accept-dialin
  protocol pppoe
  virtual-template 10
 lcp renegotiation always
!
!
!
!
interface Loopback0
 ip address x.x.x.140 255.255.255.255
 no ip route-cache
 no ip mroute-cache
!
interface Loopback10
 ip address 10.13.13.13 255.255.255.255
!
interface Loopback50
 no ip address
!
interface FastEthernet0/0
 ip address x.x.x.239 255.255.255.224
 ip ospf message-digest-key 1 md5 xxxxxxxxx
 full-duplex
!
interface Cable3/0
 ip address 172.16.0.1 255.255.0.0
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 476000000
 cable upstream 0 frequency 23008000
 cable upstream 0 power-level 0
 cable upstream 0 power-adjust continue 15
 cable upstream 0 modulation-profile 3
 no cable upstream 0 shutdown
 no cable upstream 1 shutdown
 no cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable helper-address 172.16.0.1 cable-modem
 pppoe enable
!
!
interface Virtual-Template10
 ip unnumbered Loopback10
 ip mtu 1492
 no peer default ip address
 ppp authentication pap
!
router ospf 1
 log-adjacency-changes
 area 0 authentication message-digest
 redistribute connected subnets
 redistribute static subnets
 network x.x.x.140 0.0.0.0 area 0
 network x.x.x.239 0.0.0.0 area 0
 distribute-list prefix myprefix out
!
ip classless
no ip http server
ip tacacs source-interface Loopback0
ip ospf name-lookup
!
!
ip prefix-list myprefix seq 5 permit x.x.224.0/19 ge 20
never mind.
after adding "ip cef" to the router, everything is normal and working fine.
s
mod pls close and refund.
tx
s
ASKER CERTIFIED SOLUTION
Avatar of EE_AutoDeleter
EE_AutoDeleter

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
shekharbasnet  Do you still operate a Cisco UBR7246?  I too am trying to do an ucommon PPPoE service over docsis, and could use some pointers if you have any.

Currently I'm trying too see if any radius attributes can control speeds at the  PPPoE layer instead of customizing the cable modem.   Trying a generic cable modem configuration approach, and control the rest within PPPoE.

Anyone else with input greatly appreciated as well.

-=Kreg