Link to home
Start Free TrialLog in
Avatar of isd721
isd721

asked on

Snap-In Creation Failed when accessing GPO mmc

When accessing Group Policy Object Editor I get the following error:  
Snap-In Creation Failed.  
The snap-in is not created, it may not be installed properly.
Name:  Group Policy Object Editor
CLSID:{8FC0B734-A0E1-11D1-A7D3-0000F87571E3}

I uninstalled and reinstalled Adminpak, but it didn't seem to remove the Group Policy Management snap-in.  I also removed gpmc from \Windows\System32, when opening Group Policy Managment again it put the file back in system32, but with the same problems.

This snap-in did work at one point in time.  Thanks in advance for the help!
ASKER CERTIFIED SOLUTION
Avatar of Pber
Pber
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of rehanahmeds
rehanahmeds

Another way to help with the problem in the mean time is to create your own MMC.

Start, Run, MMC
File, Add/Remove Snap-in...
Click Add, then select Active Directory Users and Computers and click add again, then close
Now Click the Extensions TAB
Uncheck Add all extensions
Now, unselect the Group Policy Object Helper and click ok.

(Leave the Group Policy Management Helper as the CLSID error you got was only for the object helper).

This can at least get you up and running with AD Users and Computers until the problem is fixed.
Avatar of isd721

ASKER

I did just try uninstalling and reinstalling GPMC, but no luck.  I tried that Microsoft KB yesterday, but that didn't work. I will try the last comment to atleast get up and running.
Avatar of isd721

ASKER

Just read your comment in full.  I'm not having any problems with AD Users and Computers, just the Group Policy Management.  I can add/remove users successfully.
when are you getting this error?? how are you trying to access it??
if you dont have any service pack installed then there is another hotfix for that

http://support.microsoft.com/kb/887698
Avatar of isd721

ASKER

This error doesn't occur on the server.  I try to access it using Group Policy Management on my laptop.  GPM opens fine, but once I try to edit a GPO I get the error.  I am also not able to create new GPOs.  When trying to create a new GPO I get the following error:  The specified object could not be found
have you checked its setting on the server

Group Policy Object Editor
USER Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy

here is the description of this setting:

Permits or prohibits use of this snap-in. If you enable this setting, the snap-in is permitted. If you disable the setting, the snap-in is prohibited. If this setting is not configured, the setting of the Restrict users to the explicitly permitted list of snap-ins setting determines whether this snap-in is permitted or prohibited
i forgot to ask... what windows version you are using on your laptop?? XP SP2 or anyother?
Avatar of isd721

ASKER

I am running XP SP2.  I looked into the Group Policy Object Editor setting and it is set to Not Defined.  I did change it to enable, but still no change (I did refresh the policy).  This was under the Default Domain Policy.  However, I don't think this is the cause because that setting has always been set that way and it did work for me before.  Also, it is working for another user on a different laptop.
Sometimes an uninstall/reinstall of the Adminpak breaks things. Reregister
the needed Dlls on Windows Xp.

"regsvr32 <Dll name that needs to be registered>"

ieaksie.dll - for IE Maintenance policies

Dlls that needs to be registered for the GPO

scecli.dll
fdeploy.dll
fde.dll - for Folder Redirection
dskquota.dll - for Disk Quota Policy
gptext.dll - Responsible for Scripts and admin templates
iedkcs32.dll
appmgmts.dll
appmgr.dll - for Software Installation policy
gpedit.dll
wsecedit.dll - for security settings
ipsecsnp.dll - for IPSec policy
certmgr.dll - for Public key policy
rigpsnap.dll - Remote Installation Service Policy Snap-in

304718 Administering Windows Server-Based Computers Using Windows XP
http://support.microsoft.com/?id=304718
Avatar of isd721

ASKER

I did reregister those DLLs.  I received the following error msg on 3 DLLs

1.  appmgmts.dll loaded, entry point not found
2.  Load Library (appmgr.dll) failed.  Module could not be found
3.  Load Library (gpedit.dll) failed.  Module could not be found

Same problem after DLLs were reregistered with the above errors.

Does AdminPak install the snapin for Group Policy Management?  Or is that a separate installation (gpmc.msi)?  At any rate, I had reinstalled both.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
and GPMC you have to install seperately...
Avatar of isd721

ASKER

I am using the old one.  Our DC is SP1
you can try it... if not then try adminpak of SP1... if you are using of windows 2003 then thats quite old...

http://www.microsoft.com/downloads/details.aspx?FamilyID=E487F885-F0C7-436A-A392-25793A25BAD7&displaylang=en
Avatar of isd721

ASKER

I finally just broke down and decided to reinstall the OS on my laptop.  As expected, that resolved the issue.  Thanks for all your help!