Link to home
Start Free TrialLog in
Avatar of Deadcats
DeadcatsFlag for United States of America

asked on

Windows 2000 and Access 97

I have a customer who has Windows Server 2000.  As most of you know I have a program that runs off of an Access97 runtime  ( and an alternate one that uses Access XP).  The problem is it just will not install.  It does not give any error messages just at the end it says that .... was not installed successfully.  I am using Windows Installer and i have successfully installed on many of operating systems including Windows 2000 and Windows 2000 server.  I have a computer with Windows 2000 and once I got the CD I sent him I was able to duplicate this issue.  The strange thing now is that I cannot install any other CD but before I installed this one CD I could install my program.

Things I have done to try to fix this.
disabled SFC w/ registry tweak ffffff9d
deleted or renamed FM20.dll, Oleaut32.dll, Olepro32.dll, hlink.dll (these are all problems I have had in the past)
Deleted the registry entry for vba332.dll
Deleted the registry entry for my program
Deleted the folder that gets installed onto the C drive
Repair install of Windows 2k

I am going to go through and delete every file my CD installs but if anyone has anything else please let me know.  

Completely reinstalling Windows 2k is not an option yet.
Avatar of Deadcats
Deadcats
Flag of United States of America image

ASKER

FYI.  This is a brand new install of Windows 2000 that I am working with.  It does not have anything on it except for Windows.  
Avatar of clarkscott
Is a later version of Office installed on the PC?
If so, there's a Word font issue that's causing the problem.
I forget which one it is, but you will have to rename the Font (reference file title) on your drive and re-install Access 97.

If you look up (google) Install Multiple Version of Access, you'll find the instructions.  it's not hard.... just a pain in the butt.

Scott C
Here is the solution.....
When you try to install Access 97, you have to avoid the "Microsoft Access can't start because there is no license for it on this machine" error message caused by the presence of the Hatten font, which is installed by Access 2000 and Office 2000. Also, if the Access 97 installation finds a newer version of the Msaccess.exe file on the computer, it will not install the 97 version of the Msaccess.exe file.
1. Click Start, point to Find, and then click Files or Folders.
2. Find the Hatten.ttf file, and then rename it to Hatten.sav. You must do this to avoid the "Microsoft Access can't start because there is no license for it on this machine" error message when you start Access 97.

NOTE: You can find the Hatten.ttf file in the Fonts folder under the name, Haettenschweiler.
3. Find the existing version of the Msaccess.exe file, and then rename it to Msaccess.2k. Before you rename it, confirm that the version of the Msaccess.exe file is 9.0x by right-clicking the file, and then clicking Properties. Then click the Version tab
4. Install Access 97 or Office 97.
5. When prompted, click Change Directory to install Access 97 in a folder other than the folder in which Access 2000 is installed. For example, install the program in a folder named C:\Program Files\Microsoft Office97\.
6. After the installation is finished, find the Msaccess.2k file and rename it back to Msaccess.exe. Also, find the Hatten.sav file and rename it back to Hatten.ttf.  


Scott C
Hi Scott C
This did not work.  As I said the only thing that is installed on this computer is WIndows.  There are no other versions of Office installed on it.  However, I did try as your post suggested (I had seen this before but w/o having Office 2000 installed I figured it would not help) but still at the end of the installation it just says that it was not completed successfully.  There are no errors and nothing is in the event log.  

Thanks for the idea.
Now here is something strange.

I reformatted the HD and installed Windows 2000 again.  This time I made a backup of the register and a complete backup of the system.  I then installed the disk that breaks it and again it broke it.  I then deleted the folder it creates and loaded the Backup of the system.  I tried to load the CD that does work and this is now failing.  Currently I am redoing the restore and then I am going to restore the registry even though I think it is already restored with the backup.  

So if I have a clean install of Windows 2000 and I install my program with the CD that works everything is fine.  However, if I first install the CD that does not work then no other CDs work even after doing a full system restore.   I will update w/ any progress I have.
Well I think I have figured out the problem however I do not know the solution.  The problem on the CD that never installs I have version 5.1 of oleaut32.dll this should have been version 2.4.  

Now I am not sure what is going on because even after I install SFC puts version 2.4 back into the system and says the install fails.  I agree w/ this. However why is it when I take a good cd ie one that has oleaut32.dll version 2.4 and try to install it does it now fail?  

I have tried replacing oleaut32 with inuse.exe  and it did it after shutting off WFP but still when I try to install with the good CD it still fails.  
I am not sure if this will help anyone but I installed Office 97 pro and when I try to open Access it opens to the quick start wizard or whatever you want to call him.  As soon as I click start using Access now it closes out of Access.  
ASKER CERTIFIED SOLUTION
Avatar of Deadcats
Deadcats
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I found that the temporary installation folder was the issue I deleted it and everything works like it should thank you everyone.
Avatar of modus_operandi
modus_operandi

Closed, 500 points refunded.
modus_operandi
EE Moderator