Link to home
Start Free TrialLog in
Avatar of Bkrull
Bkrull

asked on

Error 8017 using NTBackup

Hello all,

I am trying to run a backup, via NTBackup, using a USB HP Storageworks DAT 72 drive on Server 2003.  However, I get the following error message in the backup logs:

Backup Status
Operation: Backup
Active backup destination: 4mm DDS
Media name: "SERVER"

The device reported an error on a request to MS_UpdateNtmsOmidInfo.
Error reported: 5.
There may be a hardware or media problem.
Please check the system event log for relevant failures.
An inconsistency was encountered on the media in 4mm DDS. Do not append to this media.
The operation was ended.
Backup completed on 3/4/2008 at 10:57 AM.
Directories: 0
Files: 0
Bytes: 0
Time:  1 second

Error: C: is not a valid drive, or you do not have access.


----------------------

The operation did not successfully complete.

----------------------

I also get the same error in the Event log (8017).  I am logged in as admin and have tried new tapes.  
Avatar of bandyt1712
bandyt1712
Flag of Germany image

Avatar of Bkrull
Bkrull

ASKER

Thanks for your reply Andy,

I've tried the suggestions already...I dont have 'Allow service...' checked under the RPC service, I dont have BackupExec installed, I'm running NTBackup under administrator and I'm using Server 2003 with SP2.  I've been burning up google over the past couple of days over this.

I have ruled out problems with the tapes and backup unit.  I can connect the backup drive to an XP station and it works fine.  However, I have tried the same unit on 2 Server 2003 SP2 installs and it fails.  I also know the backup unit was working on these servers when they had SP1.  Finally, I can backup to a file on these servers.

I've searched for problems with 2003 SP2 and the backup unit but cant find anything.
Avatar of Bkrull

ASKER

Also, I have the latest firmware and drivers installed for the HP DAT drive.
What's about the VIA Chipset? Do you have a main board with VIA?

If you have a VIA Chipset then you will need to get the lasted bios & driver upgrades for that chipset. The driver upgrade would be the IDE Miniport driver v3.20b. If you do not have the VIA chipset then you will need to check the Chipset Manufactures website that you have for the latest upgrades.

And if this won't work ... we have to google again.

Is the user wich runs the backup member of the "Backup operator" group?
As some articl states, this is a problem at writing the tape label. When it is not an dll or hardware problem, then it will be quiet shure a permission problem. When all above tries don't work, we may try to give everyone the backup rights.

Good luck

Andy
Some other hints I found states that you should use UNC paths and not mapped drives and double check all permissions of the volumes / directories to backup.
Avatar of Bkrull

ASKER

I'm using an HP Proliant server.  I tried the same backup on other Proliant servers and it worked.  My best guess is this problem has something to do with SP2 and\or the permissions are too restrictive on these servers, even though I am running the backup as Administrator.

I've tried backing up a folder to tape that has full access for everyone, no go.  But I can back up the same folder via a file backup.  

It tends to point to the server not communicating with the tape drive, but I know the tape drive works on other servers.  I also know I get the same error on three other servers that were just updated to SP2.
I don't think now that the permissions are to low. As you stated you tried the backup as admin.

I'am afraid that MS messed up something with the SP2. The only chance to isolate the
problem is to make a backup on an unpatched server, install SP2 and try the backup again. If that doesn't work, you may open an issue at MS. May be they have a problem
with the RPC service in this SP,

Sorry that I couldn't help you.

Andy
Avatar of Bkrull

ASKER

Thanks for trying Andy.  I'm now getting the following message in the System Event logs:

Event ID: 115
RSM cannot identify media because a fatal error occurred while trying to load the Media Label Libraries.


The MLL files (MLL_HP, MLL_MTF; MLL_QIF) are located in Windows\System32, where the registry is pointing to.  
Hi,

have this files the appropriate  rights? Are the files equal to the files on machines without SP?
You may also ask HP for support. May be they have to address this after SP rollout.

Andy
ASKER CERTIFIED SOLUTION
Avatar of Bkrull
Bkrull

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Just a quick note that the key value (type of key needs to be of STRING value)  then name of the actual key is "RunAS" and the value for that key is "NT Authority\LocalService"


I point that out because there is 2 backslashes in the answer and it does not state what kind of key to put it in as :)