Link to home
Start Free TrialLog in
Avatar of Shain Allen
Shain AllenFlag for United States of America

asked on

Backup Exec 12 services failed to start

I have 5 servers with that i upgraded from BackupExec v.11d to v.12. one was a new install. 2 of the installs failed to start the appropriate services. i have attached a file with the errors. I've check all  of the dependant services and they are all up and running. On one of the servers i've uninstalled v.12 (a clean install which includes uninstalling SQL Server Express) and reinstalled it several times but each time i get the same errors.
SymantecAV-Errors.pdf
Avatar of honmapog
honmapog
Flag of Ireland image

If you can't start the Device and Media service there are a few steps to take that should solve your problem in 80% of the cases (below is information specific to Backup Exec 11d - but should be identical with BE12.
1. Make sure the SQL Server (BKUPEXEC) is started - if not try &  start. If it fails to start, troubleshoot SQL using Windows event logs and SQL error logs.

2. Make sure the Backup Exec database files still exist. By default they should be the following files:
C:\Program files\Symantec\Backup Exec\Data\BEDB_dat.mdf
C:\Program files\Symantec\Backup Exec\Data\\BEDB_log.ldf
If these files do not exist, you can extract the datbase files from the Backup Exec CD. You'll find them inside cabinet file WINNT\INSTALL\BE\Backup~1.cab.
They are:
F4864_bedb_log.ldf.06609F4A_77E8_4877_8B18_0B805D349FD8  (extract & rename to bedb_log.ldf)
F4893_bedb_dat.mdf.06609F4A_77E8_4877_8B18_0B805D349FD8 (extract & rename to bedb_dat.mdf)

3. Open a command prompt and run the command "sqlcmd -E -S Servername\BKUPEXEC" (replace servername with the name of your server). You should see a "1>" prompt
Type
   1>use bedb
   2>go
If this returns back to the 1> prompt, you're OK and can go on to step 4
If this produces and error, attach the databases again using the below commands(adapt accordingly if paths of file bedb_dat.mdf and bedb_log.ldf are different):
   1>EXEC sp_attach_db BEDB,
   2>N'C:\Program files\Symantec\Backup Exec\Data\BEDB_dat.mdf',
   3>N'C:\Program files\Symantec\Backup Exec\Data\\BEDB_log.ldf'
   4>Go
Try starting the Device and Media service again.

4. Download the MDAC component checker at http://www.microsoft.com/downloads/details.aspx?familyid=8f0a8df6-4a21-4b43-bf53-14332ef092c9&displaylang=en. Install and run it. First "Perform Analysis" to determine the version of MDAC installed on your system. Then "Perform analysis against a version". Make sure the version it detected is selected in the dropdown. In the Mismatch column all values should be "None". Only msxml can mismatch without causing problems. Any other mismatches need to be solved by repairing MDAC. To repair MDAC on Windows 2003, right-click c:\windows\inf\mdac.inf and choose install. Reboot.
Make sure the Device and Media service came up.


Your problem could be down to MDAC problem - which get solved in step 4. But go through the other steps first as well.

If this fails, try going back to step 2 and extract the database files from the CD. Replace existing files with the files from the CD. Then repeat step 3
Avatar of Shain Allen

ASKER

Step 3 i got the following error:
C:\Program Files>sqlcmd -e -s david\bkupexec>err.txt
Sqlcmd: Error: Microsoft SQL Native Client : An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections..Sqlcmd: Error: Microsoft SQL Native Client : Login timeout expired.
The sqlcmd options are case sensitive to my knowledge. So use sqlcmd -E -S david\bkupexec.
Also did you install Backup Exec with the default parameters - i.e. with a SQL instance called BKUPEXEC?
That worked. I downloaded the MDAC checker and when i ran the component checker to determine the the release version and returned "UNKNOWN" as the product releases. I then performed the analysis on MDAC 2.1 SP2 (which was the default in the dropdown) and it seemed to find it.
Sorry didn't check the mismatch field. I got a huge # of mismatches
I'm installing MDAC using the INF and it wants to replace msado20.tlb which is older than the one my server. My server has a newer version. Do i replace it?
MDAC 2.1 SP2 is probably not a good version to test against. If you have Windows 2003 SP1, you will want to check against MDAC 2.8 SP2.
Yeah, i did and still got a bunch of mismatches. What do i do with date mismatch that i mentioned above? I'm using the install disk from Windows Server 2003 and i'm assuming that it's the older version. Do i download and install 2.8 SP2 from MS website?
ASKER CERTIFIED SOLUTION
Avatar of honmapog
honmapog
Flag of Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I don't believe SP is slipstreamed on the 2003 CD.
I saw a download for MDAC 2.8 (not SP1). This is my Exchange server. I don't kown if it uses MDAC
And I suppose you're running SP1 or SP2 for Windows 2003?
I suggest you find or download the service pack you currently have installed. If you download it, you can extract the files from it by using the /x flag when executing the exe file you downloaded (see step 5 in http://www.petri.co.il/windows_2003_sp1_slipstreaming.htm).

When the MDAC install then asks you for the Service Pack files, point them to the folder where you extracted them.
Hopefully, doing this will get rid of the file date conflict you get.

By default Exchange doesn't use MDAC.

A backup with NTBackup is maybe a good idea if you're unsure.
I've installed MDAC 2.8. the SP1 version wouldn't install because it said the OS is not supported. Anyway, the services still won't start. I'm running Windows 2003 SP2
And the MDAC component checker checks out fine now against MDAC 2.8?
Thank you for your help. i'm giving up and callign Symantec.
Avatar of redw3409
redw3409

Was symantec ever able to fix your problem. We are having sort of the same problem
Nope. they even escalated it to one of their top tech dudes and he couldn't even fix it. Even after using their cleanup utility and manually cleaning the registry. it's pretty sad that they couldnt' solve it. Fortunately the server that this happened on is soon to be reallocated so i'm just going to put a clean isntall of the OS and be done with it. Crazy!!