Link to home
Start Free TrialLog in
Avatar of jeffreyvsmith
jeffreyvsmith

asked on

Failed to copy messages to the destination mailbox store with error

I am having a couple different issues that may or may not be related. I need to restore a user's deleted items folder from an exchange backup file. I created the RSG and am experimenting with the restore-mailbox cmdlet but experiencing problems.

If I run the following command:
restore-mailbox -RSGMailbox 'user' -RSGDatabase 'Recovery Storage Group
\Mailbox Database' -id 'Administrator' -TargetFolder 'Backup' -
StartDate '08/01/07' -EndDate '08/05/07'

It creates the Backup folder in Administrator's mailbox and begins copying over email with an enddate of 8/5. But, the start date is not adhered to and it continues on to copy over email from any start date.

If I let it run until completion, with or without start/end data parameters I get the following error:

[3/4/2008 9:51:16 AM] [0] [ERROR] Error was found for Administrator (Administrator@domain.com) because: Error occurred in the step: Moving messages. Failed to copy messages to the destination mailbox store with error: An unknown error has occurred., error code: -1056749164

And then the Backup folder is deleted from administrator's mailbox because there was an error, so I cannot copy out what I need, which is just the deleted items folder for 8/1/ through 12/31.

So, what does that error mean, how can I perhaps ignore errors and keep whatever is restored, and what am I doing wrong with the startdate?

The other problem is that this mailbox is 10GB so everytime I try this restore this the database increases by 10GB and then becomes unused space when the folder is deleted because of the error. Can I regain that space using eseutil?
Avatar of peakpeak
peakpeak
Flag of Sweden image

Empty space is removed each night by the Mailbox Management process.
Regarding deleted items, did you try Recover Deleted Items in Outlook? Retention time in Exchange 2007 is default 30 days.
Avatar of jeffreyvsmith
jeffreyvsmith

ASKER

I am fairly certain that the mailbox management process cannot perform the same function as a offline defrag, but okay. And unfortunately these email were not lost through any standard process. The user was attempting to archive them manually by dragging a large selection of emails over to his archive folder. This process was interrupted somehow and then all those emails were gone, not in mailbox, not in archive, so I am stuck trying to restore from the RSG.
I opened a case with microsoft simultaneously via email and they have been about as much help thus far. Referring me to :http://support.microsoft.com/kb/946958/ which is similiar but not the same. Had me apply Update Rollup 1, with no effect. Same error. Apparently no one is getting a similiar error. Oh well.
ASKER CERTIFIED SOLUTION
Avatar of jeffreyvsmith
jeffreyvsmith

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial