Link to home
Start Free TrialLog in
Avatar of baxleyb
baxleyb

asked on

Windows 2000: Configure Virtualbox guest to access router's gateway

Hi,

I am running VirtualBox 1.5.0 on a Windows 2000 Professional PC.

I just need this box to be a development server that will run one or 2 guests (Windows2003 Server & Ubuntu Server 6.0).

I would like the guest to receive an IP from my router (192.168.2.x) and then I would port forward out one of the guests via ssh and RDP.

Currently Virtualbox automatically assigns an ip address (10.0.0.15) and I can access the internet as well as the configuration homepage of my router, HOWEVER the other computers on my network cannot access the guest at all.

If someone could please let me know if there is way to configure VirtualBox to receive an ip via DHCP or at a minimum assign a static ip back to my network (192.168.2.1) then that would be great.

Also, if VMWare can achieve this same thing and it is free then I would be willing to experiment with it, but I do prefer Virtualbox since it seems to be faster.

Thanks in advance!
ASKER CERTIFIED SOLUTION
Avatar of Halindar
Halindar
Flag of Netherlands image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of 65td
With VM powered off select settings then network on the left side and as stated in the previous post change from NAT to Host interface.

Avatar of baxleyb
baxleyb

ASKER

Hi Halindar,

Thanks for the response. I think I know what you're talking about. Is that the command that says

"route add 10.0.0, etc."?

How would I add a route to route traffic from a 10 address to a 192 address and viceversa?

Thanks.
Yes that's the command to add a route.

Using ipconfig /all you can check if and at what IP VirtualBox has created virtual adapters

Then you might be able to use that IP as the next hop
route add 10.0.0.15 mask 255.255.255.0 [virtual adapter IP]

I don't knowif it would work since I don't have a VirtualBox setup to try it out on.
Did you get the problem resolved, or are you still waiting for more information?
Avatar of baxleyb

ASKER

Hi Halindar,

I tried adding the route and for some reason that didn't work.

I ended up trying out vmware server and it worked great.

Thanks for your help.
Avatar of baxleyb

ASKER

I didn't get the specific answer I was looking for, but got a good alternative.