We help IT Professionals succeed at work.

Require users to press Ctrl+Alt+Delete checkbox is grayed out

bmiisdept
bmiisdept asked
on
I'm trying to remove the need to have users press Ctrl Alt Delete, but the checkbox is grayed out with a check in the box.  How can I get around this and remove the check?
Comment
Watch Question

ARe you on a domain? If you are - then users have to press ctrl+alt+del to log in.
If you are not on a domain - just enable automatic logon: http://support.microsoft.com/kb/315231
Also - if not on a domain - enable the Welcome Screen:
http://www.pchell.com/support/welcomescreen.shtml

Author

Commented:
That's not necessarily true.  Yes, if it's a policy that your company has decided to enforce, but it is possible to turn that requirement off by following these steps:

1. While logged into the machine with Admin right, go to the Start Button... Setting... Control Panel.
2. Double-click "User Accounts" and go to the "Advanced" tab.
3. At the bottom of the Window there is a checkbox for "Require users to press Ctrl+Alt+Delete".

If you remove that check, the machine never brings up the Ctrl Alt Del Window when users login.

For some reason I'm not able to do that on one of our machines.  When I get to that screen the option is grayed out.
I figured it out!  There was a Local Security Policy that locked that value.

Here is the fix:

1. While logged into the computer with Admin level rights, go to Start... Settings... Control Panel... Administrative Tools... Local Security Policy
2. Browse to Security Settings... Local Policies... Security Options.
3. Change the value for, "Interactive Logon: Do not require CTRL + ALT + DEL" from Disabled to Enabled.
4. Restart the computer.
5. You're Finished!
Yes - you didn't update the question prior to today - so I didn't think of suggesting that.

The honest truth is - you should not have to edit the local security policy for a standalone computer - or at least - I try not to...
Hi, i have tried the local security but it works only if the laptop hasn't been restarted. i have changed the Interactive logon in gpedit.msc and secpol.msc, also in registry (disableCAD=0) and it doesnt stay fixed. i am thinking to backup these 3 (msc's and registry) then put the ones from a working laptop/computer in its place.

OS: Vista Business SP1 (32-bit)
Office: office 2007
Domain Controllers: Server 2003
Machine currently issue with: Lenovo T400s (http://shop.lenovo.com/ISS_Static/WW/AG/merchandising/US/PDFs/Thinkpad_t400s_datasheet.pdf)

hope someone can explain my issue please.

thanks in advance for any help/suggestions.