Link to home
Create AccountLog in
Avatar of pacman_d
pacman_dFlag for United States of America

asked on

Vista connect to print share on XP- HP LJ 1000 not supported

I'm trying to connect a Vista computer to a shared HP LaserJet 1000 on an XP Pro machine. There is no vista driver for this printer, but HP says XP drivers "should work". I set up a local port by the PC name\printershare and another with the IP\sharename.
Usually throws an error "Printer Subsystem has failed". This means the print spooler service crashed. The service can be restarted, but cannot print to this printer. I have tried using the W2k driver, or LJ 4 or 6L, even the Generic Print driver. nothing works. Either the print spooler crashes or it goes through with no actual print, or just says "print job failed".
Avatar of Peter Hart
Peter Hart
Flag of United Kingdom of Great Britain and Northern Ireland image

I'm assuming you have setup a basic network between the 2 PCs and they are in the same workgroup  (XP defaults to MSHOME and vista defaults to 'WORKGROUP' so you will have to change one of them) and you have configured the firewalls on both PCS.
so I think if you add a "network printer" instead of a local port.  your vista PC find the printer on the network and  will 'get the drivers' from the XP machine
Avatar of pacman_d

ASKER

no, they are in the same workgroup, i actually had this working with a LaserJet 1020, but the drivers for the HP LaserJet 1000 aren't available for Vista yet. If you try to connect to the printer directly it throws the "print spooler subsystem error"
right,
 I got my HP 1022n working with vista over the netowrk by using the latest xp drivers and manually setting up the local port (bascially I copied what an XP machine had configured) so it workd.
not sure if you can do this with a USB printer, but I added a new pritner and choose 'create a new port' and choose "HP Standard TCP/IP" and configured it to the printer IP address. and all works.
I was able to get a 1022 but now the client is using a LJ 1000 on the remote machine. It is shared through windows.
I tried to change it to "print directly to printer" and changed the print processor settings around as well. Nada so far...
yeh - HP really went down in my estimation by not keeping up iwth vista.
have you tried pluggin it on in directly into the usb and seeing if vista can set it up - then move ot back over the network once it works?
I will try that.
ASKER CERTIFIED SOLUTION
Avatar of pacman_d
pacman_d
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account