Link to home
Start Free TrialLog in
Avatar of softekservices

asked on

can't connect to database on local machine using sql server 2005 management studio

Hello, all.  I'm getting the following error when trying to connect to a SQL Server 2005 database on a local machine using DB management studio:

A connection was successfully established with the server, but then an error occured during the pre-login handshake (provider: SSL provider, error: 0 - the certificate chain was issued by an authority that was not trusted) (Microsoft SQL Server)

I'm not trying to use an encrypted connection, in fact, I have force encryption off in every client or server configuration properties window I can find.  The server accepts only named pipes and TCP/IP protocols, and client connections are only using named pipes and tcp/ip.  I'm trying this with either my domain/server admin account and windows authentication or the sa account, I get the same result.  I don't want the SSL provider, I just want to connect to the local database without encryption.

I can connect fine to the database remotely or from the local box using other tools such as ODBC or OSQL.  But management studio refuses to connect, using the error above.  

If someone has seen this before, please help, I've searched everywhere but can't find the solution to this.

Thank you very much.
Avatar of QPR
Flag of New Zealand image
Some suggestions here may help.... have to scroll down to get to your particular error
Avatar of softekservices


Thanks for the reply.  

The link you gave me gives a good explanation of the mechanics behind SQL protocols, but my problem is addressed for people who actually *WANT* to encrypt their connection to SQL Server, which I do *NOT*.  Even when I force named pipes or tcp/ip as the connection protocol, it still returns "SSL Provider" as the source of the error.  I'm just trying to make it accept regular, unencrypted connections from DB management studio, and I'm unable to do so.
Avatar of softekservices

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial