Link to home
Start Free TrialLog in
Avatar of Arash48
Arash48Flag for Netherlands

asked on

Active Directory setup on a Windows 2k3 behind a speedtouch Gateway

Hello,
I am trying to install Active Directory on a Windows Server 2003 which is placed behind a Speedtouch Gateway Modem. I had no problem configuring this stand alone server for ICS or Making a bridge between two lan cards. But when I want to install Active Directory, then everything goes wrong. I have also configured my Gateway modem for DHCP spoofing and get the WAN IP on the server but when then again the same error: "It cannot solve the DNS confiugration!!!"
I have a Gateway modem with IP-address as: 80.x.x.x, 255.0.0.0, 194.x.x.x and has configure the 2nd LAN card with IP-address static settings like this: 192.168.1.1,255.255.255.0, 194.x.x.x.
For DNS of the 2nd LAN card I have used the WAN IP-address or even tried with 194.x.x.x but it didn't help.

Hope someone can help me with the problem. Thx in advance.
Avatar of Richard_de_groot
Richard_de_groot
Flag of Netherlands image

So your server will have software firewall. Is that correct? If yes?

Then you can download install software from www.speedtouch.com and make this modem spoofing, which means that it will passthrough the external ipaddress right on your server. Your DNS should be a standard install after this action.

Which model of Speedtouch do you have. Make also sure you have the right firmwareupdate.

Hope this helps.
Avatar of Arash48

ASKER

Hi Richard,
Thx for your tip. However, I have already configured my Speedtouch 780 and 546 for DHCP-spoofing. For your information I am not using any firewall at this moment. Cus I like to solve this problem first and then go for firewall.

So I have a Speedtouch Modem 780 or 546, both are configured for DHCP-spoofing and I disabled also DHCP option of the speedtouch. So I get my WAN IP-address on the first network card and the 2nd network card is configured for 192.168.0.1. So we the help nslookup command I set 127.0.0.1 as the localhost. It seems working.

I would like to add that I have encountered another problem. Which is DHCP Server confiugration. When I am trying to use the Manage Authorized Servers I get this Error: "the server cannot contact the Active Directory."

If anyone can give me a tip I will really appreciate it.

Richard, thx again for your tip.
With the nslookup you check wich server is DNS.

If you install DNS on your server. You have to specify 192.168.0.1 in your tcpip settings of your network card as the DNS server. Not 127.0.0.1!

If DNS is installed, ensure that the service is running and set to
automatically start. If there are errors (eventlogs) make sure you solve them first, before starting on DHCP. If DNS works fine with you zones and PTR DHCP should be working fine also.

Hope this works.


Avatar of Arash48

ASKER

Thx Richard de groot,

That problem is solved. However I got another problem. I have access to the Internet on all PCs on the LAN side if I use Static IP. DHCP option doesn't work. NAT configuration is OK and Active but whenever I want to Authorize the DHCP server I get "Cannot connect to the Active Directory!"

Any ideas? Thx in advance.

arash48
ASKER CERTIFIED SOLUTION
Avatar of Richard_de_groot
Richard_de_groot
Flag of Netherlands image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Arash48

ASKER

Hi Richard de groot,
My appology for not being able to respond your message earlier.

For your information I would like to say that the problem is solved. Here is what happened: After instlaling the Active Directory and rebooting the system. Windows Server 2003 disables the DHCP server automatically for security reasons. When I tried to Authorize the DHCP server I got this message: "Access Denied"!!! After double and even tripple checking everything I found out that for some unknown reason I had no "Administrator Rights" anymore. So after reconfiguring my rights and disabling the "Remote Access Server" in the Properties page of the "Routing and Remote Access" everything started working.

Thx alot for the tips.

Kind regards,

arash48