Link to home
Create AccountLog in
Avatar of filtrationproducts
filtrationproductsFlag for United States of America

asked on

Receiving error in event log when attempting to view usage and performace reports in SBS 2003

My usage and performance reports use to work fine. Now when I attempt to view them from Server Management/Monitoring and Reporting/ I am receiving 2 errors in the event log that say;

====================================================
Event Type:      Error
Event Source:      ServerStatusReports
Event Category:      None
Event ID:      1
Date:            3/5/2008
Time:            8:28:26 AM
User:            N/A
Computer:      SBS2K3
Description:
Server Status Report:
      URL:            http://localhost/monitoring/usage.aspx?reportMode=0
      Error Message:      Login failed for user 'FILTRATION\IUSR_SBS2K3'.
      Stack Trace:         at usage.globalFn.connectDataSource(Boolean pingFirst)
   at usage.frmUsage.renderReportWorker()
   at usage.frmUsage.renderReport()
====================================================


Event Type:      Error
Event Source:      ServerStatusReports
Event Category:      None
Event ID:      1
Date:            3/5/2008
Time:            8:28:21 AM
User:            N/A
Computer:      SBS2K3
Description:
Server Status Report:
      URL:            http://localhost/monitoring/perf.aspx?reportMode=0
      Error Message:      Login failed for user 'FILTRATION\IUSR_SBS2K3'.
      Stack Trace:         at usage.globalFn.connectDataSource(Boolean pingFirst)
   at usage.frmPerf.renderReportWorker()
   at usage.frmPerf.renderReport()

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

====================================================
ASKER CERTIFIED SOLUTION
Avatar of Dave Stringfellow
Dave Stringfellow
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of filtrationproducts

ASKER

Where is this folder exactally?
I added the user iusr_ to the C:\inetpub\monitoring\ folder and gave it full control then I made sure the individual files (usage.asp & perf.asp had the same permissions and they do. So I still dont understand why its saying it cant login. Is this service using SQL server or anything to generate the reports?
I figured it out. I had to navigate through IIS to 'local computer > default webpage > From here I had to right click on the following items; reportserver, reports, & monitoring, right click each and click properties / directory security / auth and  access control - edit / uncheck enable anonymous access. After I did this everything started working. (you might have to reconfigure monitoring to get it to start working)