Link to home
Create AccountLog in
Avatar of Stephane Otis
Stephane OtisFlag for Canada

asked on

Read only button unavailable when trying to open a protected (in modify) Powerpoint file within a Citrix session

Hi,

Windows 2000 server with Office 2003 and Citrix Presentation Server 4.

My users can't open a protected Powerpoint file. The creator of the files (not just one file), add a password to modify the file. On a laptop or dektop computer, if you don't have the password, you can use the Read Only button. When my users in Citrix sessions tried to open the document, there's no Read Only button. On top of that, if you try the password it will not work!
The problem is ONLY with Powerpoint. I tried with Word and Excel and it works perfectly.

Anyone have an idea? I tried uninstall and reinstall but the problem is the same...


Prtscrn.JPG
Avatar of Craig Roberds
Craig Roberds
Flag of United States of America image

Is this file browsed to the same location whether it is from a citrix user or a local user (not a copy of the original file)?

Those message boxes are for two different things.  The one on the left is for a password to open the file.  The second is for the password to modify the file.  It seems to me that someone took the original file and then added an additional password just to open it and then did a save as and saved an additional copy.
Avatar of Stephane Otis

ASKER

This is the same file, just a different location. I can reproduce this issue anytime I want with any protected to modify files. The files isn't corrupt here, I can certify that.
The difference is the OS. Windows 2000 Server on the left and Windows 2003 on the right.
Office 2003 both.
OK, I did a test.  I hadn't installed powerpoint on a citrix server (Win 2K3 & PS 4.5), so I am probably breaking my EULA, shhh  :).

I made a PP and passworded the modify, and I didn't have this issue, so it has to either be that the copied file somehow got a password attached to it, the PP itself is corrupt, or somehow there are corrupt user settings/registry.

Have you tried with another PP presentation i.e. make a new test PP, password the modify, save, and see if it has the same problem?  If it doesn't then it's just that one PP presentation that is corrupt somehow, and it doesn't have anything to do with citrix.

I do not think there is an issue with the fact the PP was made from a 2000 box and opened from a session on a 2K3.  Have you tried from multiple users?  An Administrator account?  If yes then I would make a test account that won't have to go through the citrix/TS GPO's and see if it opens.  If it does then it is your default user data.  Not sure how that could happen, unless perhaps PP 2003 was installed over 2000 or something, and even then it doesn't make sense to me.  

If neither of these work I will have to think some more.  


ASKER CERTIFIED SOLUTION
Avatar of Stephane Otis
Stephane Otis
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
So while logged into the TS with the Admin it does work correctly, but if you are logged into a RDP with the same Admin account you do have the problem?

Just want to be sure, I will try some more testing.  Have you noticed a difference if say the original PP file is made outside of TS and then used in a TS, and then if you do the same thing but make a new PP file inside of TS and then save and open it again inside of TS?

Just trying to eliminate possibilites.  Something seems to not be transferring correctly in the user profile, not sure if would be in the registry or in the PP info files inside the user's application folder on their profile.
I got one TS that either I log with my Admin account in RDP or via Citrix, I can't open the protected file in Read Only. I have no choices of an encryption type in Tools, Options, Security, Advanced... When I log with the local Admin account, everything's fine with Powerpoint.

The other TS, everything works fine when using the local Admin account and also when I log with my Admin account in RDP. But I got the problem within the Citrix sessions.

I tested with many files created by me or by others. There's one thing... within a session that got the problem, I can't save a new protected file. The fact that I don't see encryption types seems to be the problem.
PP-encryption-type.JPG
Now with Windows 2K3, our TS works fine.

Thanks for your help, hope no one else has this problem because there is no solution here! ;)
I still have the problem with missing encryption in powerpoint 2003 on some machines.
All the machines are running WinXP with all the latests updates.

Do you know how to get them back or what they are called so I could copy them from one machine to the other?