Link to home
Start Free TrialLog in
Avatar of TeamMISCBC
TeamMISCBCFlag for United States of America

asked on

Shared file server folder and now no one has access to one subfolder

I have a shard folder for all employees to access their forms from. All folders and subfolders work but one!
The one that people can't access is called "legal" and I was working on it last week. . . giving one individual access to it, so he could change files. Now no one has access to it, even---believe me, I can't believe this-- the domain administrator!
I logged in and checked all domain user permissions, and all match another subfolder in that root folder.
SO, I thought I would get there faster, and plug in my jump drive---to that file server, and copy the whole folder (using the big kahuna domain admin user account). It would NOT let me copy that trouble folder called legal.
So, then I thought I could circumvent everything and share the legal subfolder, AND give domain users full access...wrong...still can't copy it, still can't open up certain files in it. The other subfolders all work, so I think it's just permissions on that one trouble sub-folder. . . "legal"

when I attempt copying the whole folder it gives me this message:
can't copy. Access denied. Make sure the disk is not full or write protected

Please assist....thanks.

teammiscbc
Avatar of DistinctiveIT
DistinctiveIT
Flag of Canada image

Have you tried taking ownership of the folder as the domain admin first? Let us know if that works.
SOLUTION
Avatar of computuners
computuners

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of TeamMISCBC

ASKER

DistinctiveIT --- good idea...I already tried that. I logged in as the big kahuna admin and it wouldn't even let me copy the whole sub-directory....I wanted to do that ...copy to my jump drive, then replace the folder in the top shared directory.
Thanks

computuners-- I attempted it and here is what error I get...

an error occured applying security info to  (root directory/path and file name)

access denied

This is while I am logged in as a domain admin.
I tried restarting the server, and no dice. same thing
Is the "Allow inheritable permissions from parent to propagate to this object" option checked or unchecked on the problem folder?
Can you take ownership of individual files within the folder?
DistinctiveIT,

 Hello. Yes, it is checked.
Nope -- I can't take ownership of any files ...it tells me access denied. . . this is from my domain
admin login account! All is ok with other subfolders in the root shared folder.
Any more ideas?
thanks

teammiscbc
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Ok, here is what I've done this morning.
I logged in as big kahuna ---domain administrator, and setup mY domain admin act as having full priveleges on the legal folder. Then I unchecked the box (sharing and security--advanced) for allow inheritable permissions from parent to propagate--ect...
  I then put in a domain user (that was not ever one having permissions to this folder) as  one that has basic privelges to this folder...just read/list folder contents/ and execute...and logged in as her domain user account...on a another desktop pc.
I could navigate to the legal folder, even enter the folder, but couldn't open any files. I then logged into the server domain admin account and gave her domain account full access to the legal folder, and the root folder --that is shared on our file server.
Still got the same error--"user does not have acces privelges". . .
I have attached a copy of the error file...
The only user I can login as and open the files in that legal folder is IF I login with my domain user account.

Ideas?
Thanks in advance

teammis

experts-exchange-forms-folder-fi.pdf
Oh-- I also re-checked the box for allowing inheritable permissions form parent to propogate...ect....

thanks
Ok, here is a screen shot--attached---about security options--advanced button

I can't attach that type of file. It's saved in rtf format, and I can't get it to change...to a doc or jpeg. Sorry.

Ok, got it.
I ended up un-checking the top one in the advanced options of sharing and security. . . for allow inheritable permissions...blah, blah...

then I  copied the flakey legal folder to another place...renamed it, checked it for permissions...set the necessary ones, and deleted the flakey folder. Then I renamed the duplicate, and it worked. Thanks.
thank you for all of the assistance. Good work!
Thanks for letting us know!