Link to home
Start Free TrialLog in
Avatar of taltomare
taltomare

asked on

Cannot get past mailbox role install while installing Exchange 2007

Need some major help.  I've been trying to deploy Exchange 2007 for the past few days without any luck.  I have a 2000 native domain with one 2000 AD server and two 2003 sp2 AD servers.  All of the FSMO roles have been transfered to one of the 2003 AD servers and confirmed.  I've run the /preparead /prepareschema /preparedomain commands succesfully.  I'm running the Exchange 2007 install from the command prompt with d:\setup /mode:install /domaincontroller:2003ADServerName /roles:ht,ca,mb,mt /enablelegacyoutlook

The install completes the Prerequisite Check without a problem.  Then starts installing the roles.  The management tools, hub transport role and client access role install without a problem then after about 30% the way through the mailbox role install errors out with:
"The Exchange server address list service failed to respond.  This could be because of an address list or email address policy configuration error."
Plus the application event viewer is loaded with Event ID 4001 Source: MSExchange System Att
A transient failure has occurred.  The problem may resolve itself in a while.  The service will retry in 56 seconds.  
Any Ideas?

There is also a warning message in the application event viewer as follows:
Event ID 2116 Source: MSExchange ADAccess
The domain controller <name of the 2000 AD server> is running Windows 5.0 (2195) (Unknown Service Pack). Exchange Active Directory Provider requires that domain controllers are running Windows Server 2003 Service Pack 1 or later versions of Windows.

Why is MSExchange ADAccess looking to my old 2000 AD server instead of the new 2003 AD server?  I even specified the 2003 AD server in the command line install.
Avatar of mass2612
mass2612
Flag of Australia image

Hi,

I am not sure about this one so anyone else please chime in. However can you confirm that the Windows 2000 DC is in the same AD site and subnet as the Windows 2003 DC's? Also what SP is the Windows 2000 DC running? I would make sure that its up to date with SP's and hotfixes.
Have you prepared your domain for AD 2003 before you transfer the fsmo roles? Have you run adprep /froestprep adprep/domainprep from the windows 2003 server CD on your windows 2000 PDC?
The other thing that you must make sure, after that you transfered the FSMO roles, did you configure your windows 2003 server as a global catalog?

Regards Harout
Avatar of taltomare
taltomare

ASKER

The service pack for the windows 2000 AD server is SP4 and all updates are installed.  Yes, both 2000 and 2003 AD servers are on the same subnet and in the same domain.  I ran /forestprep and /domainprep from the 2003 server cd on the 2000 AD server prior to running anything else.  I set the 2003 AD server as the GC after the adprep commands.   Any other ideas? Should I run the adprep commands again and try in Exchange 2007 install again?
Have you run
Setup /PrepareLegacyExchangePermissions
Do you have Exchange on any Windows 2000 domain controllers? That can cause this type of problem.

Are you using RTM code or SP1 code?

Simon.
I have not run "setup /PrepareLegacyExchangePermissions".  Not familiar with that one where should I run it?  

Yes Exchange 2000 is installed on the 2000AD server.  Don't know understand what you mean by RTM code or SP1 code?
Are you installing Exchange 2007 using the original released code, or using SP1 downloaded from Microsoft?
If you are using the original release code then I would suggest that you look to go straight to SP1. You can install Exchange fresh from the SP1 download, you just need the license key from your original media.

Simon.
I'll start the SP1 download right now and give it a try when it's done then update any progress.  Thanks!
You run it from the installation CD
ASKER CERTIFIED SOLUTION
Avatar of taltomare
taltomare

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial