Link to home
Start Free TrialLog in
Avatar of rdannels
rdannels

asked on

Solaris OS patch causes ORA-00600: internal error code, arguments: [keltnfy-ldmInit], [46], [1] ...

The sys admins applied some upgrades on this Sun Sparc 2000 box running Solaris 10.

Right after, when trying to restart the Oracle 10.2.0.3.0 database there, it would only give
ORA-00600: internal error code, arguments: [keltnfy-ldmInit], [46], [1] which says that
Oracle could not find the hostname in /etc/hosts.   The hostname is plainly there and readable
by all.  From where and what hostname is Oracle trying to find at instance startup time?

We have tried reinstalling the product, editing the hosts file, and bouncing the box with no
change in the error.

R. Dannels
Avatar of joebednarz
joebednarz
Flag of United States of America image

Did, perhaps, the a chmod get run against /etc/hosts?  It should be -rw-r--r-- (644)

Also check that the hostname hasn't changed, including the inclusion of domain information.
just guessing. . did the patch they applied require a "relink" of the binaries
shut down everything on instance, listener, database, asm..  
set your environment
then
$ORACLE_HOME/bin/relink all
Avatar of rdannels
rdannels

ASKER

No,  I removed the entire Oracle install, and re-installed the product. I was
surprised when this did not fix it.

RD
sorry, guess I could have read your message
>>"We have tried reinstalling the product,"

sounds like an oracle Tar to me.

while you're wait for them, try to create a new database on the sever.
see if that fails as well?  might give you some other clues.
but, I have no idea..
As you have mentioned that Ora 600 is looking for hostname and that there were some OS patches applied. Can you check if you are using a DNS. If yes make sure that DNS is available and is able to resolve the server name.

HTH
Vishal
ASKER CERTIFIED SOLUTION
Avatar of Brian Utterback
Brian Utterback
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
That led to the fix, thanks!