Link to home
Create AccountLog in
Avatar of Mario Zio
Mario ZioFlag for Italy

asked on

how to share the mobile phone connection with the eeepc 8g (with kubuntu installed),via usb cable.

Hello,

i've bought an asus eee pc 8g where i've installed kubuntu 8.0.4 alpha5 with kde 4.0.2. I will use it when i will be out of my home,because there i will haven't a connection cable. I have a mobile phone also,an htc p3600 trinity,with windows mobile 6.0 and a fast connection. My idea is to use this connection with the eeepc,via usb cable. With windows its easy to do,using activesync and an application on the mobile phone,called "shared connection". And with Linux ?

Thanks.
ASKER CERTIFIED SOLUTION
Avatar of noci
noci

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Mario Zio

ASKER

i've tried to use the modem of my mobile phone to connect the EeePC to internet. here is what i've done :

modprobe ipaq

lsusb -v

bus 002 device 004 : id0bb4:0xb05 : High Tech Computing
Id vendor : 0x0bb4 High Tech Computing
Id product : 0x0b05

rmmod ipaq

modprobe ipaq vendor=0x0bb4 product=0x0b05

this has given to me the /dev/ttyUSB0 device.

i've edited the /etc/wvdial.conf as follows :

[Dialer Defaults]
Modem = /dev/ttyUSB0
Baud = 115200
init = AT+CGDCONT=1,"IP","naviga.tre.it",""
Phone = *99#
Username =
Password =
New PPPD = yes
Stupid Mode = yes

wvdial

wvdial : internet dialer version 1.60

cannot get information for serial port
initializing modem
sending : AT+CDGCONT=1,"IP","naviga.tre.it",""
sending : ATQ0
Modem not responding
Avatar of noci
noci

Are you aware of this site:
http://www.taniwha.org.uk/

Halfway though there is a set of scripts to dial thought windowsce based phones
http://www.taniwha.org.uk/files/WindowsMobileGSM2007-07.zip
These are apple based, but contain well documented scripts. for basic modem use.


Here is one using wvdial
http://blog.gwright.org.uk/articles/2006/11/22/using-a-windows-mobile-phone-to-connect-to-the-internet
which claims that Windows mobile has a different Connect string (AT+CDGCONT).
yeah,

i've followed the instructions listed on this site :

http://blog.gwright.org.uk/articles/2006/11/22/using-a-windows-mobile-phone-to-connect-to-the-internet

but,as i said,it doesn't works because it says : modem not responding.
and i've tried to connect the mobile phone to the eeepc via
bluetooth,also. Here is what i've written :

apt-get install bluetooth
apt-get install bluez-utils
apt-get install dhcp3-server
apt-get install kdebluetooth

lsusb

bus001 device 002 : id 07b8:b02a d-link corp.

hciconfig hci0 piscan

and then into the "Internet Connection Sharing" program i've started
the connection using "Bluetooth PAN" and on the EeePC i've written :

hcitool scan

on the EeePc i've seen :

scanning :

00:17:83:01:4a:9d Mario

and then :

pand --connect 00:17:83:01:4a:9d -n

pand : command not found.
Are you sure *99# is the right GPRS number?
in NL For Vodaphone it seems to be *99***1#
in NL Kpn is different: *99# domestic and *31*99#abroad

Do you need a local network for Bluetooth (personal area network?)?
I thought you wanted a modem connection then an rfid channel is used like in this description
http://www.teaparty.net/technotes/blue-gprs.html

And here one for naviga.tre.it, also using rfcomm, that you seem to use, it's italian so I cant verify it contents.
http://www.intilinux.com/linux/181/nokia-6630-bluetooth-naviga-tre-debian/

And this is a wvdial, that is on ubunto forums with a comment
http://ubuntufacile.org/Internet_mobile_3G_GPRS_UMTS_HSDPA
to change the web.omnitel.it with something else if needed like naviga.tre.it

Modificare web.omnitel.it cambiandolo con naviga.tre.it,ibox.tim.it,o internet.wind
8<--
[Dialer Defaults]
Modem = /dev/ttyUSB0
ISDN = off
Modem Type = Analog Modem
Baud = 460800
Init = ATX3
Init2 = AT&F Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = at+cgdcont=1,"IP","web.omnitel.it"
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = *99***1#
Phone1 = *99***1#
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 20
Dial Command = ATM1L3DT
Ask Password = off
Password = anon
Username = anon
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on
;Minimize = on
;Dock = on
;Do NOT edit this file by hand!
8<--
I've made some progess ,as you can see here :

marietto2008:/home/mario# pand --connect 00:17:83:01:4A:9D -n

pand[3744]: Bluetooth PAN daemon version 3.7
pand[3744]: Connecting to 00:17:83:01:4A:9D
pand[3744]: bnep0 connected

marietto2008:/home/mario# ifconfig

eth0 Link encap:Ethernet HWaddr 00:16:17:AC:E5:57
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:58 errors:0 dropped:0 overruns:0 frame:0
TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4020 (3.9 KiB) TX bytes:4020 (3.9 KiB)

marietto2008:/home/mario# ping www.google.com
ping: unknown host www.google.com

but the network configuration is not good,what should i do now ?
Sidenote...
From your first example: Where you draw the conclusion modem not responding..., have you tried the AT command?
(AT <enter> )
that should respond with OK, you might need a ATQ0 first to enable the status answer).
The set you gave might timeout on connecting.... I agree i would expect it to work different then show.

For setting up a PAN you need either a NAP (Network Access point or a GN )
In this case go for NAP, that is YOUR computer needs to be assigned that role.
You do show output of commands, but you run it without configuration files?
Please present them also.
Even if you have then daemon running, there still is no network adapter dnep0,
without that IP cannot be routed.
ifconfig -a should also show a least a bnep0
after that netstat -rn should show a default route.
Then you should be able to ping that gateway. (Then you have IP)

It that's done check if a names server is configured. (/etc/resolv.conf, nameserver lines)
then you should be able to loopup a name (f.e. with  dig www.google.com)

Then you could try to run a ping or traceroute to tartget on the internet, don't be disappointed
if there's no answer, the remote host might have ping disabled by a firewall, then just try a few others.
(I would expect an answer from: www.google.com )
Kind of Howto between two computer.
http://triptico.com/software/bluetooth.html

More complete:
http://bluez.sourceforge.net/contrib/HOWTO-PAN

This is for the reverse of what you want (Have the phone use your computer to access the internet).
http://www.howtoforge.com/bluetooth_pand_debian_etch
you said :

 Where you draw the conclusion modem not responding..., have you tried the AT command?
(AT <enter> )
that should respond with OK, you might need a ATQ0 first to enable the status answer).

how can i try to give to the modem the ATQ0 command ?
It's  a serial connection, so using a tool like minicom or kermit should be able to do it.
The serial line would be called /dev/rfcommX (x = 0,1...n)

configuring that as the communication line/ modem should work.

Taking kermit as an example:

kermit
set line /dev/rfcomm0
connect
ATQ0
etc.
are you sure that's a serial connection ? because i'm using an usb connection,not serial...
Excuse me..., I thought you were using bluetooth lately, and went on to that track... (rfcomm)
minicom & kermit won't help with USB per se, only if a serial interface is emulated.  (/dev/ttyUSB*) type of devices.
But fortunately in your config the same interface is mentioned
so you can still use minicim or kermit, but now using the /dev/ttyUSBx interface.
Note that you need /dev/ttyUSB0 for those configs to work, check if USB creates that device, and not a /dev/ttyUSB1 or so
ok. this is the situation :

i've attached the mobile phone HTC P3600 with an USB cable and it has been recognized :

marietto@marietto2008:/dev$ lsusb

Bus 001 Device 004: ID 0bb4:0b05  High Tech Computer Corp.

marietto@marietto2008:/dev$ lsusb -v

Bus 001 Device 004: ID 0bb4:0b05  High Tech Computer Corp.

idVendor           0x0bb4 High Tech Computer Corp.
idProduct          0x0b05
bcdDevice            0.00
iManufacturer           1 HTC
iProduct                2 Generic RNDIS

marietto@marietto2008:/dev$ modprobe ipaq vendor=0x0bb4 product=0x0b05
marietto@marietto2008:/dev$ ls ttyU*
marietto@marietto2008:/dev$ No Such File or Directory.
marietto@marietto2008:/dev$ ls ttyA*
marietto@marietto2008:/dev$ No Such File or Directory.



no device has been created. why ? how to do ?
output of dmesg after inserting the USB connector and loading ipaq shows?
marietto@marietto2008:~$ sudo modprobe ipaq vendor=0x0bb4 product=0x0b05
[sudo] password for marietto:
marietto@marietto2008:~$ dmesg
[    0.000000] Linux version 2.6.24-11-generic (buildd@rothera) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu1)) #1 SMP Fri Feb 29 22:08:31 UTC 2008 (Ubuntu 2.6.24-11.17-generic)
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[    0.000000]  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000003f780000 (usable)
[    0.000000]  BIOS-e820: 000000003f780000 - 000000003f790000 (ACPI data)
[    0.000000]  BIOS-e820: 000000003f790000 - 000000003f7d0000 (ACPI NVS)
[    0.000000]  BIOS-e820: 000000003f7d0000 - 000000003f7de000 (reserved)
[    0.000000]  BIOS-e820: 000000003f7e0000 - 000000003f800000 (reserved)
[    0.000000]  BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
[    0.000000]  BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
[    0.000000] 119MB HIGHMEM available.
[    0.000000] 896MB LOWMEM available.
[    0.000000] found SMP MP-table at 000ff780
[    0.000000] Entering add_active_range(0, 0, 259968) 0 entries of 256 used
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA             0 ->     4096
[    0.000000]   Normal       4096 ->   229376
[    0.000000]   HighMem    229376 ->   259968
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0:        0 ->   259968
[    0.000000] On node 0 totalpages: 259968
[    0.000000]   DMA zone: 32 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 4064 pages, LIFO batch:0
[    0.000000]   Normal zone: 1760 pages used for memmap
[    0.000000]   Normal zone: 223520 pages, LIFO batch:31
[    0.000000]   HighMem zone: 239 pages used for memmap
[    0.000000]   HighMem zone: 30353 pages, LIFO batch:7
[    0.000000]   Movable zone: 0 pages used for memmap
[    0.000000] DMI present.
[    0.000000] ACPI: RSDP signature @ 0xC00FBE60 checksum 0
[    0.000000] ACPI: RSDP 000FBE60, 0014 (r0 ACPIAM)
[    0.000000] ACPI: RSDT 3F780000, 0034 (r1 A M I  OEMRSDT  12000714 MSFT       97)
[    0.000000] ACPI: FACP 3F780200, 0081 (r1 A M I  OEMFACP  12000714 MSFT       97)
[    0.000000] ACPI: DSDT 3F780400, 5F2B (r1  A0935 A0935000        0 INTL 20051117)
[    0.000000] ACPI: FACS 3F790000, 0040
[    0.000000] ACPI: APIC 3F780390, 0068 (r1 A M I  OEMAPIC  12000714 MSFT       97)
[    0.000000] ACPI: OEMB 3F790040, 0046 (r1 A M I  AMI_OEM  12000714 MSFT       97)
[    0.000000] ACPI: MCFG 3F786330, 003C (r1 A M I  OEMMCFG  12000714 MSFT       97)
[    0.000000] ACPI: PM-Timer IO Port: 0x808
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
[    0.000000] Processor #0 6:13 APIC version 20
[    0.000000] ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
[    0.000000] IOAPIC[0]: apic_id 1, version 32, address 0xfec00000, GSI 0-23
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: IRQ0 used by override.
[    0.000000] ACPI: IRQ2 used by override.
[    0.000000] ACPI: IRQ9 used by override.
[    0.000000] Enabling APIC mode:  Flat.  Using 1 I/O APICs
[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] Allocating PCI resources starting at 40000000 (gap: 3f800000:bf600000)
[    0.000000] swsusp: Registered nosave memory region: 000000000009f000 - 00000000000a0000
[    0.000000] swsusp: Registered nosave memory region: 00000000000a0000 - 00000000000e4000
[    0.000000] swsusp: Registered nosave memory region: 00000000000e4000 - 0000000000100000
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 257937
[    0.000000] Kernel command line: root=UUID=4cd56472-fc4c-44d1-bff9-5f5ca52ba98e ro quiet splash locale=it_IT
[    0.000000] mapped APIC to ffffb000 (fee00000)
[    0.000000] mapped IOAPIC to ffffa000 (fec00000)
[    0.000000] Enabling fast FPU save and restore... done.
[    0.000000] Enabling unmasked SIMD FPU exception support... done.
[    0.000000] Initializing CPU#0
[    0.000000] PID hash table entries: 4096 (order: 12, 16384 bytes)
[    0.000000] Detected 630.076 MHz processor.
[   12.190926] Console: colour VGA+ 80x25
[   12.190935] console [tty0] enabled
[   12.191573] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[   12.192733] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[   12.264915] Memory: 1018888k/1039872k available (2164k kernel code, 20276k reserved, 1003k data, 364k init, 122368k highmem)
[   12.264938] virtual kernel memory layout:
[   12.264941]     fixmap  : 0xfff4b000 - 0xfffff000   ( 720 kB)
[   12.264945]     pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
[   12.264948]     vmalloc : 0xf8800000 - 0xff7fe000   ( 111 MB)
[   12.264952]     lowmem  : 0xc0000000 - 0xf8000000   ( 896 MB)
[   12.264955]       .init : 0xc041d000 - 0xc0478000   ( 364 kB)
[   12.264959]       .data : 0xc031d12d - 0xc0417dc4   (1003 kB)
[   12.264962]       .text : 0xc0100000 - 0xc031d12d   (2164 kB)
[   12.264971] Checking if this processor honours the WP bit even in supervisor mode... Ok.
[   12.265082] SLUB: Genslabs=11, HWalign=64, Order=0-1, MinObjects=4, CPUs=1, Nodes=1
[   12.345117] Calibrating delay using timer specific routine.. 1261.75 BogoMIPS (lpj=2523514)
[   12.345198] Security Framework initialized
[   12.345218] SELinux:  Disabled at boot.
[   12.345257] AppArmor: AppArmor initialized
[   12.345268] Failure registering capabilities with primary security module.
[   12.345293] Mount-cache hash table entries: 512
[   12.345636] CPU: After generic identify, caps: afe9fbff 00100000 00000000 00000000 00000000 00000000 00000000 00000000
[   12.345670] CPU: L1 I cache: 32K, L1 D cache: 32K
[   12.345676] CPU: L2 cache: 512K
[   12.345683] CPU: After all inits, caps: afe9fbff 00100000 00000000 00002040 00000000 0000000000000000 00000000
[   12.345709] Compat vDSO mapped to ffffe000.
[   12.345742] Checking 'hlt' instruction... OK.
[   12.362052] SMP alternatives: switching to UP code
[   12.366777] Freeing SMP alternatives: 11k freed
[   12.367071] Early unpacking initramfs... done
[   13.332056] ACPI: Core revision 20070126
[   13.332240] ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.
[   13.535421] CPU0: Intel(R) Celeron(R) M processor          900MHz stepping 08
[   13.535477] Total of 1 processors activated (1261.75 BogoMIPS).
[   13.535654] ENABLING IO-APIC IRQs
[   13.535892] ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
[   13.681129] Brought up 1 CPUs
[   13.681179] CPU0 attaching sched-domain:
[   13.681186]  domain 0: span 01
[   13.681191]   groups: 01
[   13.681616] net_namespace: 64 bytes
[   13.681645] Booting paravirtualized kernel on bare hardware
[   13.682884] Time: 22:49:09  Date: 03/19/08
[   13.683023] NET: Registered protocol family 16
[   13.683551] EISA bus registered
[   13.683592] ACPI: bus type pci registered
[   13.684111] PCI: PCI BIOS revision 3.00 entry at 0xf0031, last bus=5
[   13.684119] PCI: Using configuration type 1
[   13.684124] Setting up standard PCI resources
[   13.707399] ACPI: EC: Look up EC in DSDT
[   13.746814] ACPI: Interpreter enabled
[   13.746824] ACPI: (supports S0 S1 S3 S4 S5)
[   13.746871] ACPI: Using IOAPIC for interrupt routing
[   13.763340] ACPI: EC: GPE = 0x18, I/O: command/status = 0x66, data = 0x62
[   13.763350] ACPI: EC: driver started in poll mode
[   13.763682] ACPI: PCI Root Bridge [PCI0] (0000:00)
[   13.764712] Force enabled HPET at base address 0xfed00000
[   13.764725] PCI quirk: region 0800-087f claimed by ICH6 ACPI/GPIO/TCO
[   13.764733] PCI quirk: region 0480-04bf claimed by ICH6 GPIO
[   13.765698] PCI: Transparent bridge - 0000:00:1e.0
[   13.765769] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[   13.766196] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P3._PRT]
[   13.766424] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P5._PRT]
[   13.766640] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P6._PRT]
[   13.777485] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 *5 6 7 10 11 12 14 15)
[   13.777825] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 *11 12 14 15)
[   13.778162] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 *10 11 12 14 15)
[   13.778492] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 *7 10 11 12 14 15)
[   13.778820] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[   13.779151] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[   13.779482] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[   13.779824] ACPI: PCI Interrupt Link [LNKH] (IRQs *3 4 5 6 7 10 11 12 14 15)
[   13.780184] Linux Plug and Play Support v0.97 (c) Adam Belay
[   13.780275] pnp: PnP ACPI init
[   13.780297] ACPI: bus type pnp registered
[   13.785587] pnp: PnP ACPI: found 13 devices
[   13.785595] ACPI: ACPI bus type pnp unregistered
[   13.785607] PnPBIOS: Disabled by ACPI PNP
[   13.786250] PCI: Using ACPI for IRQ routing
[   13.786259] PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
[   13.813027] NET: Registered protocol family 8
[   13.813036] NET: Registered protocol family 20
[   13.813468] hpet clockevent registered
[   13.813478] hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
[   13.813490] hpet0: 3 64-bit timers, 14318180 Hz
[   13.814586] AppArmor: AppArmor Filesystem Enabled
[   13.817006] Time: tsc clocksource has been installed.
[   13.825115] system 00:01: iomem range 0xfed13000-0xfed19fff has been reserved
[   13.825140] system 00:08: ioport range 0x380-0x383 has been reserved
[   13.825148] system 00:08: ioport range 0x4d0-0x4d1 has been reserved
[   13.825156] system 00:08: ioport range 0x800-0x87f has been reserved
[   13.825164] system 00:08: ioport range 0x480-0x4bf has been reserved
[   13.825172] system 00:08: iomem range 0xfed1c000-0xfed1ffff has been reserved
[   13.825180] system 00:08: iomem range 0xfed20000-0xfed8ffff has been reserved
[   13.825189] system 00:08: iomem range 0xfff00000-0xffffffff could not be reserved
[   13.825204] system 00:09: iomem range 0xfec00000-0xfec00fff has been reserved
[   13.825213] system 00:09: iomem range 0xfee00000-0xfee00fff could not be reserved
[   13.825227] system 00:0a: iomem range 0xe0000000-0xefffffff has been reserved
[   13.825242] system 00:0b: iomem range 0xe0000000-0xefffffff has been reserved
[   13.825257] system 00:0c: iomem range 0x0-0x9ffff could not be reserved
[   13.825265] system 00:0c: iomem range 0xc0000-0xcffff could not be reserved
[   13.825273] system 00:0c: iomem range 0xe0000-0xfffff could not be reserved
[   13.825282] system 00:0c: iomem range 0x100000-0x3f7fffff could not be reserved
[   13.825290] system 00:0c: iomem range 0x0-0x0 could not be reserved
[   13.856390] PCI: Bridge: 0000:00:1c.0
[   13.856395]   IO window: disabled.
[   13.856404]   MEM window: disabled.
[   13.856411]   PREFETCH window: disabled.
[   13.856420] PCI: Bridge: 0000:00:1c.1
[   13.856424]   IO window: disabled.
[   13.856433]   MEM window: fbf00000-fbffffff
[   13.856440]   PREFETCH window: disabled.
[   13.856449] PCI: Bridge: 0000:00:1c.2
[   13.856452]   IO window: disabled.
[   13.856461]   MEM window: f8000000-fbefffff
[   13.856469]   PREFETCH window: f0000000-f6ffffff
[   13.856478] PCI: Bridge: 0000:00:1e.0
[   13.856481]   IO window: disabled.
[   13.856489]   MEM window: disabled.
[   13.856496]   PREFETCH window: disabled.
[   13.856547] ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 16
[   13.856561] PCI: Setting latency timer of device 0000:00:1c.0 to 64
[   13.856591] ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 17 (level, low) -> IRQ 17
[   13.856603] PCI: Setting latency timer of device 0000:00:1c.1 to 64
[   13.856632] ACPI: PCI Interrupt 0000:00:1c.2[C] -> GSI 18 (level, low) -> IRQ 18
[   13.856643] PCI: Setting latency timer of device 0000:00:1c.2 to 64
[   13.856661] PCI: Setting latency timer of device 0000:00:1e.0 to 64
[   13.856693] NET: Registered protocol family 2
[   13.893164] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
[   13.893806] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
[   13.895961] TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
[   13.897297] TCP: Hash tables configured (established 131072 bind 65536)
[   13.897305] TCP reno registered
[   13.909412] checking if image is initramfs...<7>Switched to high resolution mode on CPU 0
[   14.808969]  it is
[   15.786328] Freeing initrd memory: 7228k freed
[   15.787737] audit: initializing netlink socket (disabled)
[   15.787771] audit(1205966951.196:1): initialized
[   15.788189] highmem bounce pool size: 64 pages
[   15.793394] VFS: Disk quotas dquot_6.5.1
[   15.793604] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[   15.793969] io scheduler noop registered
[   15.793977] io scheduler anticipatory registered
[   15.793982] io scheduler deadline registered
[   15.794015] io scheduler cfq registered (default)
[   15.794046] Boot video device is 0000:00:02.0
[   15.794421] PCI: Setting latency timer of device 0000:00:1c.0 to 64
[   15.794484] assign_interrupt_mode Found MSI capability
[   15.794543] Allocate Port Service[0000:00:1c.0:pcie00]
[   15.794673] Allocate Port Service[0000:00:1c.0:pcie02]
[   15.794861] PCI: Setting latency timer of device 0000:00:1c.1 to 64
[   15.794922] assign_interrupt_mode Found MSI capability
[   15.794974] Allocate Port Service[0000:00:1c.1:pcie00]
[   15.795069] Allocate Port Service[0000:00:1c.1:pcie02]
[   15.795228] PCI: Setting latency timer of device 0000:00:1c.2 to 64
[   15.795289] assign_interrupt_mode Found MSI capability
[   15.795340] Allocate Port Service[0000:00:1c.2:pcie00]
[   15.795430] Allocate Port Service[0000:00:1c.2:pcie02]
[   15.796003] isapnp: Scanning for PnP cards...
[   16.150152] isapnp: No Plug & Play device found
[   16.248904] Real Time Clock Driver v1.12ac
[   16.249144] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[   16.252430] RAMDISK driver initialized: 16 RAM disks of 65536K size 1024 blocksize
[   16.252672] input: Macintosh mouse button emulation as /devices/virtual/input/input0
[   16.252943] PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[   16.285673] serio: i8042 KBD port at 0x60,0x64 irq 1
[   16.285687] serio: i8042 AUX port at 0x60,0x64 irq 12
[   16.296700] mice: PS/2 mouse device common for all mice
[   16.297015] EISA: Probing bus 0 at eisa.0
[   16.297065] EISA: Detected 0 cards.
[   16.297072] cpuidle: using governor ladder
[   16.297077] cpuidle: using governor menu
[   16.297294] NET: Registered protocol family 1
[   16.297362] Using IPI No-Shortcut mode
[   16.297442] registered taskstats version 1
[   16.297679]   Magic number: 0:531:856
[   16.297823]   hash matches device ptyv8
[   16.297841]   hash matches device ptysb
[   16.297929] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[   16.297935] EDD information not available.
[   16.298309] Freeing unused kernel memory: 364k freed
[   16.336553] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input1
[   17.877772] fuse init (API version 7.9)
[   17.903847] ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
[   17.903864] ACPI: Processor [CPU1] (supports 8 throttling states)
[   17.909891] ACPI: EC: non-query interrupt received, switching to interrupt mode
[   17.915371] ACPI: Thermal Zone [TZ00] (52 C)
[   20.012016] usbcore: registered new interface driver usbfs
[   20.012073] usbcore: registered new interface driver hub
[   20.047940] usbcore: registered new device driver usb
[   20.066492] USB Universal Host Controller Interface driver v3.0
[   20.066637] ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 23 (level, low) -> IRQ 19
[   20.066658] PCI: Setting latency timer of device 0000:00:1d.0 to 64
[   20.066668] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[   20.067311] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
[   20.067361] uhci_hcd 0000:00:1d.0: irq 19, io base 0x0000e400
[   20.067686] usb usb1: configuration #1 chosen from 1 choice
[   20.067747] hub 1-0:1.0: USB hub found
[   20.067762] hub 1-0:1.0: 2 ports detected
[   20.168071] ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 19 (level, low) -> IRQ 20
[   20.168098] PCI: Setting latency timer of device 0000:00:1d.1 to 64
[   20.168108] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[   20.168169] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
[   20.168214] uhci_hcd 0000:00:1d.1: irq 20, io base 0x0000e480
[   20.168489] usb usb2: configuration #1 chosen from 1 choice
[   20.168548] hub 2-0:1.0: USB hub found
[   20.168563] hub 2-0:1.0: 2 ports detected
[   20.272053] ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 18
[   20.272080] PCI: Setting latency timer of device 0000:00:1d.2 to 64
[   20.272090] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[   20.272152] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
[   20.272201] uhci_hcd 0000:00:1d.2: irq 18, io base 0x0000e800
[   20.272483] usb usb3: configuration #1 chosen from 1 choice
[   20.272542] hub 3-0:1.0: USB hub found
[   20.272556] hub 3-0:1.0: 2 ports detected
[   20.376038] ACPI: PCI Interrupt 0000:00:1d.3[D] -> GSI 16 (level, low) -> IRQ 16
[   20.376063] PCI: Setting latency timer of device 0000:00:1d.3 to 64
[   20.376073] uhci_hcd 0000:00:1d.3: UHCI Host Controller
[   20.376137] uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
[   20.376183] uhci_hcd 0000:00:1d.3: irq 16, io base 0x0000e880
[   20.376453] usb usb4: configuration #1 chosen from 1 choice
[   20.376514] hub 4-0:1.0: USB hub found
[   20.376528] hub 4-0:1.0: 2 ports detected
[   20.446324] SCSI subsystem initialized
[   20.480082] ACPI: PCI Interrupt 0000:00:1d.7[A] -> GSI 23 (level, low) -> IRQ 19
[   20.480113] PCI: Setting latency timer of device 0000:00:1d.7 to 64
[   20.480122] ehci_hcd 0000:00:1d.7: EHCI Host Controller
[   20.480195] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
[   20.484146] ehci_hcd 0000:00:1d.7: debug port 1
[   20.484157] PCI: cache line size of 32 is not supported by device 0000:00:1d.7
[   20.484173] ehci_hcd 0000:00:1d.7: irq 19, io mem 0xf7eb7c00
[   20.519869] usb 2-2: new low speed USB device using uhci_hcd and address 2
[   20.531784] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[   20.532091] usb usb5: configuration #1 chosen from 1 choice
[   20.532155] hub 5-0:1.0: USB hub found
[   20.532172] hub 5-0:1.0: 8 ports detected
[   20.594427] libata version 3.00 loaded.
[   20.636569] ata_piix 0000:00:1f.2: version 2.12
[   20.636587] ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]
[   20.636648] ACPI: PCI Interrupt 0000:00:1f.2[B] -> GSI 19 (level, low) -> IRQ 20
[   20.636729] PCI: Setting latency timer of device 0000:00:1f.2 to 64
[   20.663763] scsi0 : ata_piix
[   20.690574] scsi1 : ata_piix
[   20.693981] ata1: SATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
[   20.693990] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
[   21.028196] ata2.00: ATA-0: ASUS-PHISON SSD, TST2.03Y, max UDMA/66
[   21.028208] ata2.00: 15761088 sectors, multi 0: LBA
[   21.028245] ata2.00: limited to UDMA/33 due to 40-wire cable
[   21.036098] ata2.00: configured for UDMA/33
[   21.052092] ata2.00: configured for UDMA/33
[   21.052106] ata2: EH complete
[   21.052401] scsi 1:0:0:0: Direct-Access     ATA      ASUS-PHISON SSD  TST2 PQ: 0 ANSI: 5
[   21.139745] usb 5-5: new high speed USB device using ehci_hcd and address 3
[   21.273233] usb 5-5: configuration #1 chosen from 1 choice
[   21.511629] usb 2-2: new low speed USB device using uhci_hcd and address 3
[   21.685317] usb 2-2: configuration #1 chosen from 1 choice
[   22.208080] Driver 'sd' needs updating - please use bus_type methods
[   22.208268] sd 1:0:0:0: [sda] 15761088 512-byte hardware sectors (8070 MB)
[   22.208300] sd 1:0:0:0: [sda] Write Protect is off
[   22.208308] sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
[   22.208352] sd 1:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPOor FUA
[   22.208463] sd 1:0:0:0: [sda] 15761088 512-byte hardware sectors (8070 MB)
[   22.208489] sd 1:0:0:0: [sda] Write Protect is off
[   22.208495] sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
[   22.208536] sd 1:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPOor FUA
[   22.208547]  sda: sda1 sda2 < sda5 >
[   22.211150] sd 1:0:0:0: [sda] Attached SCSI disk
[   22.228210] sd 1:0:0:0: Attached scsi generic sg0 type 0
[   22.348038] usbcore: registered new interface driver libusual
[   22.369962] Initializing USB Mass Storage driver...
[   22.378007] scsi2 : SCSI emulation for USB Mass Storage devices
[   22.388259] usbcore: registered new interface driver usb-storage
[   22.388275] USB Mass Storage support registered.
[   22.388285] usb-storage: device found at 3
[   22.388290] usb-storage: waiting for device to settle before scanning
[   22.391252] usbcore: registered new interface driver hiddev
[   22.404829] input: Genius Optical Mouse as /devices/pci0000:00/0000:00:1d.1/usb2/2-2/2-2:1.0/input/input2
[   22.415613] input,hidraw0: USB HID v1.10 Mouse [Genius Optical Mouse] on usb-0000:00:1d.1-2
[   22.415654] usbcore: registered new interface driver usbhid
[   22.415665] /build/buildd/linux-2.6.24/drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
[   22.597115] Attempting manual resume
[   22.597125] swsusp: Resume From Partition 8:5
[   22.597129] PM: Checking swsusp image.
[   22.597470] PM: Resume from disk failed.
[   22.639607] kjournald starting.  Commit interval 5 seconds
[   22.639643] EXT3-fs: mounted filesystem with ordered data mode.
[   22.811370] Clocksource tsc unstable (delta = -6959274376 ns)
[   22.815352] Time: hpet clocksource has been installed.
[   25.859631] usb-storage: device scan complete
[   25.860265] scsi 2:0:0:0: Direct-Access     USB2.0   CardReader SD0   0100 PQ: 0 ANSI: 0
[   25.862080] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[   25.862178] sd 2:0:0:0: Attached scsi generic sg1 type 0
[   27.919271] Linux agpgart interface v0.102
[   27.991411] agpgart: Detected an Intel 915GM Chipset.
[   27.991754] agpgart: Detected 7932K stolen memory.
[   28.407586] agpgart: AGP aperture is 256M @ 0xd0000000
[   29.003312] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   29.063567] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   29.434954] intel_rng: FWH not detected
[   29.722905] iTCO_vendor_support: vendor-support=0
[   29.798911] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.02 (26-Jul-2007)
[   29.799255] iTCO_wdt: Found a ICH6-M TCO device (Version=2, TCOBASE=0x0860)
[   29.799361] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[   30.539129] input: Power Button (FF) as /devices/virtual/input/input3
[   30.554760] ACPI: Power Button (FF) [PWRF]
[   30.555063] input: Lid Switch as /devices/virtual/input/input4
[   30.566804] ACPI: Lid Switch [LID]
[   30.567009] input: Sleep Button (CM) as /devices/virtual/input/input5
[   30.579449] ACPI: Sleep Button (CM) [SLPB]
[   30.579668] input: Power Button (CM) as /devices/virtual/input/input6
[   30.594689] ACPI: Power Button (CM) [PWRB]
[   33.938093] Attansic(R) L2 Ethernet Network Driver - version 1.0.40.2
[   33.938103] Copyright (c) 2006 Attansic Corporation.
[   33.940103] ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
[   33.940128] PCI: Setting latency timer of device 0000:03:00.0 to 64
[   34.069258] ath_hal: module license 'Proprietary' taints kernel.
[   34.166066] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[   34.638930] wlan: 0.8.4.2 (0.9.3.3)
[   34.714263] input: PC Speaker as /devices/platform/pcspkr/input/input7
[   34.905890] ath_pci: 0.9.4.5 (0.9.3.3)
[   34.906902] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 18 (level, low) -> IRQ 18
[   34.906926] PCI: Setting latency timer of device 0000:01:00.0 to 64
[   34.955163] wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
[   34.955195] ACPI: PCI interrupt for device 0000:01:00.0 disabled
[   35.086761] ACPI: AC Adapter [AC0] (off-line)
[   35.298775] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input8
[   35.309757] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[   38.693530] ACPI: Battery Slot [BAT0] (battery present)
[   40.190372] Synaptics Touchpad, model: 1, fw: 6.3, id: 0x180b1, caps: 0xa04753/0x200000
[   40.281695] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input9
[   40.893199] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 16
[   40.893250] PCI: Setting latency timer of device 0000:00:1b.0 to 64
[   44.584244] lp: driver loaded but no devices found
[   44.620066] usbcore: registered new interface driver cdc_acm
[   44.620080] /build/buildd/linux-2.6.24/drivers/usb/class/cdc-acm.c: v0.25:USB Abstract Control Model driver for USB modems and ISDN adapters
[   45.110533] Adding 385520k swap on /dev/sda5.  Priority:-1 extents:1 across:385520k
[   45.144555] EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
[   45.144953] EXT3 FS on sda1, internal journal
[   46.132544] ip_tables: (C) 2000-2006 Netfilter Core Team
[   46.897942] No dock devices found.
[   47.163572] toshiba_acpi: Unknown parameter `hotkeys_over_acpi'
[   49.612731] NET: Registered protocol family 10
[   49.614268] lo: Disabled Privacy Extensions
[   49.733557] ppdev: user-space parallel port driver
[   49.932967] audit(1205966995.693:2): operation="inode_permission" request_mask="a::" denied_mask="a::" name="/dev/tty" pid=4865 profile="/usr/sbin/cupsd" namespace="default"
[   50.124670] apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
[   50.124683] apm: overridden by ACPI.
[   51.313419] [drm] Initialized drm 1.1.0 20060810
[   51.338934] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 16
[   51.338956] PCI: Setting latency timer of device 0000:00:02.0 to 64
[   51.339156] [drm] Initialized i915 1.6.0 20060119 on minor 0
[   53.976891] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   54.050785] Bluetooth: Core ver 2.11
[   54.052891] NET: Registered protocol family 31
[   54.052902] Bluetooth: HCI device and connection manager initialized
[   54.052911] Bluetooth: HCI socket layer initialized
[   54.219363] Bluetooth: L2CAP ver 2.9
[   54.219375] Bluetooth: L2CAP socket layer initialized
[   54.351245] Bluetooth: RFCOMM socket layer initialized
[   54.352310] Bluetooth: RFCOMM TTY layer initialized
[   54.352320] Bluetooth: RFCOMM ver 1.8
[   94.734429] usb 1-2: new full speed USB device using uhci_hcd and address 2
[   94.933714] usb 1-2: configuration #1 chosen from 1 choice
[   95.529067] usbcore: registered new interface driver cdc_ether
[   97.183811] rndis0: register 'rndis_host' at usb-0000:00:1d.0-2, RNDIS device, 80:00:60:0f:e8:00
[   97.184515] usbcore: registered new interface driver rndis_host
[  102.002552] rndis0: no IPv6 routers present
[  103.196392] usbcore: registered new interface driver usbserial
[  103.197751] /build/buildd/linux-2.6.24/drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
[  103.199804] usbcore: registered new interface driver usbserial_generic
[  103.199818] /build/buildd/linux-2.6.24/drivers/usb/serial/usb-serial.c: USB Serial Driver core
[  103.221355] /build/buildd/linux-2.6.24/drivers/usb/serial/usb-serial.c: USB Serial support registered for PocketPC PDA
[  103.221372] /build/buildd/linux-2.6.24/drivers/usb/serial/ipaq.c: USB PocketPC PDA driver v0.5
[  103.224696] usbcore: registered new interface driver ipaq
marietto@marietto2008:~$

This part should have created the /dev/ttyUSB0 device.
usbcore: registered new interface driver usbserial_generic
/build/buildd/linux-2.6.24/drivers/usb/serial/usb-serial.c: USB Serial Driver core
/build/buildd/linux-2.6.24/drivers/usb/serial/usb-serial.c: USB Serial support registered for PocketPC PDA

I'll try to get a hand on an MSMobile device, to see what happens on my system...
#modprobe ipaq
results in the following in dmesg after pluggin in a device.
usb 5-2: new full speed USB device using ohci_hcd and address 3
usb 5-2: configuration #1 chosen from 1 choice
ipaq 5-2:1.0: PocketPC PDA converter detected
usb 5-2: PocketPC PDA converter now attached to ttyUSB0

#ls -l /dev/ttyUSB*
crw-rw---- 1 root uucp 188, 0 Mar 21 21:15 /dev/ttyUSB0

Subsequently I tried to access the device using the synce tools, and those start a pppd session to the device. The WinCE device in question is a GPS route planner, and unfortunately has no modem on board.
The use of pppd suggests that the ttyUSB is just a serial connection. (pppd is used to connect IP, DECnet and some other networks over a serial/modem/isdn links
I don't see any /dev/ttyUSB* device. what to do now ?

problem is not have been fixed,but you have helped very much.