Link to home
Create AccountLog in
Avatar of bscriv77
bscriv77

asked on

New Windows XP Home install will not connect to the internet

I recently "downgraded" a machine of ours to Windows XP Home Edition from Vista Business Edition. Long story short, certain programs were not completely compatible with Vista and the easiest solution was to reformat and put Windows XP Home on it. The PC is a store-bought HP that, of course, has their "recovery partition" on it. When I initiated the Windows XP Home installation (from a brand new disc we just purchased), I opted to leave the recovery partition alone and just reformat the C drive.

That part was successful and I was able to load Windows XP Home onto the machine. At the time of installation the machine was not connected to the internet. I did not activate it as I was planning on doing that when I took the machine to it's final location (I had it in my office at the time). However, when I set it up in my co-worker's office and plugged in an ethernet cord (connected to a working network - I double checked as the same cord was connected to a computer sitting right next to this one), this machine would not recognize the connection.

I restarted and entered the set up menu in the BIOS and onboard LAN was enabled, but still nothing. I even ran the Network Set Up Wizard and that did nothing. I also looked in the Device Manager and saw that the driver was installed for the ethernet card.

Why can't I get it to recognize the internet/network? Aside from leaving the recovery partition on there, it's a fresh installation. Any ideas?
Avatar of theProfessa
theProfessa
Flag of United States of America image

Plug the computer into the network.

Start - Run - type in "CMD" without quotes
type in IPCONFIG
Are you getting an IP address that starts like this: 169.254.x.x?
If so download and run this program:
http://www.majorgeeks.com/download4372.html

If that is not the case can you give us a bit more information on your network setup.
If you can also tell us what your full IP settings are that would be helpful
You can do this by typing in IPCONFIG /ALL
Avatar of madmanmatt
madmanmatt

You getting any IP address?  Have you try releasing and renewing the IP?  Is that system a desktop or laptop?
XP Home has the limitation that it does not support connection to domain network, i.e. login to a domain. If this is what your machine suppose to do, it needs XP professional.
Avatar of bscriv77

ASKER

Ok, I just tried running IPCONFIG on that machine and it doesn't even come up with an IP address. It just says "Windows IP Configuration" and goes back tot he prompt. Weird. Why would it do that?
I'm beginning to think that the ethernet card is not being recognized after all. I just tried going into the Device Manager on my machine and saw two things under Network Adapters: 1394 Net Adapter, and my netwrok card. On that machine, all I see is the 1394 Net Adapter. Could that be it?
Replace the network card if it is not recognised in the device manager.
I would download the latest version of the driver and run the Add Hardware Wizard
I believe it's onboard...
Yup...it's an onboard LAN: 10/100 Marvell 88EC031
I would go to your motherboard manufacturer's website and download the Ethernet driver.
ASKER CERTIFIED SOLUTION
Avatar of theProfessa
theProfessa
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Are you sure the onboard LAN is not  DISABLED in your Bios setting?
I just downloaded the ethernet driver and tried installing it on the machine. It got almost all the way through set up and could not complete it. It just said set up was unsuccessful. I also just tried running the nVidia driver update which seemed to complete successfully but didn't change anything.

Could something in the BIOS be preventing it from allowing Windows XP to see and load drivers for the the components? A weird question, I know, but there doesn't seem to be any other reason for Windows XP not to see all the included components.
Yea, and just to be sure you stated that you already checked the BIOS settings right?

Let me see what else I can dig up
Well, I got into the BIOS and made sure the LAN was enabled (which it was), but no other settings looked off to me. Anything in particular I should check on?
I suggest to disable the onboard LAN and put in a network card since 10/000 NIC is dirt cheap nowady. Time spent will not be worthwhile in "digging for the absolute truth" in a business environment. But, it's just me. Good luck.
Well, I fixed the problem...downloaded the correct nVidia chipset drivers and they took...phew! Thanks for all the help!
Glad I could be of assistance, sorry I wasn't able to direct you to the actual driver, but I'm glad that resolved your problem!
In device manager.  Goto your network card.  Right click / Properties/  Click the power management tab.

Make sure the "allow the computer to turn off this device to save power" is unchecked.  I believe you have to reboot after this.

I had a similar problem with my PC.  I also have the 1394 and Marvel network adapter.  In my case.  I have 2 network ports.  One network port was defective.  When the cable is plugged in.  The LED light would remain red. (faulty).  I had to goto into the BIOS and disable 1 of the network adapters in order to connect back to the internet.  Try disabling your primary network card.  See if you can connect.  If not. Re-enable it, and disable the secondary adapter in the BIOS.