Link to home
Start Free TrialLog in
Avatar of webenerds
webenerdsFlag for United States of America

asked on

DCOM Error 10004 - changed local admin password

We recently were purchased by another company and are migrating servers to the new domain.  We have one server that ran a few backups for us using NTBackup and ever since moving it to the new domain and changing the local admin password it has been having DCOM errors almost every minute.

Event Type:      Error
Event Source:      DCOM
Event Category:      None
Event ID:      10004
Date:            3/6/2008
Time:            12:47:29 PM
User:            N/A
Computer:      Computer
Description:
DCOM got error "Logon failure: unknown user name or bad password. " and was unable to logon Computer\administrator in order to run the server:
{722B92C5-ABCB-4D6A-9814-9A296E8D0639}

I've searched thru all services and none of those services use the local admin account, I've run thru dcomcnfg and the above credentials are not listed on any service on the Identity tab and I cant find what I think is an CLSID listed in the error above in the registry.

Where might I look to find what is trying to authenticate?

As a result the ntbackup error dumps this:

Event Type:      Error
Event Source:      NTBackup
Event Category:      None
Event ID:      8012
Date:            3/6/2008
Time:            12:43:50 PM
User:            N/A
Computer:      Computer
Description:
The 'ESE API' returned 'Unable to perform the operation. Either you can not connect to the specified server
or the service you are trying to connect to is not running.
' from a call to 'HrESEBackupRestoreNodes()' additional data 'Computer'

I'm not backing up exchange which is what this error is somehow tied to so not sure the relevance.  But something is not starting that is pivotal to ntbackup as far as I can tell and it continually locks the local admin account after X failed attempts to authenticate.

Help much appreciated.


ASKER CERTIFIED SOLUTION
Avatar of Nuno Martins
Nuno Martins
Flag of Portugal image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of webenerds

ASKER

Tried a few of the solutions mentioned that seemed relavent to my process all w/ no success.

tried running the script from the inetpub/adminscripts dir
Unjoined from the domain and rejoined and the dcom error is gone but no ntbackup still generates some odd error.  I'll close this ticket and open another for that problem.

Thanks
ok, but why shoud i refund points if i didn´t get any?
Well, actually I was trying to give you some of the points.....dont know how I screwed that up.....let me try that again.
While I didnt get a complete solution for this problem based on the reply it pointed me in the right direction and helped me along.
Avatar of kodiakbear
kodiakbear

nfmartins,
You were awarded 500 points with a B grade for this question,
Why do you think you didn't get any points ? Or needed to refund any ?

Please post here so I can attempt to figure this out
https://www.experts-exchange.com/questions/23222709/Working-Automated-Request-for-Review-PAQ-Q-23220449.html

kb
Experts Exchange Moderator