Link to home
Create AccountLog in
Avatar of Oestonee
OestoneeFlag for United States of America

asked on

Net Send Error

I am trying to use Net Send on a Domain Controller to a client on the network.   For example:
C:\> Net Send L6968 TEST

The error I receive is the notorious:

An Error occurred while sending a message to L6968
The message alias could not be found on the network.
More help is available by typing NET HELPMSG 2273


Server - Windows Server 2003 standard (updated  with all critical updates) I've tried to send from 4 different servers including my Exchange sever, a print server, Domain Controller and a Virtual Server all 2003

Client Windows XP or Vista (current on updates) I've attempted both
Yes - messenger and  alert services and running, set to automatic on both client and server (And yes I stopped and restarted just to be safe)
No firewall is enabled on client, No ports blocked internally.
The client computer name is listed in Net  View
Does not work with computer name, user name, full computer name (including domain)  OR IP Address but I can ping the computer using the computer name.

There are no group policies limiting messaging.

Anyone have any ideas??
Avatar of tboy6423
tboy6423
Flag of United States of America image

If you disable the windows firewall (on the XP machine), are you able to send?
If in windows firewall, File and Printer sharing is not enabled, you will get this error, if you don't want to enable that , you add port TCP 139
Avatar of Oestonee

ASKER

The firewall isn't enabled at all
What do you use for your firewall?
Use this syntax for net send, your missing the domain name
{name | * | /DOMAIN[:name] | /USERS} message
tboy

Cisco ASA. The firewall is configured for External Traffic only.   I've never had to use the doamin name before, but it still doesn't work.
Is messenger set up as automatic? I am trying to recreate this error ....
Yes.... I stopped and restarted too.
Type in nbtstat -n Are there any unregistered?
All have a status registered -
Ok Try and enable NetBios over TCP/IP on the XP boxes, that should fix this issue:
Control Panel, network connections, right click on local area connection, properties, highlight Itnernet Protocol, select properties,select advanced on general tab, on the WINS tab, enable NetBios over TCP/IP
It is already enabled..... but thanks for the suggestion
Ok i am going to do some more research see if i can come up with whats causing it, strange..
Thanks Tboy... I've been all over technet and google..... 20 years in IT and I've never seen this before.
Same here, the usual and unusual fixes don't seem to work, which leads me to believe it's most likely an easy fix that we are missing...I will keep testing..
THANKS! If it helps the test boxes are on the same subnet. So I'm confused why it's not working...
Are you using static IPs or DHCP
DHCP mostly... the servers of course have static and my boxes... but the clients aren't.
When you checked the NetBios ever TCP/IP on the XP machine, was it the 2nd setting, where it says just "Enable NetBios...
Yes
ok just checking..
have you tried a net send to yourself( on the server) net send yourPCname hello...What happens?
Same error... I thought it was because I am on Vista... so I swiched to an XP client. I've tried 4 different servers and 4 different clients ... same results. Confusing isn't it?
And they are all in your test enviroment on the same domain?
hmm mabye it has something to do with the local security policy...
In services is windows firewall disabled and stopped completely?
Yes tboy... same domain; even the same subnet, no security problems our users are local admins; firewall is completely disabled..... when did DOS get so complicated??
ASKER CERTIFIED SOLUTION
Avatar of tboy6423
tboy6423
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
That worked! THANKS Tboy!
Tboy was a great help!
weird huh??? told you it was going to be something simple... :)
Avatar of Trex0314
Trex0314

Where was this "New Windows Messenger" downloaded from?
I downloaded mine from here:
http://get.live.com/messenger/config 
I had this same problem.  After trying everything on this thread and a bunch more things, I discovered that the computer that I was trying to NET SEND to wasn't registered on the DNS server.  On the client (target) computer, I opened properties for the TCP/IP connection (properties >> tcp/ip connection >> advanced >> dns tab) and checked the box labeled "Register the connections addresses in DNS" and renewed the IP address.  Instant success.
ACSIPaul's suggestion and setting the Network properties from a working PC helped to solve this.
wow...i have exactly the same problem !!
Net send was working two days ago and not anymore (although it works for the entire doamin...net send domaine_name works)
anyways..i'm going to try your solution ;-)