Link to home
Create AccountLog in
Avatar of brianadixon
brianadixonFlag for United States of America

asked on

How can I resolve an "The remote computer disconnected the session because of an error in the licensing protocol" error message?

I have two terminal servers on my network one lets call Server1 and the other called Server2. Both servers are running Windows Server 2000. However sometimes when a user tried to connect to Server2 they get the error "The remote computer disconnected the session because of an error in the licensing protocol."

A quick fix for them is to terminal service into Server1 (dont have to login, just hit the server) Then they are able to log into Server2.

I have tried removing the MSLicensing key and that doesnt do anything. I am sure this has something to do with the Windows Terminal Server Licensing. Could someone please help me out with this?

Thanks alot in advance!!
ASKER CERTIFIED SOLUTION
Avatar of LaserSpot
LaserSpot

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of brianadixon

ASKER

Thanks for the reply... I have a question about that.

In these instructions number 5 says "Add the License Server machine name and click OK". Which is my License server? Is it talking about Server2 or my DC?


Publishing a License Server 
 
We can manually publish the Terminal Server License Server, using one of the following two methods,
 
Using "Active Directory Sites and Services":
 
1. Open the "Active Directory Sites and Services" snapin; Start -> Programs -> Administrative tools -> "Active Directory Sites and Services" 
2. Select the Site in which you wish to publish the Terminal Server License Server 
3. Open the "TS-Enterprise-License-Server" Object.  If the "TS-Enterprise-License-Server" object is does not exist, you may have to create it. See below. 
4. Under the "Licensing Setting" tab click on the "Change" button 
5. Add the License Server machine name and click OK

Open in new window

I did notice if I open the "Licensing Site Settings" the "Licensing Computer" says Computer: Invalid and Domain: Invalid.

Hopefully this helps explain my problem
Avatar of LaserSpot
LaserSpot

TS licensing should be running on your DC. Is the license server object pointing to a defunct server?
Neither one were pointed to a server. So both "Licensing Site Settings" and "TS-Enterprise-License-Server" should be pointing to my active DC?
Thanks!!
please check whether the terminal server can locate the terminal license server. This is the prerequisite for terminal license to work. If  so, please perform the following steps on the problematic client to test  this problem again:  
 
1.      Start Registry Editor (Regedit.exe).  
2.      Locate and then click the following key in the registry:  
HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing  
3.      Delete the whole MSLicensing key from the registry.  
4.      Quit Registry Editor.  
5.      Connect to the Terminal Services server.