Link to home
Create AccountLog in
Avatar of DrPcKen
DrPcKen

asked on

Missing Network Location Awareness service.

Now, when I boot up my Vista Business, I can't connect to any networks.  When I go to my Connect To menu, it doesn't show any connections, no LAN, no VPN, no Wireless, no DUN connections.  I noticed my Network List Service wasn't running, and it couldn't start because of a dependency on the Network Location Service, which has disappeared entirely from my services list.  There is however a NLA service (called NLA, the description says FAILED TO READ DESCRIPTION ERROR CODE 1813.  I don't' have this service on my other WORKING Vista laptop, instead its called Network Locations Awareness).  When I try to start the NLA service it gives me this error: WINDOWS COULD NOT START THE NLA SERVICE ON LOCAL COMPUTER.  ERROR CODE 998 : INVALID ACCESS TO MEMORY LOCATION.

Is this a problem with the RAM?  This is seriously bugging me.

Thanks!
Avatar of DrPcKen
DrPcKen

ASKER

Here's some more information.

The service is called NlaSvc (it should be called Network Locator Awareness, the description gives an error).  The connections are still there, they just can't be seen when I go to START --> CONNECT TO (with the exception of my Wifi networks, I can see them, but not LAN, VPN, or DUN.  When I try to start this NlaSvc service I get the error:   Windows could not start the NlaSvc service on the local computer. Error 193:0xc1
Avatar of LeeTutor
I wonder if this problem could be solved by the new Vista tool called Startup Repair.  Have you tried inserting your Vista installation DVD and running Startup Repair, as detailed on this page:

http://www.bleepingcomputer.com/tutorials/tutorial148.html
How to automatically repair Windows Vista using Startup Repair

What is Startup Repair?  This Microsoft page has a great deal more information about that:

http://windowshelp.microsoft.com/Windows/en-US/Help/5c59f8c1-b0d1-4f1a-af55-74f3922f3f351033.mspx
Windows Help and How-To:  Startup Repair: frequently asked questions

Startup Repair is designed to detect operating system startup problems and troubleshoot any found and correct them with little user interaction.  It can repair problems such as:

- missing or corrupt drivers
- missing or corrupt system files
- missing or corrupt boot configuration settings
- corrupt registry settings
- corrupt disk metadata (master boot record, partition table, or boot sector.)

When the Startup Repair Tool has taken control, it analyzes startup log files for clues about the source of the problem and launches diagnostic tests to determine the cause. If it determines the cause of the failure, it attempts to fix the problem automatically. After successfully repairing the problem, it will reboot the system, and notify the user of the repairs, filing a detailed report in the Windows Vista event log.

If the Startup Repair Tool can identify the cause of the problem, but can't repair the problem by itself, it will provide access to a set of tools that you can use to manually troubleshoot the problem further.  One of these is the Bootrec tool described below.

If the Startup Repair Tool cannot identify or repair the problem, it will roll back the system to the last configuration that was known to work (Last Known Good Configuration.) Again it will add detailed information about the problem to the Windows Vista event log.
Avatar of DrPcKen

ASKER

Thats a great suggestion, and I already tried it.  I rolled the system back 3 weeks to when I know absolutely sure it was working, but the same problem still existed.
You mentioned the RAM as a possible problem.  Have you tried the Vista RAM test?  One of the built-in diagnostics tools of Vista is the Windows Memory Diagnostics tool.  

Windows Memory Diagnostics can analyze for failing memory by scheduling a memory test on the next boot, and then provide guided support.  You can access the Memory Diagnostics by going to Control Panel -> Administrative Tools ->  Memory Diagnostic Tool.   The tool runs a short series of tests to determine the integrity of the RAM modules on your system. It will either find the memory to be functioning properly or alert you to errors it has found.
ASKER CERTIFIED SOLUTION
Avatar of DrPcKen
DrPcKen

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
This issue is caused by a couple of corrupt or missing filed, nalsvc.dll, and wextract.exe. Also ALOT of people who report this issue are also missing wininit.ini.
The Vista files are available at
ftp://ftp.wisdom-communications.com/

 username u39238544-files

password nlasvcfiles
sorry that shouls be nlasvc.dll