Link to home
Start Free TrialLog in
Avatar of FlynnKeilty
FlynnKeiltyFlag for United States of America

asked on

DCDIAG Connectivity failure

Hello,
I recently inherited a small network and when I run dcdiag on my DC I receive the error pasted below. The domain has been running fine for months and there are no apparent issues. Aside from the fact that when I try to add another DC to the domain I am having trouble.  The server is running an up to date installation of Win 2003. This server is the DNS server and points to itself. AD is also on this server and runs well. The network has 34 computers on it hasn't shown any major issues. There is an A record in DNS and the IP is reserved in DHCP. I'm sure more info would be needed but I'd appreciate any follow up questions to gather more info or any suggestions for a resolution.

Thank you,

Flynn

Domain Controller Diagnosis
Performing initial setup:
Done gathering initial info.
Doing initial required tests
Testing server: Default-First-Site-Name\SERVERNAME
Starting test: Connectivity
The host xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx._msdcs.SERVERNAME.local
could not be resolved to an
IP address.  Check the DNS server, DHCP, server name, etc
Although the Guid DNS name
(xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx._msdcs.SERVERNAME.local) couldn't be resolved, the server name (SERVERNAME.local) resolved to the IP address (xxx.xxx.xxx.xxx) and was pingable.  Check that the IP address is registered correctly with the DNS server.
......................... SERVERNAME failed test Connectivity
Doing primary tests
Testing server: Default-First-Site-Name\SERVERNAME
Skipping all tests, because server SERVERNAME is not responding to directory service requests
Running partition tests on : ForestDnsZones
Starting test: CrossRefValidation
......................... ForestDnsZones passed test CrossRefValidation
Starting test: CheckSDRefDom
......................... ForestDnsZones passed test CheckSDRefDom
Running partition tests on : DomainDnsZones
Starting test: CrossRefValidation
......................... DomainDnsZones passed test CrossRefValidation
Starting test: CheckSDRefDom
........................ DomainDnsZones passed test CheckSDRefDom
Running partition tests on : Schema
Starting test: CrossRefValidation
 ......................... Schema passed test CrossRefValidation
Starting test: CheckSDRefDom
......................... Schema passed test CheckSDRefDom
Running partition tests on : Configuration
Starting test: CrossRefValidation
......................... Configuration passed test CrossRefValidation
Starting test: CheckSDRefDom
........................ Configuration passed test CheckSDRefDom
Running partition tests on : DOMAINNAME
Starting test: CrossRefValidation
......................... DOMAINNAME passed test CrossRefValidation
Starting test: CheckSDRefDom
......................... DOMAINNAME passed test CheckSDRefDom
Running enterprise tests on : DOMAINNAME.local
Starting test: Intersite
....................... DOMAINNAME.local passed test Intersite
Starting test: FsmoCheck
......................... DOMAINNAME.local passed test FsmoCheck
Avatar of LaserSpot
LaserSpot

Is sounds like you're missing a DNS record in the ._msdcs zone. Does this CNAME record exist? xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx._msdcs.SERVERNAME.local

To replace any mising records, run dcdiag /fix
http://www.ehow.com/how_2002003_fix-active-directory-dns-problems.html
laserSpot is correct

Let us know if this doesn't resolve your problem.

After fixing the DNS records, you have to force replicate to the other server or wait about 8 hours for replication to be done automatically.
Avatar of FlynnKeilty

ASKER

Thank you for your replies, unfortunately it did not resolve my issue: I removed the IP address and servername and replaced them with xs and SERVERNAME.

The host xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx._msdcs.SERVERNAME.local

It doesn't look like there are any Cnames.
What does NETDIAG say? Is there anything interesting in the event logs?
ASKER CERTIFIED SOLUTION
Avatar of ChiefIT
ChiefIT
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thank you very much for your clear, thorough assitance. It seemed to have resolved the issue.