Link to home
Create AccountLog in
Avatar of I_play_with_DNA
I_play_with_DNA

asked on

Large e-mail appearing in local delivery queue; bogs down Exchange

Background (sorry it's long):

Recently, we started having a delay in the delivery of incoming and internally sent e-mail to local mailboxes.  I noticed that e-mails were starting to pile up in the local delivery queue but were not being delivered.  I took at look at the local delivery queue folder (D:\Program Files\Exchsrvr\Mailroot\vsi 1\Queue) and there were a pile of .EML files in there (obviously the delayed e-mails).  Among those files, these was one that was 647 MB in size.  I figured that this was what was choking up Exchange, so I tried to delete it, but of course, it was 'in use'.  I tried to shut down Exchange but the Information Store service would not stop; I believe that it was churning away on this 647 MB e-mail file in the queue.  I was forced to End Task on store.exe (I HATE doing this) to relase the file so I could delete it.  Once deleted, I restarted Exchange and all the delayed e-mail inthe queue was immediately delivered and everything went back to normal.

This has happened twice more since the first occurrance, so my questions are:

1)  Where is this massive .EML file coming from and how is it getting into my local delivery queue?
2)  I'm pretty sure I have my SMTP configured to reject e-mails of this size, but what settings specifically should I be checking to make sure?  Exchange is also configured to prevent anyone internal from sending an e-mail of that size.

Also, I have saved a copy of the .EML file, but I can't open it; my computer chokes on it because of its size.
Avatar of Lee025_
Lee025_
Flag of Australia image

The best way to find out where it's coming from is to check the queue from system manager on the exchange server.

Open system manager and go to administrative groups, "admin group name",servers,"server name",queues

You will then see a list of the queues, find the relevant queue, right click on ti and select find messages. Don't put anything in the window that pops up just click find now and you will get a list of all messages in the queue, that should give you the info you need.

You may also be able to find it in the message tracking center under tools in system manager. Just put the relevant dates in and see what comes back.

Hope that helps.

Lee
ASKER CERTIFIED SOLUTION
Avatar of abhaigh
abhaigh
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of I_play_with_DNA
I_play_with_DNA

ASKER

@Lee025

Nothing shows up in message tracking for that particular message.  I looked at the size column in message tracking, but there were no e-mails listed that day that were larger than 4 MB.  I didn't check "Find Messages" in the System Manager/queues this time, but the last two times it didn't show up there either, even though the file was in the queue folder.

@abhaigh

The message size was already set to 20 MB on my outbound SMTP connecter, but the limits weren't set on my virtual server.  I think what happened was at some point the virtual server was re-created but not fully configured.