Link to home
Start Free TrialLog in
Avatar of Shaunwh
Shaunwh

asked on

ISA and OWA Issue - Unable to delete email

I have a problem that i'm at a loss to figure out, I have a ISA 2006 proxy server and an exchange 2003 server with OMA configured to allow users access internal when they move from desk to desk.
The Issue that i'm having is when i have the proxy configured in IE i can access the OWA and view all my emails but I can't move them or delete them from the first screen. If i open any email  up i can click the delete button and the message goes, If i remove the proxy server from IE there is no issue.....
Avatar of Keith Alabaster
Keith Alabaster
Flag of United Kingdom of Great Britain and Northern Ireland image

In the first line you mention OMA - was that just a typo or are you running both?

Have you deployed the ISA2006 supportability pack to the ISA server?
Have you disabled the pop-up blocker for the OWA site?
Avatar of Shaunwh
Shaunwh

ASKER

Sorry it is OWA not OMA, this was a typo.
Have you deployed the ISA2006 supportability pack to the ISA server?
Have you disabled the pop-up blocker for the OWA site?
Avatar of Shaunwh

ASKER

I have not deployed the ISA2006 supportability pack nor the pop up blocker for OWA site, the Site is currenlty running IE6.
Support pack should be deployed. Pop-up blocker is part of ie6 (sp1 I think) so you likely already have it installed. A number of frames that OWA uses are treated as pop-ups - thats why I mention it as we were caught out by it also. Can you check?



Avatar of Shaunwh

ASKER

OK Im looking at the pop blocker and Support pack now. Thanks Keith
I will detail my environment this may help with the issue that Im having
Windows 2003 Std Server
ISA2006
GFI Web Monitor

I have setup ISA 2006 as an edge firewall, integrated authentication so it will not prompt the users.
I have created a local access rule for the local network (local host + internal to internal) this looked to be the only way that i could get access to internal web pages.
I have configured a GPO with the details of the server  isa01.XXX.local port 8080, Ticked bypass proxy for local address.

1)Now this is were it gets a little funny i click on the link from the intranet page io then can access the http://192.168.75.12/exchange it asks me for my username and password (this is what i want) and i get access to the OWA i can read and move to different folders but i'm unable to delete.

2) If I added the ip addresses to the exceptions and open up the intranet page and click on the OWA link it automatically logs me in and I have the ability to delete move messages to other folders etc.

So I think that with the exceptions in it will work but how do I get OWA to ask for a username and password, I don't want it to automatically log in to OWA
When you ran the publishing rule to setup the external access for OWA, it automatically puts in the defaults - have you changed any of the settings within the IIS that hosts the OWA?

If you have, tell me and I can give you a walkthrough that puts the IIS permissions back to how it should be.
http://www.msexchange.org/tutorials/Resetting-OWA-Folder-IIS-security-permissions-Exchange-2003.html


Avatar of Shaunwh

ASKER

The isa server is set as a single network card template. External owa is fine it is internal that is not working corrctly, i have not published any access. Im new to ISA so please forgive my lack of detail, learning as i go.

Many thanks
Shaun
SOLUTION
Avatar of Keith Alabaster
Keith Alabaster
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Shaunwh

ASKER

I have added the ip range to the exception and the problem with OWA has gone, but just like all IT issues i now have another one. When i click on the link to OWA from the intranet page it automatically logs in with the users details. I want it to ask me for the Username and password.

I have intergrated authenication set should i also set basic with in the proxy server?

The internal rule i have is allow all protocols FROM internal & localhost TO internal , should i add the local host in the TO section?
Avatar of Shaunwh

ASKER

Please i really need help....................
Avatar of Shaunwh

ASKER

PLEASE I REALLY NEED HELP
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial