Link to home
Start Free TrialLog in
Avatar of quang051097
quang051097

asked on

When I send a message to an external address with CC to some internal addreses, the external receipient will receive my message with all my internal addresses replaced with question mark symbol.

I am using Outlook connecting to Exchange 2003 to send a message to my friends as follows:

to: <abc@xyz.com>
cc: myfriend@my_email_domain

When he reply my message, only I could receive the replied message, not myfriend. I discovered the reason why myfriend didn't receive the message is that <myfriend@my_email_domain> was replaced by <?????????????>.

Any one could tell me why it so and how to solve my problem.
Thanks a lot in advance.

Avatar of quang051097
quang051097

ASKER

Just add a note that the problem go away when I remove all the internal addresses from Outlook address autocomplete or remove NK2 file.
<<myfriend@my_email_domain
does this have a .com extension? (or .net, .gov, .edu). Sounds possibly like your computer is caching a invalid email address that is only recognized within your network.

Try to send another email, but when you CC your frient actually type out myfriend@my_email_domain.com, don't use whatever outlook has cached.


I hope this helps.  
It is due to the way your friends mail client parses the addresses. What client does he use? Lotus Notes?
Thank you a lot, guys for your quick reply.

@NetAdmin: Yes. But these internal addresses are all valid to outside. I have tested with my own address in CC but it is still the same problem until I delete the NK2 file.

@peakpeak: I use a Barracuda box for antispam. When I look into the outbound message header I could see that the internal addresses in CC already replaced by question mark before reaching to external receipient.
@NetAdmin: In my previous comment, I meant my own address is not in my NK2 file.
Recreate the Outlook profile.
check your reply to email address in your email account setup in outlook.  make sure it correct.  

its under reply email on the general tab of the pop3 email account settings
@NetAdmin: I have the same idea as you. But the problem is still there when I typed full internal address instead of from caching. The outlook just converts it into internal address format.
Do you have any idea how to fix it.
@opie6373: I used Outlook with Exchange 2003. Where could I set up my reply?

@Peakpeak: I will give it a try. Howver, I will have to restore all cached entries.
I don't think the problem is with my reply address because I could receive the reply but not my colleague with <myfriend@my_email_domain> in CC which is replaced by <??????????>
then it is probably in his reply to address settings
This is an important piece of information:

"When I look into the outbound message header I could see that the internal addresses in CC already replaced by question mark before reaching to external receipient"

It means we can rule out recipients client software and concentrate on your equipment only. Is it possible to bypass the Barracuda spam box for testing purposes?
@peakpeak: I will do it at after working hour today.
One more thing to check....
Go to your exchange server. Open up active directory users and computers. Find your friends user account. Right click, properties, email addresses, then check that only valid email addresses are present. Make sure his correct email address is set as primary. exchange 2003 *should* be using your primary address for all reply's (I think).
http://www.petri.co.il/change_primary_email_address_in_exchange_2007.htm

Otherwise, I'm thinking you may have to just recreate your profile, as peak suggested.
Please also note that it happened to many other users in my office. They have the same problem.
Is there any solution beside creating a new profile (or just deleting NK2 file)?
Did this JUST start happening? I'm wondering a reboot of your exchange server wouldn't be the thing to do at this point if it's happening to others as well.
No. It happened to some user before (but not all). For some, I just delete NK2 file and it work. For some other, it didn't work.

By the way, in GAL, the email address column in some user's outlook show in format of "\OU=..." instead of <abc@xyz.org>. I don't know why.
ASKER CERTIFIED SOLUTION
Avatar of David Scott, MCSE
David Scott, MCSE
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thank you very much for your answer. It seems working now. However, there is no "rebuild" option in ESM\GAL but in ESM\OAL. I just rebuild OAL and then download it to the Outlook.
Sorr, opie6373's solution worked in one computer but still doesn't work in other machine.

Still looking for me a solution. I will award 125 points more to one who give me the correct answer.
is the "other client" in cached mode?  if so take them out of cached mode then try the steps that fixed the other
No. I don't use cache mode in the office.
Finally, I have to create new profile for the concerned user and it seems to fix the problem. Thanks  Peakpeak for your solution. I would like to find a way to award him the point amount for the question.

However, I still don't know why old profiles were corrupted and how to avoid the profile corruption completely.

Also I user NK2view program to edit the NK2 files and discovered that there are many entries where very strange characters (like Chinese characters) were showed in the e-mail address column instead of Exchange SMTP or EX addresses. Anyone please tell me why it happened and how to solde this problem? Thanks a lot.
I deleted the profile and it fix the problem for some time. However, the problem comes back again after a day.
Help, please.
try reinstalling outlook on that machine
Is there any global solution beside dealing with local outlook?
Thanks a lot.