Link to home
Start Free TrialLog in
Avatar of Doug Fenner
Doug FennerFlag for United States of America

asked on

Cannot connect to Desktop/Server computers using Remote Web Workplace from 1 computer.

I have a Dell Precision M6300 and cannot connect to my desktop or server using Remote Web Workplace when I am connected via AT&T Wireless Card. I can connect to my desktop and server using a wired or wireless LAN connection. I can also connect to my desktop and server from other computers. I have spoken to AT&T Technical Support and they say that their network is completely "open" and therefore no ports are being blocked. I go to https://ipaddress/remote and connect to Remote Web Workplace. I logon using my network credentials. This takes me to the screen where I click on "Connect to Desktop Computers" . This takes me to the list of Network Desktops where I click on my Computer name. When I do this, I get the error. Cannot connect to remote computer. Your computer may be unavailable or too busy to take connections. Network problems may also be....

I have also tried to connect to other known good RWW networks that I administer, and that I know work fine and I get the same results with this computer only when connected via AT&T Wireless Card. AT&T has basically refused to help me further saying it is not their problem. Any advice moving forward would be greatly appreciated.
Avatar of Rob Williams
Rob Williams
Flag of Canada image

Any chance you are running Vista on it? If so there are compatibility issues with some routers/modems/networks and Vista's use of TCP Windows scaling. See:
http://www.lan-2-wan.com/RD-FAQ.htm#q1
Avatar of Doug Fenner

ASKER

Sorry I did not enter that information, the computer is running Windows XP Professional.
If they are not blocking any ports, then you should be able to do a port scan and verify that. Try using angryIP scanner and specify a few ports you know should be open, including TCP 3389, your RDP port. If it shows the port is not open then this could give you some answers.
Otherwise it could be a throughput or most likely a latency issue.
One fix often suggested by PeteLong in similar situations, and seems to be quite effective, is to enable Black Hole Detection on the RDP host server/computer. To so see the following registry addition:
1. Start Registry Editor (Regedit.exe).
2. Locate the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tcpip\parameters
3. On the Edit menu, click Add Value, and then add the following registry value:
Value Name: EnablePMTUBHDetect
Data Type: REG_DWORD
Value: 1  
4. Quit Registry Editor, and then restart the computer.
from: http://support.microsoft.com/kb/314825
We were expericing the same problem connecting to RWW over a AT&T cell data card network connection (it would get as far as the screen to select the computer you wanted to connect to, but when you tried to connect it would respond that the computer was unavailable) and the fix posted by RobWill above worked great.
I have tried all of the above solutions and none of them have worked. I had to do a wipe/reload of OS due to a memory reference error. Now I can connect to my desktop on my RWW network, but still cannot connect to the "problem" computer on the "problem" RWW network. Again,  I only experience any kind of problem when I try to connect to RWW via the AT&T Wireless card. From any other computer, on any other network, I can connect to the "problem" computer. In the Registry Edit mentioned by Rob Will, it does not say whether to make the 1 value decimal or hexadecimal, but I have tried it both ways to no avail. Still searching for solution.
Which machine did you make the regkey edit on? Was it just the SBS server or the workstation in question as well? It seems at the client we had problems with we had to add the DWORD (we used 1 decimial) to each machine that need to be accesed via RWW.  We started by adding it to the server, and we were able to RWW into it, and then we had to add it to the workstation to connect directly to it.
I edited the regkey on the Server and the laptop I am trying to connect from, but not the desktop I am trying to connect to.
Add it to the desktop you are trying to connect to, we found that made a difference.
Should change on the connecting computer, and
1 decimal = 1 hexidecimal
Right now I have the regkey on all 3 computers. Connecting From, Server, and Connecting To and the connection will not complete. Does it hurt to have the regkey on all of the computer?
ASKER CERTIFIED SOLUTION
Avatar of Rob Williams
Rob Williams
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I removed the regkey from all but the Connecting From computer. In addition to this, I was told by AT&T to turn off "Acceleration" on the Wireless Card and turned off the ByteLock Service in Windows that allows data compression when connected via Wireless Card. I can now connect to Desktop at work. Thanks to everyone for the help.
Good to hear, and thank you for posting your findings.
Cheers !
--Rob
Turning off Acceleration in the AT&T card settings worked for me.
Avatar of ewiener
ewiener

I had the same issue and just tried turning off Acceleration in the AT&T  Communication Manager:
1. Start AT&T Communication Manager (it works if its already running and connected)
2. Click Settings from the Tools menu
3. Go to the Acceleration tab and and change it from Automatic to Manual (this permanently disables autostarting acceleration).
4. Click the Stop button

You can always manually turn acceleration back on by going back to this tab and choosing Start.  You can also leave it on automatic and only turn it off when you need to use RWW RDP.