Link to home
Start Free TrialLog in
Avatar of sarpycounty
sarpycounty

asked on

ActiveSync causes OWA redirect error

We are currently running Exchange 2007 sp1 (roll-up1).  We have OWA setup on its own website to allow a purchased certificate to be used for access.   When we install the ActiveSync virtual directory (microsoft-server-ActiveSync) under this website, our OWA redirector stops working.  For example before the Microsoft-Server-ActiveSync directory is installed http://webmail.company.com is redirected via a .htm file to https://webmail.company.com/owa.  As soon as I install the Microsoft-ActiveSync directory access to any file under http://webmail.company.com gives a Page cannot be displayed message.  Typing in https://webmail.company.com/owa works, but I can't get the redirector page (or any other page) to work.  If I remove the ActiveSync directory, pages are displayed again from the http://webmail.company.com website with no problem.  

We have tried, recreating the website, removing and reinstalling the virtual directors for OWA and ActiveSync, reapplying SP1 Roll-up1 and a variety of permission/setting changes in IIS and in the Exchange manager -> server configuration-> Client Access -> Exchange-ActiveSync connector.

Has anyone see this before?
Avatar of Nuno Martins
Nuno Martins
Flag of Portugal image

How did you create the EAS directory and how are you doing the redirect?

Simon.
Avatar of sarpycounty
sarpycounty

ASKER

I created the EAS directory using this command:
new-avtivesyncvirtualdirectory -WebSiteName "WebMail"  - webmail is the name of the website we have OWA setup on.
Here is the code from the redirect. I've tried using a .asp page to do the same thing with no success when the EAS directory is installed.

<html>


<HEAD>
<META HTTP-EQUIV="Refresh"
CONTENT="1; URL=https://webmail.company.com/Owa">
</HEAD>


<title ID=titletext>Redirection</title>


<body bgcolor=white>



</body>
</html>
Sorry for the typo:  the command I used was
new-activesyncvirtualdirectory -WebSiteName "WebMail"
With regards to the redirect, that wasn't quite what I meant. How are you calling the redirect? Using the require SSL trick, just the page in the web site? Something else?

Simon.
The redirect code is in a file called redirect.htm.  I have that set as the default content page under the properties of WebMail.  Calling the page directly http://webmail.company.com/redirect.htm does not work either.

The initial page doesn't load, or it doesn't redirect correctly?

Changing the default page on the web site might have caused a problem and is not something I would have done. I would have saved the file as index.htm.

Simon.
ASKER CERTIFIED SOLUTION
Avatar of sarpycounty
sarpycounty

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial