Link to home
Create AccountLog in
Avatar of slattdog
slattdogFlag for United States of America

asked on

Why can I browse Internet sites, but not ping them?

I am able to browse the Internet and access all intranet sites just fine.  Email works great as well.  I can do pretty much everything you'd normally expect.  A ping to localhost works fine as well, but if i try to ping any other LAN or WAN addresses I just get a request timed out.  
Avatar of wjester
wjester

you probably have firewall software that is blocking ICMP packets. it's not unusual to not be able to ping internet sites (as they are often blocking ICMP also). but you should be able to ping at least your default gateway on the LAN.
Avatar of slattdog

ASKER

As mentioned, I cannot ping other LAN computers either.  I have turned off the Windows firewall and AV (just for testing purposes).  I have other PCs on the same network that can ping each other, as well as, the outside world (google.com, etc.) no problem.
can these other PCs ping you?? if not, there is something on your workstation that's dropping the ICMP packets.
Yes.  The PCs that cannot ping out are reachable (pingable) by the other computers that can ping just fine.
Just out of curiousity can you tracert from your affected computer to another in your network?
Yes.  tracert works fine to another LAN PC, but not beyond that.
I can tracert to any of the other PCs on the LAN, but not the router or anywhere beyond.  I can also tracert to the affected machines from other machines just fine.
So far I'm suspecting your router since the trace route's ICMP don't seem to pass through the router one way. Do you have any firewall or access-list configuration on your router?
Yes.  But other PCs on the same LAN segment work just fine.
I was more asking if there would be any rules on the router that restricts traffic from the affected computer so I can rule it out.
Oh, sorry.  No.  No rules that would affect only those PCs.
As far as you has this always not worked, or did you just notice it recently?
As far as I know, it has never worked on any of the 3 PCs that display this behavior.
When you ping an affected computer,does it say request timed out or  Destination host unreachable?
"Request timed out."  (It is only when I ping FROM an affected computer, not TO one.)
Try resetting winsock on an affected computer to see if theres a difference.

Start -> Run
Type in cmd and ok
type in: netsh winsock reset
restart
no difference
May as well try to rebuild everything, go to the Device Manager, scroll down to Network Adapters, expand it, right click the NIC and uninstall then restart. This will prompt windows to reinstall the nic from scratch and could get things back to normal.
Any luck with that?
No.  Still the same.  I am changing out our router (mostly due to issues with VoIP).  So far that seems to have cleared up the matter.  Although, that doesn't make any sense since if it was the router, why were only some of the PCs effected?  Anyway, thanks for the help.
My guess is the router had some firewall entry that wasn't allowing the traffic through or it could have been a bug in the router's firmware. Hard to say.
Thanks for sticking with it donmanrobb.  As much as I hate to "give up" (because it bothers me that we may never know why now) sometimes practical reality has to win out.   (In a business setting at least ;-)
Yes its always annoying not knowing the answer to something, but thats the way it goes sometmes
ASKER CERTIFIED SOLUTION
Avatar of slattdog
slattdog
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account