Link to home
Create AccountLog in
Avatar of JPaulC
JPaulCFlag for United States of America

asked on

Lost my modem and com port settings

I have been playing with computers since I had a TRS-80 many years ago. However about a lot of things I am still a newbie. I am running a Toshiba P25 S607 laptop with XP Pro SP2 and a "Toshiba Software Modem" (PCIVEN_8086&DEV_24D6&SUBSYS_00011179&REV_02). I have been trying to increase my protection against identity theft by using some anonymizing software when I surf the internet. Unfortunately in setting up one of these programs I screwed up the modem and com settings and can't figure out how to correct my mistake. The modem cannot give me a dial tone, and I get a message that com3 is not open. Can anyone tell me how to get access to the modem settings and com controls and what settings to enter or where I can find the settings I should enter? Thanks.
Avatar of Darr247
Darr247
Flag of United States of America image

In Control Panel -> Phone and Modem Options, click the Modem tab, Then the Modem tab in that window too. Ensure the volume there is turned up at least part way, set the Max. Port Speed to 115200, then move over to the Diagnostics tab. Click the Query Modem button there. If it doesn't find the modem, click the Advanced tab, then the Advanced Port Settings button. In there you can set the port to COM3, and certainly any universal asynchronous receiver/transmitter chip made in the last 15 years has first-in first-out buffers, so make sure the box is checked to enable their use and push the FIFO sliders all the way to the right. Now go back to Diagnostics and Query the modem again. If it gives a response, you have the port set correctly; if not, go back to Diagnostics and try a different port.

Once you're getting responses from it, open Hyperterminal (usually installed in Start->Programs->Accessories->Communications), make a profile with your area code if there isn't one already, and click OK. On the next screen name the New Connection ''Talk to Modem'' - click OK, then on the next screen don't type in anything... just click on the modem name that's in the bottom field and pick COM3 (or pick accordingly), click OK. On the Port Settings screen set the options to 115200, 8, None, 1, and Hardware. Click OK. In Hyperterminal proper now, click File->Save As and save your new shortcut as Talk to Modem. The default save folder for the shortcuts is Hyperterminal, in Accessories->Communications.

Type AT and hit enter. The modem should respond OK. If you can't see what you're typing, hit enter, type ATE1 and hit enter again. Now you should be able to see the AT commands as you type them. Type ATM3 [Enter], then ATH1 [Enter] and you should hear a dial tone. If you don't, check the volume control in the notification area (nee System Tray)... if it's already turned up, double-click the volume control in the tray and look for a Modem or Phone Line volume slider... if there isn't one, use Options->Properties in the Master Volume dialog, it should open on Playback controls, so scroll through the list of 'controls to show' and check the appropriate item. OK out of the Properties dialog, then uncheck the Mute box at the bottom of the Modem/Phone volume control and push its slider up until the dial tone is LOUD. Now go back to the Hyperterminal window and type ATM1. That should quiet the dial tone considerably (M1=low; M2=med; M3=loud). Then type ATH and the modem should go back onhook.
Type
AT&F [Enter]
ATS11=55 [Enter]
AT&W [Enter]

That sets the the modem to factory defaults, then the DTMF tones to 55 milliseconds each (speeds up dialing a LOT) and finally writes S11=55 to non-volatile ram so you don't need to re-enter it every time you use the modem. Unless you use the &F command again, in which case S11 will be set back to its default... If after you connect, the modem reports its connect speed as 115200, open that Talk to Modem shortcut and run
ATS95=41 [Enter]
AT&W [Enter]

Actually, any odd number should make it report the DCE rate rather than the DTE, but 41 is what I typically used. There may be other AT commands you want to add in the 'extra initialization' strings (like, for answering FAX calls, et al), but they're likely modem-dependent. Google AT commands and the brand of modem reported when you got a response for Query Modem in Diagnostics.
Whoops... prior to ''Type AT and hit enter. The modem should respond OK.'
insert
''Connect a phone line to your modem's (RJ-11) port on the computer.''
(in case it was unhooked before then.)
Avatar of JPaulC

ASKER


I thank you for you help, Darr.  I seem to have run into a roadblock.  I have gotten near the bottom of your first paragraph.  When I click Advanced Port Settings and choose a port, I click the OK button, and with only one exception so far I get the error message:  "The port has been opened by another application.   Renaming the port may have an unpredictable effect on the other application.  Do you wish to continue?"  The only exception was com4 where the error message was:  "This COM name is being used by another device (such as another com port or modem).  Using duplicate names can lead to inaccessible devices and changed settings.  Do you want to continue?"  After I got these results from the first ten ports, I began skipping by five, ten, fifty, or a hundred ports.  Admittedly I haven't tried every port yet, but every one I've tried up to the last, port 256, has given me the error messages above.  Is there any way to find out what application is using each port?  What do I do now?  Could this be the result of some malware?
Sounds like an unwanted process is disturbing your setup. You may want to check what processes are autostarted by using msconfig. Kill/block unnecessary processes or programs. Then perhaps uninstalling the modem and reinstalling the Toshiba drivers may help.
/RID
ASKER CERTIFIED SOLUTION
Avatar of Darr247
Darr247
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of JPaulC

ASKER

I have never played around in BIOS land.  Where can I find directions to get there and so as not to do any damage when I get there.
Avatar of JPaulC

ASKER

I forgot to mention that since my posting of 03 08 2008 I have uninstalled and reinstalled the modem with no improvement.
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account