Link to home
Create AccountLog in
Avatar of Bob_Griesel

asked on

Windows XP SP2 (Networked) will not stay in Hibernate mode

We are working with 5 HP/Compaq DC7600 SFF test machines that are representative samples of several hundred machines on our LAN.  We are attempting to implement power saving settings.  None of the test machines will stay in Hibernate mode for more than a few seconds if the network cable is attached.

1.  These machines MUST stay connected to the LAN, and disabling Wake on LAN is not an option.  
2.  We have been working with Verdiem Surveyor.  The surveyor server service is installed on a VMware server, and the Surveyor client has been installed on the PCs.  NOTE:  The hibernation problem persists despite the fact that Surveyor client has been removed from the PCs and the server service has been disabled at the server.  
3.  We have the Shavlik product running on our LAN, however we do not think Shavlik issues any unexpected calls to the NICs.

Thanks in advance for any answers.
Avatar of forrestoff

Hibernate mode conserves power by copying system data to a reserved area on the hard drive and then completely turning off the computer. If you plan to stay connected to the LAN and keep a valid IP with the computer, they cannot be turned off.  If the computer successfully enters Hibernation mode, it cannot be turned back on by activity (ie. wake-up requests) on the network.  If your computer is turning back on, I'd check the bios and change the wake-up option there.
Avatar of Bob_Griesel


Forrestoff - thanks for the reply.

If the network cable is pulled, or if, in Device Manager, the NIC is set to not wake the PC, then the PC stays in Hibernate mode indefinitely.  Therefore I do not think the unintended wake-up event is happening due to activity within the PC itself.

Bob Griesel
We'll if you can't disable the Wake on Lan, then I don't see any way around the problem, because this is what's starting the machine again.  There should be a complementary option in the bios that has control over this as well, and most of the time, this option is an external connector that runs from the NIC to a special place on teh motherboard (outside of hte PCI interface).  

It's almost like saying that when when you turn off your computer, you don't want it to come back on when you press the power button.

My new burning question: Is there a reason why you can't disable the WoL feature?
Regarding WoL:  This effort is aimed at saving power.  Our objective is to put most of the PCs in our network domain into a power saving mode at the end of the reguar work day.  The problem is that we must also push security patches to these PCs overnight on a regular but unpredictable basis.  The PCs must wake up for this to happen.  For some reason network activityin our domain wakes the PCs immediately.   We are searching for the reason why. There are other domains in this AD forest where thousands of PCs are managed this way using Verdiem Surveyor software (Surveyor issues the WoL instruction).   While we search for the answer, Surveyor has been uninstalled at the PC and shut down at the server.

In other words:  If Surveyor is shut down and not sending WoL, then does anyone know of other network activity that would be interpreted as WoL by the NIC?

Avatar of Netman66
Shutting down the PC is just as acceptable.  WOL will actually power up the PC from a cold power down state.

Hibernate won't work because it's triggered to wake within the OS itself not the hardware as with WOL.

As long as the NIC is set to WOL then shut them off completely.  A magic packet can be sent to turn them on about 15 minutes before you push out patches.  If necessary, you can script a full shutdown after.  

What I would do is set the patches for 5am.  Wake the PCs at 4:45am.  Leave them on after the patches so they are powered up for the employees in the morning.  This gives you a few hours to ensure they all get done.


See if you can capture anything on the lines causing the wakenings....
Avatar of giltjr
Flag of United States of America image

Link to home
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
A quick update -
The three expert comments from 3/13/08 started us down a path of further testing.  We should have better information and responses to the comments by Mon - Tue.  In the meantime . . .  

Netman66:  We are trying hard to avoid the complete shutdown.  To say that our user base includes many "special" users would be an understatement.  Still, we may end up there.  Your patch management suggestion is very close to our own thinking.  More to follow.

johnb6767:  Our top network guru intercepted network traffic and says he didn't see anything.  I think we need to return to sniffing and look for something that was missed.  Still in progress on this one.

giltjr: The HP/Compaq 7600 NICs offer the four options you suggest.  In 'Magic', the machines stay in Standby or Hibernate indefinitely, but the Verdiem Surveyor server component can't wake them from either state even tho it claims to send the Magic Packet as a wake-up call.  In 'Frame', they wake up on their own in about a minute, and the Verdiem Magic Packet does not wake them during that minute.  Oddly, when set to 'Both' the machines wake up spontaneously from Hibernate or Standby in about 5 seconds!?!

I will report back to this site as more test results and information become available.  

- Bob
If you have users that fail to log off or don't shutdown then that's easily dealt with by pushing out a scheduled task to shutdown the PCs at a time when everyone should be gone.

A simple, "shutdown /s /f" should do it.

The task can be deployed by script manually using a commandline:

schtasks /create /S %computername% /RU SYSTEM /TR "shutdown /s /t 60 /f" /SD 17/03/2008 /ST 20:00:00 /SC DAILY /TN NIGHTLY-SHUTDOWN /F

...where %computername% could be read from a list of workstation names in a text file or simply picked up during a startup script.  The /S switch could be eliminated if the startup script is used to create the task.

Well, then I would say that something is sending out ethernet frames to the computer's mac address enough times to meet the requirement for wake on lan.

Do you have managed switches?  Can mirror the port that the desktop computer is on and run a packet capture to make sure the magic packet is making it out to the computer?

It possible that something in the network is blocking/dropping the magic packet before it gets to the computer.

Better yet, if you can mirror the port just start captuering traffic to see what is being sent out on the computers switch port to see what is waking it up.
Update:  3-24-08

Following another week of testing - as time allowed - we can retire the question about PCs not staying in Standby and/or Hibernate.  

As long as the NIC's wake-up capability is set to Magic Packet, the PC will sleep.  It took a second round of tests to confirm this.

We also determined that Verdiem software was not issuing the Magic Packet.  Chalk it up to marginal documentation.  When a Magic Packet is sent. the PCs wake up.

It is still not clear why the PCs won't sleep with the NIC set to wake on Frame or Both.  Sniffing with Ethereal has not revealed much other than 'who is' queries.

The remaining issue is how to set 500 NICs to Magic Packet without visiting each workstation.  If there are any suggestions, please post.  Otherwise the question is resolved and can be closed.

- Bob
Easy, have the users bring the computers to you.  :)

O.K., so that might not be the answer you were looking for.

How are you deploying the security patches?  Couldn't you use that same method to update the NIC configuration?
See final post in series