Link to home
Create AccountLog in
Avatar of markmaske
markmaskeFlag for United States of America

asked on

What can I do to make Microstation J run like it used to

We switched from a Novell network to Microsoft and got new PC's. We copied working configs from old workstations to new ones. Now when I launch Microstation J it comes up w/a box saying it can't load some things. When I run a debug on it I see that it is not picking up my username varible. Without that it falls apart. See attached snippet and file (screenshot).
Processing macro file [p:\prefs\ustation\config\site\gsc\gscsite.cfg]
(system): HOME=p:\users\ [p:\users\]
Macro HOME locked.
(system): GSCSTD=p:\prefs\ustation [p:\prefs\ustation]
Macro GSCSTD locked.
(system): _USTN_PROJECT=p:\prefs\USTATION\CONFIG\PROJECT\ [p:\prefs\USTATION\CONFIG\PROJECT\]
Macro _USTN_PROJECT locked.
(system): _USTN_USER=$(HOME)$(USER)\ [p:\users\]
Macro _USTN_USER locked.
(system): _USTN_USERNAME=$(USER) [(null)]
(system): _USTN_USERCFG=$(HOME)$(USER)\$(_USTN_USERname).ucf [p:\users\e).ucf]
Macro _USTN_USERCFG locked.
(system): MS_USERPREF=$(HOME)$(USER)\$(_USTN_USERNAME).upf [p:\users\E).upf]
Macro MS_USERPREF locked.
(system): _USTN_USERINT=p:\users\ [p:\users\]
Macro _USER_USERINT not found, "lock" skipped.
(system): _USTN_USERINTNAME=$(_USTN_USERNAME) [E)]
Macro _USTN_USERINTNAME locked.
(system): _USTN_UIPATH=p:\users\$(_USTN_USERNAME)\;p:\users\GSC\ [p:\users\E)\;p:\users\GSC\]
Macro _USTN_UIPATH locked.

Open in new window

msj-errors.doc
Avatar of forrestoff
forrestoff

Can you post the content in gscsite.cfg?

Thanks.
Avatar of markmaske

ASKER

I have attached the Gscsite.cfg file.

Thanks

GscSite.cfg.txt
I don't know about your previous os, but in windows, the USERNAME variable points to the current username, not USER.  You could try one of two things:

Set User=%username% at this location:
[winkey+pause]-->advanced tab-->Environment Variables button-->"New" button
make the variable USER and the value %username%

or

edit your gscsit.cfg file and replace $(USER) with $(USERNAME)

that *should* solve your problem.
Thanks forrestoff, that worked for resolving the username error (gotta give you some points for that one). Now my site config file processes all the way through. However, I still am getting the same error as I attached originally (msj errors.doc) what do you think could be causing that? I have reinstalled MSJ but get the same thing. I have attached the latest debug file.

Thanks
msdebug.txt
It's clear that microstation is not finding the components baseman, dbdlglib.dll, and mgdshook.ma (whether these are files or not, is not clear--but most likely, they are).  This problem also probably happened when you installed the program on your new computer and it put these files in a different path from your previous machine.

Here's how I'd resolve it.

Find the files baseman, dbdlglib.dll, and mgdshook.ma on your previous machine.
Write down the path to those files.
Then either compare those paths to a relevent path in the msdebug.txt file to figure out what needs to change, or post it back here and I'll take a look at it for you.

Either way, (1) you probably have those files on your new machine because it's not possible to microstation to run without them, and (2) that pins the problem to an case of "old path passing" from the copying of the cfg file.  I used microstation when I was 10 yrs old (my dad worked for the texas highway department, and it was more fun than skifree from the windows 97 productivity pack).

So grab that information and we'll talk in a bit! :)
Both baseman and dbdlglib are found in the "C:\Bentley\Program\MicroStation\mdlsys\asneeded" directory on both old and new machines and do not exisit on the server. No sign of mgdshook.ma maybe it's made when these files work together?

Looking at the bottom of the debug file I see variable summary I see paths similar to where those files live on C. So still I wonder what could have changed...

Thanks
msdebug.txt
GscSite.cfg.txt
ASKER CERTIFIED SOLUTION
Avatar of forrestoff
forrestoff

Link to home
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
See answer
One more step...
I added your last line (#5) and got 'Unable to find configuration variable (MS_Userlicense)". So I added this
#-----    LICENSE FILE AND PATH  -----#
#MS_USERLICENSE = $(_USTN_LICENSING)C:/BENTLEY/PROGRAM/LICENSING/
MS_USERLICENSE = $(_USTN_LICENSING)MSJ.LIC
_USTN_LICENSING=$(GSCSTD)/LICENSE/$(COMPUTERNAME)/

And, I can get there! Fantastic!!! But this brings up one more issue, licenses files. The licenses files that we have now are computername.lic and live in C:/BENTLEY/PROGRAM/LICENSING/. Mine licenses name is msj.lic. I can set mine up to work but the others will be looking for the computername.lic. I tried this on another machine and it told me that it couldn't make changes to the username.ucf (or upf) so I will have to make sure that directory has write rights etc. Which lines above make sense to use in this case?
Sorry I have been as focused as I'd like to have been this weekend. A side from trying to fix this MSJ we made a new virtural server and upgraded to GroupWise 7 so it has been a long weekend for me.

But just to be clear, the "MS_USERLICENSE = $(_USTN_LICENSING)C:/BENTLEY/PROGRAM/LICENSING/MSJ.LIC" line works on my machine but it won't on the others because us the license name being the same as their computer name. So if you could help me w/the syntax that would be great.

Thanks,

Mark