Link to home
Create AccountLog in
Avatar of fifthelement80
fifthelement80

asked on

how to revoke a missed cert on openvpn ?

Hi,
I am using webmin to manage my openvpn certificates , someday ago I generated a certificate for a user , today I revoked his certificate using webmin , but he is still able to connect to my OPENVPN server ! I really dont know why , seems the certificate is not revoked properly.
the problem is that webmin has deleted the users certificate from the server , so I can not revoke it manually , is there a solution to revoke a missed certificate ? for example when he is connected , using management console I can revoke his certificate ?
any thoughts ?
Regards
ASKER CERTIFIED SOLUTION
Avatar of ravenpl
ravenpl
Flag of Poland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of fifthelement80
fifthelement80

ASKER

thank you for your reply , no it is not in there , seems webmin is not revoking the certs properly.
I have file 11.pem which belongs to the certificate which I want to revoke. ( I found out it from the common name of certificate which existed in 11.pem ) , is there anyway I could use this file to revoke this certificate ?
I found out why webmin is unable to revoke certs , I tried to revoke a cert manually and got the following error :
14852:error:0E065068:configuration file routines:STR_COPY:variable has no value:conf_def.c:629:line 10

I am using openssl 0.9.7a
What commands have You tried?
Thank you for your help :-)