Link to home
Create AccountLog in
Avatar of unprogram
unprogram

asked on

Cisco : Poor quality Video Conferencing over WAN

Hello, I am trying to troubleshoot poor video quality over a 2Mb WAN link (frame relay)
The video is jerky and of relatively poor quality compared to the demonstration example. The hardware is Tandberg, the ip address of the box on network A is 172.16.1.16 and on network B it is 172.16.2.105.

The cisco configs look fine to me, after some research on the internet it seems that the problem could well be autonegotiation of the ethernet ports connected to the Tandberg boxes (apparently they should be set to 100 /Full Duplex).

I would be very grateful if someone could double check these configs for me just to be more sure that it is not a QoS problem!

Thanks in advance.


Configs (only relevant information presented) :

Router A
-------------

ip multicast-routing

class-map match-all video-fr
  match access-group 107
class-map match-all video-in
  match access-group 106

policy-map PBX
  class video-in
   set ip dscp 34
  class class-default
   set ip dscp 0

policy-map LLQ
  class video-fr
    priority 384
   police cir 384000
     conform-action set-prec-transmit 6
     exceed-action drop
      violate-action drop

  class class-default
   fair-queue

interface FastEthernet0/0
 ip address 172.16.1.5 255.255.255.0
 ip pim sparse-dense-mode
 speed 10
 half-duplex
 service-policy input PBX
!
interface Serial0/0
 bandwidth 2048
 no ip address
 encapsulation frame-relay IETF
 ip route-cache flow
 no ip mroute-cache
 no fair-queue
 frame-relay traffic-shaping
 frame-relay lmi-type ansi
!
interface Serial0/0.101 point-to-point
 ip unnumbered FastEthernet0/0
 ip pim sparse-dense-mode

 frame-relay interface-dlci 101  
  class VOIPovFR
!
ip flow-export version 5
ip flow-export destination 172.16.1.71 2048
ip classless
ip forward-protocol udp 1551
ip route 0.0.0.0 0.0.0.0 172.16.1.8
ip route 172.16.2.0 255.255.255.0 Serial0/0.101

ip route 172.16.254.0 255.255.255.0 Serial0/0.101
ip http server
ip pim bidir-enable
ip pim send-rp-announce FastEthernet0/0 scope 16
ip pim send-rp-discovery FastEthernet0/0 scope 16

map-class frame-relay VOIPovFR
 no frame-relay adaptive-shaping
 frame-relay cir 2048000
 frame-relay bc 20480
 frame-relay be 0
 frame-relay mincir 2048000
 service-policy output LLQ

access-list 106 permit ip host 172.16.1.16 any
access-list 107 permit ip any any dscp af41

---------------------------------------------------------------------------------------------------------------------

Router B
-------------


class-map match-all video-fr
  match access-group 105
class-map match-all video-in
  match access-group 106

!
!
policy-map LLQ
  class video-fr
    priority 384
   police cir 384000
     conform-action set-prec-transmit 6
     exceed-action drop
     violate-action drop
  class class-default
   fair-queue

policy-map pbx
  class video-in
   set ip dscp af41
  class class-default
   set ip dscp default
!
!
!
voice call carrier capacity active
!
!
!
!
!
!
!
!
!
mta receive maximum-recipients 0
!
!
!
interface FastEthernet0/0
 ip address 172.16.2.1 255.255.255.0
 ip helper-address 172.16.1.8
 ip helper-address 172.16.1.9
 ip helper-address 172.16.1.10
 ip helper-address 172.16.1.11
 ip helper-address 172.16.1.12
 ip helper-address 172.16.1.1
 ip helper-address 172.16.1.4
 ip route-cache flow
 no keepalive
 speed auto
 service-policy input pbx
!
interface Serial0/0
 bandwidth 2048
 no ip address
 encapsulation frame-relay IETF
 ip route-cache flow
 no fair-queue
 frame-relay traffic-shaping
 frame-relay lmi-type ansi
!
interface Serial0/0.101 point-to-point
 ip unnumbered FastEthernet0/0
 ip access-group 110 out
 frame-relay interface-dlci 101  
  class VOIPovFR
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0.101
no ip http server
ip flow-export version 5
ip flow-export destination 172.16.1.71 2042
!
!
!
map-class frame-relay VOIPovFR
 frame-relay cir 2048000
 frame-relay bc 20480
 frame-relay be 0
 frame-relay mincir 2048000
 service-policy output LLQ

access-list 105 permit ip any any dscp af41
access-list 106 permit ip host 172.16.2.105 any
Avatar of unprogram
unprogram

ASKER

Does anyone think that have the ethernet ports set to half-duplex may have an effect on the video quality ??      
Avatar of Les Moore
Ethernet port needs to remain at auto as long as the switchport is also auto or an unmanaged switch.

Do you have any serial interface errors on either router? Use "show interface serial 0/0" and look for CRC and frame errors

>interface Serial0/0.101 point-to-point
> ip unnumbered FastEthernet0/0
> ip access-group 110 out
I don't see access-list 110... is it restricting anything?

What is the default gateway IP on the Tandberg? Is it the local firewall or this router?
Set the call bandwidth for 384k in the Tandberg setup on both ends
No there is no access list 110 on the config. I will  find out the details of the Tandberg unit this week.

thanks
I would remove the access-list from the interface for sure...
would the line

conform-action set-prec-transmit 6

affect the performance? Precedence 6 seems to be recommended for routing protocols only
ASKER CERTIFIED SOLUTION
Avatar of unprogram
unprogram

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account