Link to home
Start Free TrialLog in
Avatar of PatrickDoman
PatrickDomanFlag for United States of America

asked on

Remote Desktop from LAN to Vista Business fails

We have an interesting issue. We are unable to remote into a Windows Vista Business computer. A HP/Cpq Business Desktop (Brand New in Dec  2007). The unit has the NVidia chipset and a onboard intel nic. The NIC has a lot of driver features like VLAN and packet tagging etc... It is a DC7800-CMT computer. The P/N of the computer is GC758A. This should help give you information on what is in the computer.

We can remote out of the computer to other Vista and XP systems but are unable to remote into the computer from XP or Vista.
On my Velocity Micro machine I had issues with my onboard NIC almost out of the box with Vista. I had to go get a 3rd party NIC to install into the computer to get it back up and running.

From what I understand remoting into the computer has never worked.

The windows firewall is disabled.
The computer doesn't even respond to the connection. It's like the port is closed....

Is there a way that the computer firewall (windows firewall) could be blocking the 3389 connection with the windows firewall disabled?
There doesn't appear to be any other security software installed.

Remote connections ARE enabled. THe user that is logged into the computer has remote desktop access.

I have tried with VisionApp to login to the console of the computer.
I have tried with Remote Desktops on my computer.
I have tried remoting into the computer remotely through a sonicwall firewall.


The office has a single static IP.

I set the computer to forward 3389 to the internal address of the computer.

The user at the client site is on with Microsoft and they are telling her that this is an issue with their XP domain. :P
"They keep saying my XP Is the problem I can't connect because it's Xp on a domain to a Vista."

We can use applications like Logmein and other remote support apps. But I need to fix this issue. We had thought of upgrading to Vista Ultimate electronically. We're not thinking that this will resolve the issue however.

Any registry ideas? Any utilities for Vista out yet to help determine whether or not ports are responding?

I did try telnetting to 3389 and 3390 but that didn't come up with anything. Both connections failed.




Avatar of PatrickDoman
PatrickDoman
Flag of United States of America image

ASKER

I am seeing Event Log in the security log on the vista computer that says "Windows Firewall was unable to notify the user that it blocked an application from accepting incoming connections on the network.

Error Code 2
Avatar of Celteh
Celteh

If the Vista pc is on a domain, ensure that group policy is not applying the XP windows firewall settings to it, they're not compatible. On the affected Vista pc, try using the advanced firewall console to create an inbound rule for port 3389.
No domain. Only pc in office.

Connects via cat 6 to Sonicwall LAN port
Out to Business Cable modem
I disabled the Windows Firewall service
Are you on a workgroup or domain?

here are some thoughts
- Disable ip6 in side of your network connection.
- Make sure your internet connection sharing service is set to disabled.
- Try chaning the remote desktop port to 3489 and make the approprate changes into your router or firewall.
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
- If there is additional software with the network card uninstall only use the generic driver.
- If you have a lan pci card disable the integrated lan in the cmos and try the other card.
- Make sure you are not running any virus scanners which may have a firewall you are not aware of.
- make sure there is no virus scanner software which includes addition firewall features you may not be aware of.
- Try adding an individual administrative user in the remote users access list.

One of my coworkers was having issues with a sockets program that i designed. It was simply not working on his computer. It turned out that somehow the mcafee security suite product he previouly uninstalled had somehow screwed up hit tcp stack. I beleive he was able to correct the issue be installing the product and uninstalling it again.


if you are on a domain make sure to use mydomain.com\MyRDPUser format for the username.

Hope any of this helps
I changed the default listening port on the computer to 4001.
I rebooted after changing the system policy in gpedit.msc to allow remote connections using terminal services.

I went into the advanced firewall and disabled the firewall for Domain Public and Private.
No AV is loaded. Running Spysweeper and found no spyware.
Disabling IPV6


No go after changing port.

Trying to telnet into different ports to see if they are open.

Doing a Netstat -ano I don't see that 3389 is listening on the IPv4 address or the IPv6 address...
The issue appears to be that the 3389 port is not being listened to on the specific Vista machine/

I ran a netstat -ano I get the attached.

There is no port 3389 listening.
On my personal vista machine it is listening on the [::] IPv6 port but not on the IPv4. It is working fine for me though.

tcpiplistenports.jpg
If you have a SonicWall with IPS or Internet Prevention Services enabled, the Router will block this type of connection.

Try this.

Make an attempt to connect to the vista computer, obviously it will not work but this will generate a log in the SonicWall.

Open the SonicWall management and select the log.

Your blocked attempt will show up as a yellow event in the log, click this log to open a diaglog and under the option that says prevent, change it to disabled.  

All of this is assuming you have forwarded the correct ports (3389 for RDP) in the sonicwall to your local IP.  If you need addition assistance let me know.

Josh
The issue actually had to do with missing vista registry entries and the C: drive having the everyone full control right someohow on it. This question can be closed.
ASKER CERTIFIED SOLUTION
Avatar of Computer101
Computer101
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial