Link to home
Start Free TrialLog in
Avatar of mertzonj
mertzonj

asked on

I can't get this printer to communicate with the pc

I have installed the drivers for this printer, and it came with a serial cable which attaches to the printer and the other end is a USB connection which goes to the pc.  The pc shows the printer and all looks good, but no printing. I did all the Windows trouble shooting with no resolution. Reading on the Zebra website, I see some indications  that it may be easier to get it to work using a serial cable on both ends...what do you think?  I use Windows XP
Avatar of TECHLAW008
TECHLAW008
Flag of United States of America image

Did you use the latest drivers from the website or the drivers from the cd?
This can be the problem sometimes.

Also ensure that the correct USB port is selected in the port configuration.
I set one of the Zebra printers up before and they can be tempermental sometimes.

Also try removing it completely and the readding it.
Avatar of mertzonj
mertzonj

ASKER

I bought it refurb'd off Ebay...the cd that came with it was a "sealed" cd from Fed Ex,  I like to use USPS, so I went to the Zebra site and downloaded drivers from there.   Now when you say the correct USB port, what do you mean exactly, I have it on LPT1.  I thought about uninstalling it but I can't find a place to do that either...so my theory about the serial cable, you think that won't help?
according to what i see alot of these printers have usb/parallel/serial connections.

below is a picture of a normal usb cable.
if that is the one, then you need the port to be usb1 or usb2
http://www.usb-cable.com/assets/images/IMG_134745668.jpg

below is picture of a parallel cable
http://pan.fotovista.com/dev/6/5/00032956/l_00032956.jpg
if it is this one then LPT1 would be correct.

below is a picture of a usb to serial db9
http://img.alibaba.com/photo/11607331/USB_To_Serial_DB9_.jpg
if it is this use these instructions

remove the USB/serial cord from your computer
right click on my computer -> click management -> click device manager
expand the + tab next to com & lpt ports.
it should show any com existing ports.
plug in the USB/serial cord.   now look again at the ports.
you should see another port added.   Probably com5
This is the port you should use instead of LPT1.

now double click on the new port to get it's properties.
one of the tabs at the top will say Port Settings, click on this tab.
Usually you want the settings to be 9600baud, 8, none, 1, none.
another setting is 9600, 8,none,1,hardware
another setting is 9600, 7,none,1,none
another setting is 9600, 8,none,1,xon xoff

if that doesn't work you may have to purchase whats called a null modem cord to hook up your printer directly to the computers com port.
alot of new computers do NOT come with a com port so make sure on the back of the computer you have a 9 pin port.
Ok, I have the third connection you have listed (usb to serial)...couldn't I just replace that connection type with the parallel type and avoid all the instructions you have listed?  I won't be at the pc with the zebra printer until morning to try your suggestions, but just kinda of thinking ahead. Thanks for all the info!
yes.. parallel or usb would be the easiest
 parallel your already set up for and should work right off with out any changes if i'ts still on LPT1.
Ok, I was unable to locate the type of parallel cable needed for this printer, seems to be no such animal. SO anyway I went back to use the connection cable you discussed (usb to seria)l,  I did the steps and when I plugged in the usb to the pc , when I originally open the tab for ports, it showed lpt1 and com1, once I plugged the usb in no other ports appeared.  I went ahead and did the set up wizard again and set the port to Com1 ...still nothing happens when I ask it to print.  This null modem cord where can I purchase that, but also I have the option of returning the printer to the seller.   If I purchase a new one with all the correct cables maybe it will work. I think the cd he sent is outdated or incorrect.   Also when I used the set up wizard form the updated drivers I installed from Zebra site I got a Warning message about the software not having passed the windows logo testing. When I looked on the site it said for WIndows Xp to just click on continue anyway, I hope that was ok to do!
the null modem cable can be purchased at most stores, radio shack, or www.cablestogo.com.  I think i have seen them at best buy but im not sure.

if no other com ports are showing up then i would have to say either the cable is not a usb/serial cable or it is broke.  Serial/usb cables have electronics in them to convert the usb signal to serial and that could be the problem.

a null modem cable should run you about 10-20.00.

did your cable look like the pictures i showed or different?  If so which one.
the cable sent was supposed to be new one, but it also looks like the package  the new "Universal" cable came in may have contained a cd with it at some point but it didn't arrive with the package, so I am wondering if it needes this disk to work. THe cable looks like the third one you mentioned here below is a picture of a usb to serial db9
http://img.alibaba.com/photo/11607331/USB_To_Serial_DB9_.jpg,
 however the parallel end which connects to the printer is wider it has kind of a unique looking end really not exactly pins...but there is another connection available on the printer that is a 9 pin female connection available on the printer. Unfortunately the computer's 9 pin port is also female and hubby couldn't find a cable 9 pin with femle on both ends...
Regarding the Warning not to install the printer driver as it had not passed the Windows Logo Testing...I proceeded becasue the Zebra site said to continue anyway but ever since I did so my internet connection has been dragging!!!any connection here or am I just paranoid??   We are also having a tremendous snow storm maybe that's what it is...I hope if I wrecked my pc  yikes
humm... does it look like this one?
http://www.datapro.net/images/UP-100.jpg
if so this would be a usb to parallel port cord. and would require drivers.

that being said you could use a standard parallel cord with lpt1.

is there any writing/label of the model number of the cable.

the warning is not anything to be concerned about, if the manufacture doesn't pay microsoft to verify and test the driver they have that warning. So alot do have that.
Ok, yes it looks exactly like that!  If it requires drivers, then perhaps that's why I see a place for a cd to be in the connection package he sent!  And so then those drivers would be available through the maker of the cable perhaps...
The cable box says: Bafo Technologies Model Number BF-1284 and the back of the box says among system requirements is a cd rom drive, so I suspect there should have been a cd.  It is called  True PnP and Bi-directional printing USB2.0 to Parallel
You have been very helpful I appreciate your fast responses!  Can't find the Seller with a search warrant but will try calling him tomorrow.
ok, you have 2 choices,
1) buy a new usb to parallel cord
the bafco website says that item should be automaticaly reconigized by xp but sounds like it's broke.

2) buy a normal standard parallel cord.
almost any place has these, should be under 12.00
you have to make sure you have a parallel port on the back of your computer.
it will look like this: http://www.ladyada.net/images/digg/mods/Parallel_t.jpg

if so .. buy that cord plug it in and try the printer. i'm assuming the printer isn't broke but we haven't gotten to a point where thats even part of the test.
Ok, will buy one  tomorrow. I do have that parallel port on my pc.  One more question, the standard parallel cord ( that you are referring to)on the end that connects to the printer... what does it's end look like  because this printer has both the 9 pin and then that large parallel point that looks like the picture you sent me ( http://www.datapro.net/images/UP-100.jpg)   So will the standard cable have that larger end? I'll get back to you tomorrow.     I don't think the printer is defective really, but I am no expert. It did print out it's own configuration data during my attempts to get it working, so that makes me think it is functional. Thanks!
standard parallel cables look like this
http://pan.fotovista.com/dev/6/5/00032956/l_00032956.jpg

Ok, great, thanks again, talk to you tomorrow, when all is working, I Hope :)
Good Morning, I purcahsed anew printer cable, a USB Parallel Printer Adapter, looks like the one the Seller sent me. Still won't work.  The instructins that cme with this cable said to use a USB port, so since 1 and 2 are in use I used USB 3, but notta.
remove the USB/parallel  cord from your computer
right click on my computer -> click management -> click device manager
expand the + tab next to com & lpt ports.
it should show any existing ports. you mentioned com1 and lpt1.

plug in the USB/parallel cord.   now look again at the ports.
you should see another port added.   should be lpt2
change the printer to reflect that port.
Ok, I did that originally the ports listed are LPT1 and CoOm1, after I re-plug the usb back into the pc...no other ports appear... I do already have 2 regular HP printers connected to my pc...I do a lot of printing both  are very new and connect via usb, if this matters.
did the usb/parallel come with a disk?

under the device manager click the + sign and see if there is a "unknown device" or any device that has a yellow or red mark next to it.   If they do right click and uninstall them.
then right click on the top item (it will say your computer name) and click "scan for hardware changes"
to see if it will load properly.
it also could be that your computer has 1.0 usb and the usb/parallel is a 2.0 compliant.

whenever you plug in a USB item you should hear a "dun nunt" sound come out the speakers.

otherwise you may want to try the usb cord and printer on another computer.  You are looking for the computer to add a LPT port to the device manager when you plug it in.. after that then load the printer drivers.   It not adding the port is the first problem you need to overcome.
Hi, Well, I tried everything and the last option worked! I connected it to my laptop and off it went without a hitch. Now, I really, really want it connected to my desktop, which is a brand new Dell Optiplex...really "beefy"  Any clue as to what might be the problem , now?  On the laptop, I connected to USB1 which was my only option... I am sure I tried USB1 on the desktop also but it sure wouldn't print, at least we know it is not the printer.
on the desktop you may have to connect to usb2 or usb3.

keep in mind 1 thing, when you print a document, it trys to print on the port it's assigned to at the time, when you change the port that document will retry but to the first port.
so what you have to do is test print, if it does not work, clear out the print jobs so there is nothing, change the port then try again.
Ok, that makes sense. I will try again tomorrow on the desktop, and will connect to USB2 or 3, and see what happens. How can I be sure what port I am connecting to as far as 1,2, or 3 for example?  And to print a test page, should I go through the printer wizard again until I get that screen that asks Print a test page?  I really appreciate all your help,  I am sure we are close to having this resolved.  
ASKER CERTIFIED SOLUTION
Avatar of dauman
dauman
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Great, thanks...talk tomorrow.
Morning, Ok I still cannot get the desktop  work with the printer.    I deleted the zebra printer and started all over. Let me ask this, I have physically have any number of usb ports on the dell desktop,2 in the front and about 6 in the back, but when I go to device manager and click on ports only the com1 and lpt1 are visible?Yet when I go through the printer wizard and it asks which port I want to use there are all kinds of choices. So from that screen is where I have selected the USB port (tried 3, 4, 5, etc) won' t work.  Also when I initially physically connect the printer to the computer the window "New Hardware found doesn't appear.  Windows on this pc is not finding the printer,  
unless something is wrong with the dell usb's all should work fine.
when you plug into the usb reguardless of if it can install it properly or not you should hear a sound though your speakers.  You may have something going on with your usb ports themselfs since we know it works with the laptop.
Ok, but the two other printers work fine from the usbs..I even took one printer off and used that usb port for the zebra printer and still nothing...and this is a brand new computer, should I contact Dell?
Great News!!! I got it to work, I used USB 4 like you said...did that last night too, but I don't know why it didnt work then. Before I did that, I was giving up and as a last resort installed it on hubby's desk top, well it installed perfectly just like my laptop.  So I was about to call Dell and then decided "one more time" ...success. I wish I could tell you why for future reference, but I reallyl don't know why.  Thanks very much again for your determination.   Mertzonj