Link to home
Start Free TrialLog in
Avatar of RussellDull
RussellDull

asked on

After Disabling CD Roms using the method described in MS KB article 555324 Changes wont reverse

I implemented the MS solution in MS KB article 555324 to set preferences to Disable USB Drives, but also Disabled CD Roms on all domain computers by mistake as well. The solution worked wonderfully, but when trying to enable the CD Roms, nothing happens as far as I can tell. I have tried completely removing the Administrative template, simply selecting "Disable" on the preference, selecting "Enable" with the sub-option "Enable" and every other variation of options to no avail. I always do a gpupdate /force after every change and a reboot of the test machines as well, but the CD Roms simply will not show back up. In the Device manager, I get the Yellow Exclamation point telling me the drive is not working correctly and when I check the driver properties, it tells me that a policy is blocking the cdrom.sys file. Well I knew this already. That is what the preference is supposed to do, but it is also supposed to let let you enable it too. Why won't it work, and what can I do to fix it?
Avatar of janicegannon
janicegannon

Have you ran GPUPDATE /FORCE on the machine after you changed the policy?
Avatar of RussellDull

ASKER

Yep. You'll see that I stated that in my question. Unfortunately it doesn't help.
Thanks for the quick response BTW. I have 80 machined down because of this and someone is going to get very cranky if I don't find a solution soon.
Sorry, I guess I missed that part...

The article reads this;

"This template is considered a preference rather than a true policy and will tattoo the registry of client computers with its settings. If this template is moved out of scope of the Group Policy which applies it, the registry changes it makes will remain. If you wish to reverse the settings made by this template, simply reverse the options to re-enable the drivers."

Can you check the registry on a machine and see if the changes are in there? It seems that just disabling the policy isn't going to work, so you may need to edit the registry.

Test on one machine first, and if you can find the fix you can run a GP policy to change the reg settings.
I'm not really sure here, but I have tried changing the "Start" registry setting manually to 1, 3, and 4 and nothing seems to make a difference. The drive shows up in Device manager and shows to be enabled despite the Exclamation point. When I click on properties I find that the device status is "A driver (service) for this device has been disabled.  An alternate driver may be providing this functionality. (Code 32)". The drive does not show up in explorer or Disk Management either.

Could their be something elswhere that is blocking the cdrom.sys?
OK, so maybe you can go to a windows xp computer that is working and export the registry keys that are referenced in the ms kb.

Then import them into a system, restart and test.

I mean, it has to be the registry, since that is what gets changed. Maybe after you add the start setting to the reg and it disables the cdroms, the somehow it changes another reg setting, maybe where device manager info is saved.;

http://msdn2.microsoft.com/en-us/library/aa447470.aspx

maybe check a system that is working for the cdrom details and compare to yours that are not working.

Sorry I a stretching here, but you have  a hard issue here.

Also, what about system restore, is that enabled on one of these machines? Maybe you can go back to a working day and check the reg settings to see what they should be.

Good Luck
Ok. That KB article is for Windows CE 5.0. But other than that you are right. when I ran the system restore the Cd Rom came back. And now that I have the Administrative template set to "Not Configured" for CD Roms, It stays there. However, there are some systems on which I cannot do a restore (Servers and such), and frankly I don't really want spend days restoring all 80 machines. lol I have tried using WinDiff as instructed to compare the registry keys, but all it will do is tell me that one file is newer than the other. and I can't open the exported text file with notepad or anything else. The files lock up anything I try to open them with. The Bottom line is that I still haven't found a way to compare the working registry with one that doesn't work.
ASKER CERTIFIED SOLUTION
Avatar of janicegannon
janicegannon

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I'm going to go ahead and close the question. Still haven't found a good way to push the Reg Key that I need  to, but that is for another thread. Thanks for all your help.