Link to home
Start Free TrialLog in
Avatar of Badgeros
BadgerosFlag for China

asked on

Cannot start Vista Event Log / Task Scheduler Services

Running Vista Business Edition on a Lenovo Thinkpad T60P.

Noticed Diskeeper had stopped working.  On Launching message told me the service was not running.  Tried to run manually with the message "windows could not start the diskeeper service / error 1062 the service has not been started"  Reinstalling Diskeeper to not correct the problem.

On checking the event log I could not start Event Viewer because the service was not running.  Again tried manually and received  "windows could not start the event log service / error 2 the system cannot find the file specified".  The service is pointing to the svchost.exe file which of course is there.  I don't know if this may somehow be corrupted.

Further checking revealed the Task Scheduler service was not running.  Tried manually with "Windows could not start the task scheduler service / 1068 the dependency service or group failed to start"

I guess these are all somehow interrelated.

Any help would be appreciated as I really do need these services and don't want to reinstall.  Only thing I found on the web remotely connected to the above was something about file permissions though the particular problem was different.
Avatar of LeeTutor
LeeTutor
Flag of United States of America image

Well, the Task Scheduler service has as one of its dependencies the Windows Event Log service (click on the Dependencies tab of Task Scheduler in the SERVICES.MSC window and you will see that.)  In other words, in order to be able to start Task Scheduler, the Windows Event Log service must be already running.  So the more basic problem is that you cannot start the Windows Event Log service.  Here is a page I found which may be of help:

http://www.winvistaclub.com/t58.html
The Windows Event Log Service Cannot Be Started In Vista.
Avatar of Badgeros

ASKER

Correct I am aware of the interdependency of the services as explained in the original description.  Regardless I still CANNOT start the Event Log Service after following the suggestions.  

Running SFC identifies some problems that cannot be fixed but inspecting the log does not show any instances of "cannot repair member file".

I have checked the permissions on the Log Folder and that seems OK.  Though I do think this may be permission related somehow.

Furthermore I decided to check my system restore points and was again quite shocked to find "There was an unexpected error, the filename, directory name, or volume label syntax is incorrect (0x8007007B).  System restore will now close So no system restore either.  Not sure if this is related.

BTW I have run extensive virus scans, malware scans and rootkit checks...nothing!
I wonder if you would need to try Vista Repair (somewhat corresponding to XP Repair, or reinstall XP over itself)?  This page says you can do it and not lose your programs, data, etc. (although it would probably be a good idea to back up your data at least before trying it):

http://vistasupport.mvps.org/repair_a_vista_installation_using_the_upgrade_option_of_the_vista_dvd.htm
Interesting suggestion.  Though i am of course somewhat dissapointed that there is no other easier option.  If anyone does have further suggestions I would be very happy to hear them.

That said my Vista files must be on my Lenovo T60 Preload C drive.  Anyway to get to these files or indeed the repair options without an actual physical CD?
If you have a cd or dvd burner on the machine, it looks like you can burn your own recovery disks, according to this Lenovo support web page I found; otherwise, you would have to order them:

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-4M7HWZ
I am going to close this question and state it is unanswered.  Reinstalling Windows is not an answer that I could not have realised myself.

Thanks for your help in any case.
ASKER CERTIFIED SOLUTION
Avatar of Badgeros
Badgeros
Flag of China image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial