Link to home
Create AccountLog in
Avatar of boomvader
boomvader

asked on

Outlook 2007 prompts for password during Autodiscovery process.

Hello,

I need a little assistance with my transition to Exchange 2007 from Exchange 2003.

I have the following setup in my environment.  

2 Exchange 2007 CAS/HUB NLB

2 Exchange 2007 MBX in CCR mode

1 legacy Exchange 2003 server

When attempting to conifgure Outlook 2007 through the Autodiscovery process, the user is prompted to enter password to authenticate to the Mailbox (back-end) server.  Despite repeatedly entering the correct credentials, the user is still infinitely prompted.

Godaddy SAN SSL cert installed on both CAS servers.  CN same as Outlook Anywhere and OWA URL.  Autodiscover.domain.com is part of cert and resolves properly.  TCP 443 open to the outside world.  OWA, ActiveSync, and Outlook Anywhere work properly.  InternalURi set for both CAS servers as hostname.domain.com (domain.com=external domain and NOT active directory domain, which is domain.ad).
 
Any insight would be greatly appreciated.

-boom  
Avatar of isaman07
isaman07
Flag of Canada image

If the users mailbox is on the exchange 2003 server, then make sure that you don't have require SSl on your exchange 2003 server.

Regards Harout
Avatar of boomvader
boomvader

ASKER

Hi isaman07.  Thanks for your reply.  These are mailboxes residing on the 2007 mailbox server.  

-boom
A common mistake that people seem to be making is setting require SSL on the mailbox servers.

If you use the test auto discover process in Outlook, is it the autodiscover URL that is generating the prompt?
Are these clients inside or outside the network?

Simon.
Hi Simon,

I did not specifically set 'require SSL' anywhere on the mailbox server.  Is there a place I should check?

The autodiscover.ext-domain.com initally prompts for password.  I seem to successfully authenticate with it and then I am endlessly prompted for authentication by mailboxserver.domain.local, which is the back-end CCR.

All clients experiencing this issue are outside the network.

Thanks, Simon.  
ASKER CERTIFIED SOLUTION
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Simon,

Sorry for the late reply.  The problem was with the CAS and a fresh reboot magically fixed it.  Go figure.