Link to home
Create AccountLog in
Avatar of rlocone
rlocone

asked on

pptp can't resolve names

Hello All!

I have pptp setup in my dd-wrt router.  At this point I can connect to IP but not DNS names.  I know for sure that I have it pointing to the correct DNS server.  In Windows I can't even browse the network.  This was all working during my Xmas break and I was able to do everything I needed.  But this weekend I was out of town and couldn't do anything with my pptp connection.

I was reading about a static route that you have to put in.  I didn't need this before.  So I tried it still nothing.  Also, I figured out that my connection @ the hotel was 1.237 and the gate was 1.254.  Wonderful ATT & there 2wire modems.  That's why in the hotel it didn't work.  But today I'm using a Verizon connection with a 2.10 and gate 2.1.  It should work.  But it doesn't.  

Thanks,
lock
name *
proxyarp
ipcp-accept-local
ipcp-accept-remote
lcp-echo-failure 10
lcp-echo-interval 5
deflate 0
auth
-chap
-mschap
+mschap-v2
mppe stateless
mppc
ms-ignore-domain
chap-secrets /tmp/pptpd/chap-secrets
ip-up-script /tmp/pptpd/ip-up
ip-down-script /tmp/pptpd/ip-down
ms-dns 192.168.1.2
mtu 1450
mru 1450

Open in new window

Avatar of giltjr
giltjr
Flag of United States of America image

Umm, the type of connection AT&T 2-wire vs. Verizon of some sort, will not change how IP works.  IP works the same no matter what type of connection you have.

Can you ping the IP address of the DNS server you want to use?

There is a known problem, that will probably never get fixed:

     http://support.microsoft.com/?id=311218

You can go here:

     http://www.ureader.com/message/89324.aspx

And get the script that is posted.  Execute the script, then try.  If that works, then I would suggest that you execute the script before you make the pptp connection EVERY time.
Can you open a command prompt and post the output of  "route print" before and after the VPN connection is established.


--
Scott McKenzie - Nerds On Site Australia
ASKER CERTIFIED SOLUTION
Avatar of Rob Williams
Rob Williams
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of rlocone
rlocone

ASKER

Thanks for all of your responses.  So far the LMHOSTS is the only thing that worked.  Why isn't the DNS working it used to work w/o a LMHOSTS file?  Also,  browsing the network I still can't see the machines there.  
Browsing the network will only work if you have WINS servers located at both sites. This is due to the fact that browsing primarily relies on NetBIOS broad casts. Broadcast packets are not routable, and therefore cannot be routed over a VPN.
However, if the above conditions are met, especially #'s 4 & 5 I am surprised if you cannot connect by name.
Thanks rlocone.
Cheers !
--Rob