Link to home
Start Free TrialLog in
Avatar of chorlac
chorlac

asked on

Dell 4700c - failure to start after Bios upgrade.

Hi

User running Dell 4700c desktop, 3 y/o.  WinXP - Pro SP2.  

Pentium 4 Processor 540 (3.2 Ghz) with HT technology. 1GB RAM .

Machine running normally - no problems prior to this event.

User upgraded Dell Support utility, then proceeded to upgrade several software components based on recommendations from Dell Support Utility.  Upgrade included the bios, per Dell recommendation to Phoenix POM Bios Plus Ver. 1.10 A07.   Upgraded 3-4 other applications - don't remember which ones.

Hot reboot - machine operating normally.  No problems.

Next cold reboot - get major error message on black screen:

"Incompatible processor detected. System halted!"

Unable to access bios setup screen using F2.  Won't boot from Dell OEM recovery disk.  

Machine locked up.

How to recover from situation ?

How to reprogram or replace the bios PROM to previous version, or at least a version that works.

Dell techie admitted that upgraded bios installation may cause this type of hang.

Please advise.

Craig

Denver

Avatar of garethh86
garethh86
Flag of United Kingdom of Great Britain and Northern Ireland image

Generaly speaking when a BIOS flash goes bad there is no way to recover unless it has this kind of redundancy built in. The other way to fix it would be to replace the BIOS chip but I think you going to struggle with that with a laptop. I'm afraid it looks like a Dell Service Centre job. Sorry!
Avatar of chorlac
chorlac

ASKER

Thanks for the quick response.  

This is a desktop model.  

Do you thinking the bios is integral to the processor or likely a PROM that can be changed out?

Need to open it up and take a look.

Dell techie recommended changing the motherboard,  which seems extreme for the problem.  

Craig
 
There is a tool you can use for popping out the BIOS chip and replacing it (or if your feeling really brave you can try it with an assortment of small screwdrivers like I've had to do before)
http://www.bioschip.com/remove_dip.html

You might be able to get the chip from here:

http://bios-repair.co.uk/bios/preflash.htm

Would certainly be cheaper than buying a new board. Obviously this would invalidate your warranty (if you leave any fingerprints behind).

Best of luck!
Avatar of chorlac

ASKER

Thanks for the suggestions.

My swiss army knife is sharp and ready to pop the prom.

Cheers

Craig

Be carefull when removing it, make sure all power is disconnected and that you remove it level, edge by edge, the connectors are easily damaged.
Could you just remove the coin shape battery first? and try again to toot and access bios page. If you can get bios page, there is a chance then.


http://support.dell.com/support/edocs/systems/dim4700c/en/SM/parts.htm#wp1059875
Avatar of Gary Case
As noted already, a bad BIOS flash is a "catastrophic" event --> it turns your motherboard into a paperweight.

It IS possible to buy a new BIOS chip and replace just the chip ... but put your Swiss army knife away until you inspect your board.   While there are still some boards with socketed BIOS chips; many now have these soldered in place.   If that's the case, you'll need either a DIP-desoldering tool or SMD soldering gear.   If that's the case, it's much easier to just replace the motherboard, especially if you don't have experience with multiple-contact desoldering equipment (either DIP or SMD).

Replacing the motherboard is a simple task ... and at e-bay prices you can do that for not much more than you'd pay for a new BIOS chip:  http://cgi.ebay.com/Dimension-4700-Socket-775-System-Board-Dell-DH682_W0QQitemZ260215189121QQcmdZViewItem

HOWEVER ... just to be sure this isn't a simple case of corrupted CMOS data that's causing the halt, before you do anything else unplug the system;  remove the CMOS battery for a few minutes (5 minutes is plenty);  then replace the CMOS battery; plug the system in; and see if the symptoms change.
Every Dell board I have worked with has socketed BIOS chips, especially this one being 3 years old. Also the ebay image shows the bios chip in the top left corner socketed. This isn't curropted CMOS data either, but give the battery removal a try. Either the wrong BIOS bin has been applied or the flash was unsuccessfull in some way.
Glad Dell's among the still-using-sockets crowd.   My initial thought was also that it was clearly a bad flash;  but the comment that the system worked fine AFTER the flash ["... Hot reboot - machine operating normally.  No problems."]  indicates it may not be quite that absolute.   It certainly won't hurt to completely clear the CMOS by removing the battery and see if that changes anything.


you can always try these guys :
http://www.recoverybios.com/                                    replace bios
http://www.badflash.com/                                        "          "
http://bioschips.nlan.org/                                    bad bios chip
Certainly wouldn't hurt to try clearing thge CMOS. I believe the reason the machine worked after the first reboot is because it wouled have been flashed through windows and would require a hard reboot to apply the changes. I have seen this problem before with incorrect CPU type but this usually indicates that the wrong BIOS bin has been applied.

You could also try calling Dell and see if they will repair it free of charge. I've had a lot of success with Dell in the past swapping and repairing parts even when they are not at fault, this has always been trough business accounts though, don't know how lucky you would be if you are a regualr end user.
Avatar of chorlac

ASKER

Removed the battery, waited 5 min, reinstalled battey,
Same problem, full halt - Incompatible Processor - error.

Does the state of charge in the battery affect the flashing of the BIOS prom?

The Bios chip is the Dip type.

Some websites mention that Dell does not supply the bios chip, therefore you are forced to get the motherboard.   Sound right to you guys?

 



 
No, the state of the battery doesn't have any impact on the flashing.

A socketed DIP BIOS chip is good news => you can simply buy a replacement chip pre-programmed with the correct BIOS.

Not sure why Dell doesn't sell replacement BIOS chips ... probably just to ensure that the motherboard and BIOS absolutely match (which is clearly true with a replacement motherboard).   Considering that a new chip is ~ $30 and a replacement motherboard (via e-bay) is ~ $40 I'd be tempted to simply replace the board --> or at least buy the board and use the BIOS chip from it [Then you'd have a spare motherboard for $10].

Yeah, the website I mentioned before should have one or something extemely similiar.

http://bios-repair.co.uk/bios/preflash.htm

http://www.motherboard-biosflash.co.uk/

The battery wont affect flashing the BIOS, this just holds CMOS data when the machine is switched off - time/date,BIOS settings etc.
another thought, get all details off the BIOS chip on your board and run a search in google, or post it here and I'll see if I can find it.
Another possibility r.e. why Dell doesn't sell replacement BIOS chips --> Dell's license with Microsoft provides for BIOS-locked activation for XP, Vista, etc.   This means the OS does not require activation, since it is tied to the BIOS identification string.   This MAY require that the BIOS & motherboard be sold together.
ASKER CERTIFIED SOLUTION
Avatar of garethh86
garethh86
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I ran into this issue the other day while updating a Dimension 4700C motherboard with A02 BIOS to A07 and I'd like to clear up some misunderstandings and/or misinformation about this issue.

Ill preface my explanation with some background information. Ive had some integration experience and although Im no BIOS expert I have had some experience with customizing system BIOSs and therefore the information I am supplying is from both past experience and my observations of this issue with the Dimension 4700C BIOS upgrades.
 
The exact error message appears as follows:
Alert! Incompatible processor detected.
System halted!

The message is displayed about half way down the screen following some BIOS Post information (Dell Copyright info., BIOS version info).

In my case the update (started from within Windows) finished as expected during the reboot/flash with an Update Successful message.

The subsequent reboot indicated the BIOS was at an A07 level and Windows ran fine, as I continued to install updates and new software during a fresh reload of Windows XP Pro.

It wasnt until I powered the system down and rebooted the next morning that the alert message appeared.

Several posts, including this one, have referred to this issue as a bug and/or Bad Flash situation. This isnt the case and is in fact exactly what the error message indicates, at least in my situation, an Incompatible processor. That is BIOS updates A06 and A07 dropped support for my particular processor or possibly several other processors.

In my case the motherboard I have has a Pentium 4, 3.40Ghz, 800Mhz FSB, 1M L2 Cache processor (processor ID = 0F34). This ID refers to half a dozen processors of different clock speeds.

Removing this processor and installing a Celeron 3.20Ghz processor allowed the board to function at all levels of the BIOS from A02 thru A07. I downgraded the BIOS to A02, reinstalled my 3.40Ghz processor and upgraded one BIOS level at a time until I reached A06 at which the alert message reappeared indicating Dell/Phoenix dropped support for my processor at version A06. Why? Well if I recall there is only so many CPUIDs that can be stored in a particular BIOS so they have to choose the most popular or in Dells case they may have chosen to drop support for the oldest processors in lieu of support for newer models. I then reapplied A04 (with the Celeron install) and my 3.40Ghz worked fine.

It is my opinion that since these processors had already shipped in this board at some point it was a serious lapse in judgment by someone at Dell to allow subsequent BIOS updates to be released without support for a previously shipped product! Or was it?

Since this issue has been around since at least 2005 when A06 was released, it would lead one to believe this may have been intentional. Think about it, the board is now about 4 years old, how better to force people to upgrade then to INOP their motherboard (which is out of warranty) with a simple BIOS upgrade! Unlikely, hmm let me continue&

After reading several posts about this issue and discovering that a lot of responses were you have to replace the motherboard I started looking for a replacement and what do you think I found, dozens for sale on eBay and even more from other wholesale companies.

I also found several posts about newer boards exhibiting the same error during BIOS updates.

I then called Dell support and as expected their response was that the board was out of warranty and I could buy a new one from their parts division and/or a new PC! They went on to try to explain it was my fault for upgrading directly from A02 to A07! Which as Ive explained was NOT the case, go figure Dell overseas support accusing the customer of wrong doing and not even understanding the issue themselves, now thats never happened!

Not to mention IF this was the case wouldnt it be prudent to note this in the release notes as a prerequisite or better yet put a check in the BIOS update program to prevent users from updating to a newer BIOS which would INOP their motherboard!

Sloppy Dell, very sloppy! Now I know why so many people are unhappy with Dell on the consumer front (the business side isnt that much better, believe me!) Ive been running into more and more people that flat out wont buy a Dell due to poor support (outsourcing) and situations such as this BIOS botch. Ive always liked the look and feel of a Dell (not including the new shiny Inspirons) and the ease of locating the correct drivers and/or system information on their support website, however due to their decline in customer support I am seriously considering looking elsewhere!

Daveinfla
Avatar of chorlac

ASKER

Dave,

I agree with your observations and hats off to you for going the distance to trouble shoot the problem.

After being a polite pain in the zxvx!#, I got pretty good tech support from the Escalated Service Desk at their Small Business Group. Even Dell had a time maching a processor to the MB! Their guy was OK and very frank about the situation and sent parts as needed w/o cost to trouble shoot the problem

I suspect they probably built in some planned obselesence (sp) in their system.

In the end I still could not get it to work.

So rather than consume more time on it, I just harvested the old hard drive, stuck it in a enclosure and run it off  another computer.

So good marks for the customer service bad marks for their management of BIOS updates and their older processor compatibility!  

Thanks for your comments.

Craig
Denver
I have done the same thing. OOPS. Now i rendered it useless. I was wondering the model number of the processor you used to make it post with A07 so i can put it back to A02?
Dave in Florida? You said you used a celeron 3.2 Do They all work in this bios A07?
Thank you in advance
Daveinfla => Excellent info.   I agree that Dell has superb support on their web site -- easy access to documentation and drivers for virtually all of their systems ... but it's inexcusable that they would delete support for CPU's from a BIOS update and not note that in the release notes.  [Or better yet on the actual download page ... some of us are religious about reading release notes, but many folks do not]

Luckily you had an older CPU you could use to isolate exactly which BIOS version you could upgrade to.
Ahhhhh..........I actually got lucky and got a CPU to borrow and did a swap for 5 minutes and i was able to revert back to A02. Sweet. I used and Intel P4 640 Prescott. Booted up and just reverted back to A02 restarted and then shut it down. Then i swapped the CPU's back and she is running fine again. I wish Dell would put the listed processors under the compatibility page before you download it to see if it works with your machine. Whats best is that i actually used my service tag number so they would definitly know my configuration and it shows i can download the A07 bios. The kicker is that Dell wanted like 50 dollars to tell me they couldn't help me. I refuse to pay them money when every other manufacture gives free tech support like Asus or EVGA. My original CPU that was dropped from A05 bios on to A07 bios is the Intel P4 530.