Link to home
Start Free TrialLog in
Avatar of bombipiece
bombipiece

asked on

Banner message has the incorrect Domain Name for HELO Response

When I try and change the FQDN in the default connector for response to HELO I receive the following error. I need to change the local domain to my external company domain. This is running on an Exchange Hub Server.

When the AuthMechanism parameter on a Receive connector is set to the
value ExchangeServer, you must set the FQDN parameter on the Receive
connector to one of the following values: the FQDN of the transport
server " exchhub.domain.com ", the NetBIOS name of the transport
server " exchhub ", or $null.
Avatar of murgroup
murgroup
Flag of United States of America image

Try this article. You must configure the send and recieve connectors in Exchange 2007. I assume your running everything on one server.

http://msexchangeteam.com/archive/2006/11/17/431555.aspx
Avatar of bombipiece
bombipiece

ASKER

The Hub server is seperate from my clustered mainbox servers. I am unable to configure the FQDN that is used during a HELO to the Hub server. The error I posted is what I receive when attemping to change the FQDN used in response to HELO in the default Receive Connectors under Server Configuration --> Hub Transport.
I usually create a new receive connector in addition to the default. You can call it whatever you like and put the FQDN on the general tab. Then under permission groups you should only check anonymous users. This will resolve the error you are getting.
This will not remove the internal IP and server name from your email headers. Simon explains it in this article:
https://www.experts-exchange.com/questions/22373847/Exchange-2007-has-its-Private-IP-in-SMTP-header-Security-Issue.html?anchorAnswerId=18562668#a18562668
If you are using exchange 2007 it is important that you state whether you are changing a SEND Connector or a RECEIVE Connector.

If you have been running some tests on the domain then Exchange 2007 will now fail some of those tests, because it is gives out different information for inbound email compared to outbound email. The only one you need to worry about is the Send Connector, which is for outbound email.

Exchange 2007 SP1 installation actually checks the Receive Connector to ensure that it is one of the required settings. The receive connector should be set to either the server's FQDN, Netbios name or blank. Changing it to something else may well cause problems.

Simon.
I am running Exchange 2007 SP1 hence the reason why I am unable to change the domain to be the external and receiving the error when I try. Is there a way around this since this will cause issues if an email is sent to a server that is checking reverse DNS.
ASKER CERTIFIED SOLUTION
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial